Pourquoi Firefox essaie-t-il d'utiliser Gedit pour ouvrir des fichiers .deb

27

J'utilise Firefox 15 sur Ubuntu 12.04.

Si je vais sur un site Web avec un lien .deb , Firefox télécharge le fichier, puis tente de l’ouvrir avec gedit . Si j'utilise Nautilus pour ouvrir le fichier .deb , il l'exécute dans gdebi ou dans le centre logiciel Ubuntu (j'ai expérimenté les deux).

Bizarrement, peu importe ce que j'ai fait, je ne peux pas croire que Firefox ne doit pas être ouvert par gedit . Voir ci-dessous de mon mimeapps.list . De plus, il n'y a aucune référence à mes fichiers .deb dans /usr/share/applications/defaults.list

    
posée Kendor 07.09.2012 - 16:25
la source

6 réponses

14

Firefox a également sa propre liste d'applications. Vérifiez Preferences- & gt; Applications, puis trouvez les fichiers Debian. Il dit probablement "Toujours demander" à côté si vous n'avez rien changé. Si vous cliquez sur "Toujours demander", vous pouvez sélectionner "Utiliser autre" et choisir le centre du logiciel Ubuntu ou Synaptic ou tout ce que vous souhaitez (bien que vous deviez malheureusement utiliser le moteur de recherche pour accéder au fichier de l'application) , ce qui peut être un léger désagrément). Le logiciel Ubuntu est en /usr/bin/software-center et gdebi peut être trouvé dans /usr/bin/gdebi-gtk .

    
réponse donnée SMeznaric 07.09.2012 - 17:56
la source
16

J'ai aussi eu ce comportement avec Firefox. Il ouvrait des fichiers PDF, .DOC, .DOCX, etc. avec Gedit. Très ennuyant. Peu importait que la liste Applications de Firefox spécifiait LibreOffice, Evince, etc., car l'application préférée UNLESS , je cliquais sur le lien "Afficher tous les téléchargements" en bas du menu des téléchargements (dans le firefox).

Pour résoudre ce problème , j'ai ouvert .local/share/applications/mimeapps.list et supprimé l'association de application/octet-stream avec gedit.desktop . Faire cela restauré le comportement normal / prévu.

Cela met clairement en évidence un bogue dans Firefox, à savoir que parfois utilise sa liste d'applications, mais pas toujours (à partir de la version 35.0.1 sur Ubuntu 12.04).

    
réponse donnée jdpipe 27.04.2015 - 02:32
la source
13

Il existe des programmes par défaut xdg-open et gnome-open qui sélectionnent automatiquement l'outil approprié pour un fichier.

J'ai réussi à découvrir que ça suffit pour changer d'association pour un type inconnu et que tout fonctionne bien.

Solution

Tout ce dont vous avez besoin BEGIN

sed 's#.*octet-stream.*#application/octet-stream=gnome-open.desktop#' ~/.local/share/applications/mimeapps.list -i

END

Je suis arrivé à cette conclusion en utilisant find, ubuntu-tweak- inotifywatch

    
réponse donnée test30 03.09.2014 - 16:58
la source
0

Cela se produit car certains packages interrompent vos liaisons d'application de type MIME.

Je suis pareil et j'ai supprimé le fichier de liste dans mon répertoire personnel, mais cela ne durera que lorsque vous aurez à nouveau mis à jour le logiciel à l'origine de ce problème.

Pour résoudre le problème, vous devez définir les applications pour le type MIME en conséquence. Les paramètres de /usr/share/applications/defaults.list doivent être corrects.

Vous remarquerez que ces fichiers ".desktop" se trouvent dans / usr / share / applications /; vous pouvez en utiliser et y créer vos propres privilèges root.

    
réponse donnée thecarpy 19.03.2014 - 11:30
la source
0

Pour ajouter au premier message de SMeznaric: j'ai vérifié les préférences de Firefox et les deux entrées deb étaient déjà le centre du logiciel ubuntu. Une solution de contournement consistait à remplacer l’option par défaut par «save file», car au moins cela fonctionne. En cliquant dessus dans le dossier des téléchargements de Thunar, vous fonctionnerez normalement et vous aurez une copie dans un endroit logique (plutôt que / tmp / mozilla-firefox0)

    
réponse donnée dez93_2000 17.02.2016 - 21:58
la source
0

J'ai eu ce problème, ainsi que la fenêtre Préférences- & gt; Applications de Firefox étant totalement vide.

Est-ce que ce qui suit a été:

sudo apt-get remove --purge firefox
sudo apt-get install firefox

Il a corrigé les deux problèmes (pour le moment, je le vérifierai s'il se reproduit) et tous mes paramètres et plugins sont toujours intacts.

    
réponse donnée George Agathos 20.08.2016 - 21:53
la source

Lire d'autres questions sur les étiquettes