Comment puis-je faire en sorte que gnome-shell traite les deux moniteurs de la même manière?

29

Gnome-shell semble aimer laisser un moniteur "fixe" lorsque vous changez d’espace de travail.

De plus, il n'y a pas de prévisualisation dans la vue Activités de mon moniteur secondaire.

Sur le deuxième moniteur, où il doit y avoir un espace de bureau vide ou une copie du panneau, je n'ai qu'une barre blanche.

Comment puis-je obtenir que gnome-shell traite mon moniteur secondaire comme le moniteur principal?

    
posée Alex 18.10.2011 - 18:20
la source

5 réponses

16

14.04

Dans les versions ultérieures de Gnome, vous devez ouvrir gnome-tweak-tool et, sous "Espaces de travail", modifier le paramètre "Espaces de travail uniquement sur l'affichage principal".

    
réponse donnée Rory 10.12.2014 - 09:31
la source
12

En ce qui concerne le second moniteur fixe, il existe un moyen simple de résoudre ce problème, comme je viens de le découvrir. Si je peux citer:

  
  1. Téléchargez gconf-editor - ceci est probablement disponible dans le gestionnaire de paquets de votre distribution.
  2.   
  3. Lancez gconf-editor - le menu "Exécuter la commande" est toujours disponible dans GNOME 3 en appuyant sur Alt-F2.
  4.   
  5. Dans l’arbre de gauche, accédez à / desktop / gnome / shell / windows
  6.   
  7. Cochez la case à côté de workspaces_only_on_primary
  8.   

Source: lien

    
réponse donnée Martin Matysiak 04.11.2011 - 21:55
la source
10

Je n'ai pas trouvé la clé / desktop / gnome / shell / windows mentionnée par Martin, mais la source citée dit:

$ gsettings set org.gnome.shell.overrides workspaces-only-on-primary false

Cela a corrigé instantanément pour moi. Merci, Gregor (la source).

    
réponse donnée ringe 20.12.2013 - 07:38
la source
1

Vous pouvez le faire en installant Tweaks GNOME à partir du logiciel Ubuntu. Après l'installation, il apparaît dans le tiroir d'applications sous la forme Tweaks . Le nom du package s'appelle en réalité gnome-tweak-tool .

L'option que vous recherchez se trouve dans l'onglet Espaces de travail et s'appelle Affichages d'espaces de travail .

    
réponse donnée philsf 01.10.2017 - 00:48
la source
0

Mon Ubuntu 18.04 avec l'unité a le même problème.
En utilisant le gconf-editor proposé par Martin , la case que je dois désélectionner se trouve à /org/gnome/mutter/workspaces-only-on-primary .

    
réponse donnée HD189733b 08.05.2018 - 20:18
la source

Lire d'autres questions sur les étiquettes