bluetooth oreillette se connecte mais ne s'affiche pas dans les paramètres sonores

29

J'ai pu écouter avec mon casque BT, mais soudainement, un jour, il a disparu des réglages du son pour toujours!

J'ai même re-couplé mon oreillette (et sa connectée déjà) mais il n’a aucune option dans les paramètres sonores pour pouvoir l’écouter.

Lorsque j'essaie cette commande:

hcitool scan

Il ne trouve aucun appareil! Même cette commande:

pactl list cards short

Ne répertorie que ma carte son par défaut uniquement! Que dois-je faire?

    
posée Hossain Alhaidari 11.06.2014 - 21:08
la source

5 réponses

28

Essayez cette commande:

sudo -H pactl load-module module-bluetooth-discover

Je lance ceci chaque fois que je me suis associé, et connecté avec succès, mais ne peut toujours pas les voir dans les paramètres sonores. Il indique essentiellement à pulseaudio de charger la liste des périphériques Bluetooth. "

    
réponse donnée Tim 11.06.2014 - 21:21
la source
7

Le kit oreillette est correctement apparié et s'affiche sous Périphériques Bluetooth, mais il ne s'affiche pas comme source d'entrée / de sortie disponible pour l'audio. Le problème est que le module bluetooth pulseaudio est chargé avant X11, en changeant quelques fichiers de configuration, faites le tour:

PulseAudio ne peut pas charger le module Bluetooth 15.10 / 16.04

nano /etc/pulse/default.pa

Commentez les lignes suivantes:

#.ifexists module-bluetooth-discover.so
#load-module module-bluetooth-discover
#.endif

nano /usr/bin/start-pulseaudio-x11

Trouvez les lignes suivantes et ajoutez-les après:

if [ x”$SESSION_MANAGER” != x ] ; then
/usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
fi
Ajoutez les lignes suivantes:
/usr/bin/pactl load-module module-bluetooth-discover
/usr/bin/pactl load-module module-switch-on-connect

De cette façon, les modules Bluetooth de l'audio pulsé ne seront pas téléchargés au démarrage, mais après le démarrage de x11.

    
réponse donnée Mark 28.12.2016 - 01:58
la source
5

La solution permanente consisterait à ajouter le blueman PPA et à mettre à jour votre paquet avec la dernière version corrigée du bogue: lien

sudo add-apt-repository ppa:blueman/ppa
sudo apt-get update
sudo apt-get upgrade

De cette façon, vous ne devriez plus avoir à exécuter le

sudo -i pactl load-module module-bluetooth-discover

commande à chaque fois mais une seule fois. Fonctionne pour moi sur 14.04 LTS (Trusty)

Source

    
réponse donnée Louis Gagnon 26.11.2015 - 17:09
la source
4

Je ne suis pas en mesure de commenter la réponse du haut, mais je pensais ajouter que sur mon ordinateur portable Ubuntu MATE 12.04 LTS, je devais le faire:

sudo apt-get install pulseaudio-module-bluetooth

seulement alors fait ce travail

sudo -i pactl load-module module-bluetooth-discover

Ensuite, je devais aller dans l'appli Bluetooth Manager, jumeler l'appareil, puis régler sur le mode 'Audio Sink', puis je pouvais voir le périphérique dans les options Ubuntu Sound et manipuler les entrées / sorties!

    
réponse donnée adowdy 20.11.2015 - 02:55
la source
4

Etendre la réponse de Mark, qui a essentiellement fait l'affaire pour moi.

Le problème est que le service Bluetooth essaie de charger le module bluetooth pulseaudio au démarrage, ce qui échoue car il nécessite que X11 soit en cours d'exécution. Vous devez changer la configuration pour que le module bluetooth pulseaudio soit chargé après X11.

  1. Dites au service Bluetooth de ne pas charger le module. Pour ce faire, éditez /etc/pulse/default.pa et mettez en commentaire ces lignes en mettant les caractères # devant eux:

    .ifexists module-bluetooth-discover.so
    load-module module-bluetooth-discover
    .endif
    
  2. Configurez le module à charger après X11. Pour ce faire, éditez /usr/bin/start-pulseaudio-x11 et ajoutez deux lignes:

    if [ x"$DISPLAY" != x ] ; then
        # ...
    
        # Add these lines:
        /usr/bin/pactl load-module module-bluetooth-discover
        /usr/bin/pactl load-module module-switch-on-connect
    fi
    
  3. Redémarrez pulseaudio et bluetooh . Redémarrez votre ordinateur ou utilisez les commandes suivantes:

    pulseaudio -k
    start-pulseaudio-x11
    sudo service bluetooth restart
    

Ainsi, le module Bluetooth pulseaudio devrait fonctionner et Volume Control ( pavucontrol ) devrait détecter le périphérique Bluetooth et le répertorier sous les périphériques d’entrée et de sortie.

    
réponse donnée danijar 01.02.2018 - 14:55
la source

Lire d'autres questions sur les étiquettes