Pourquoi est-ce que je reçois une erreur "type fs incorrect, mauvaise option, mauvais superbloc"?

117

Lors du montage d’un répertoire NFS en faisant:

sudo mount 192.168.1.5:/home/shared /mnt/common

Je reçois l'erreur suivante:

mount: wrong fs type, bad option, bad superblock on 192.168.1.5:/home/shared, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program)  
In some cases useful info is found in syslog - try dmesg | tail or so.

Le noyau est à jour.

La question a déjà été posée (par exemple ici et ici ), mais ne répond pas ou que les réponses ne vous sont pas utiles mon cas.

Qu'est-ce qui ne va pas?

    
posée Arseni Mourzenko 17.09.2014 - 18:03
la source

6 réponses

141

Le message d'erreur mentionne:

  

(pour plusieurs systèmes de fichiers (par exemple, nfs, cifs), vous pourriez avoir besoin d’un programme d’aide / sbin / mount.)

Ceci est pertinent étant donné que vous essayez de monter NFS. Le programme /sbin/mount.nfs helper est fourni par nfs-common . Vous pouvez l'installer avec:

sudo apt install nfs-common

D'autre part, si vous essayez de monter CIFS, le programme d'aide est fourni par cifs-utils . Vous pouvez l'installer avec:

sudo apt install cifs-utils
    
réponse donnée muru 17.09.2014 - 18:18
la source
57

Assurez-vous que mount.cifs est répertorié dans /sbin :

ls -l /sbin/mount.cifs

Vérifiez si le package cifs-utils est installé:

dpkg -l cifs-utils

Si ce n’est pas le cas, installez les librairies cifs avec

sudo apt-get install cifs-utils
    
réponse donnée Ely 09.10.2014 - 15:59
la source
18

Il semble que nfs-common package devrait être installé pour pouvoir monter des répertoires NFS.

sudo apt-get install nfs-common

Si ce n’est pas le cas, le montage d’un répertoire NFS entraîne l’erreur que j’ai eu.

    
réponse donnée Arseni Mourzenko 17.09.2014 - 18:03
la source
2

J'avais ce même problème dans Ubuntu 14.04 LTS. J'ai essayé d'installer le package nfs-common sans succès.

J'ai pu résoudre le même problème que vous aviez:

  1. Aller à l’application "disques" de Linux.
  2. Cliquez sur le lecteur USB que j'essayais de monter dans la section des périphériques (fenêtre à gauche).
  3. En cliquant sur plusieurs actions sous la section de partition du système de fichiers Volumes (deux petits engrenages à droite des signes moins / plus).
  4. Cliquer sur les options de montage (en haut de la fenêtre des options de montage).
  5. Cliquer pour activer les options de montage automatique.
  6. Cliquez ensuite sur le bouton de montage (+ signe sous les volumes) - cela devrait changer en carré.

Ceci a monté mon lecteur USB et a résolu le problème.

    
réponse donnée Jamildoit 07.03.2015 - 11:52
la source
1

Essayez:

mount -t nfs 192.168.1.5:/home/shared /mnt/common
    
réponse donnée Minos 09.10.2014 - 16:23
la source
1

Je l’ai résolu en installant virtualbox. Faire

sudo apt-get install virtualbox-guest-utils

Il installe mount.vboxsf

    
réponse donnée Zhihan Jiang 09.04.2015 - 04:22
la source

Lire d'autres questions sur les étiquettes