Impossible d'installer Google Chrome. Comment je le répare?

31

Je ne peux pas installer le navigateur Google Chrome. Je me demande pourquoi et comment le réparer. Voici le journal que j'ai reçu de mon terminal lors de l'installation de Google Chrome.

$ sudo dpkg --install chrome.deb
[sudo] password for young: 
Selecting previously unselected package google-chrome-stable.
(Reading database ... 141861 files and directories currently installed.)
Unpacking google-chrome-stable (from chrome.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libgconf2-4 (>= 2.27.0); however:
  Package libgconf2-4 is not installed.
 google-chrome-stable depends on libnss3-1d (>= 3.12.3); however:
  Package libnss3-1d is not installed.
 google-chrome-stable depends on libxss1; however:
  Package libxss1 is not installed.

dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Errors were encountered while processing:
 google-chrome-stable

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  linux-headers-3.5.0-17
Use 'apt-get autoremove' to remove it.
The following packages will be REMOVED:
  google-chrome-stable
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 140 MB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 141960 files and directories currently installed.)
Removing google-chrome-stable ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...

$ sudo dpkg --install chrome.deb
Selecting previously unselected package google-chrome-stable.
(Reading database ... 141861 files and directories currently installed.)
Unpacking google-chrome-stable (from chrome.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libgconf2-4 (>= 2.27.0); however:
  Package libgconf2-4 is not installed.
 google-chrome-stable depends on libnss3-1d (>= 3.12.3); however:
  Package libnss3-1d is not installed.
 google-chrome-stable depends on libxss1; however:
  Package libxss1 is not installed.

dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Errors were encountered while processing:
 google-chrome-stable

Cela ne fonctionne pas aussi dans l'interface graphique. Regardez ce que j'ai:

    
posée owl 23.11.2012 - 15:51
la source

6 réponses

30

Vous devez probablement activer le référentiel "universe".

Une fois que vous l’activez, mettez à jour votre système et vous devriez maintenant pouvoir installer google-chrome-stable .

sudo apt-get update
sudo apt-get install libgconf2-4 libnss3-1d libxss1
    
réponse donnée jokerdino 24.11.2012 - 14:02
la source
50

Vous pouvez résoudre ce problème en installant des dépendances manquantes.
Lancez simplement la commande suivante
(après avoir exécuté sudo dpkg -i google-chrome-stable_current_i386.deb ).

sudo apt-get install -f

Cela va installer les dépendances manquantes et configurer Google Chrome pour vous.

    
réponse donnée Vineet 02.02.2013 - 17:26
la source
9

Pourquoi ne pas installer Chromium à partir des dépôts Ubuntu?

sudo apt-get install chromium-browser

C'est simple!

    
réponse donnée smooth-texan 23.11.2012 - 16:55
la source
1

sudo apt-get update ; sudo apt-get install libgconf2-4 libnss3-1d libxss1

Publiez toute erreur ici. Si aucune erreur, sudo dpkg -i chrome.deb encore après et vous devriez être bon.

    
réponse donnée Jim Salter 23.11.2012 - 16:21
la source
0

J'ai récemment vu cette erreur et j'ai pu le résoudre en utilisant ce qui suit:

apt-get install libcurl3
    
réponse donnée Snap Shot 04.01.2015 - 12:00
la source
0

J'ai eu le même problème et je l'ai utilisé pour y remédier.

sudo apt-get update
sudo apt-get upgrade
sudo apt -f install

Ensuite, essayez d’installer à nouveau Google Chrome.

    
réponse donnée Anamitra 27.06.2017 - 15:57
la source

Lire d'autres questions sur les étiquettes