Comment désactiver le raccourci global Super-p?

30

Dans Ubuntu 11.04, il y avait une solution de contournement en utilisant gconf-editor et la clé de réglage /apps/gnome_settings_daemon/plugins/xrandr/active à false.

Cependant, gconf-manager n’utilise pas de clé utilisant ubuntu 11.10 (gnome 3).

    
posée Dovydas Sabonis 18.10.2011 - 05:00
la source

5 réponses

19

La nouvelle version de gnome-settings-daemon stocke ses informations de configuration dans dconf plutôt que gconf .

Pour faire l’équivalent de ce que vous faisiez le 11.04, essayez ce qui suit:

  1. Installez le package dconf-tools , puis exécutez dconf-editor .
  2. Dans l’arbre de gauche, naviguez sur org - & gt; gnome - & gt; settings-daemon - & gt; plugins - & gt; xrandr .
  3. Décochez la case active .
réponse donnée James Henstridge 18.10.2011 - 06:54
la source
8

Pour désactiver les raccourcis globaux <Super>p et NON toute autre clé multimédia (testée dans Ubuntu 15.04 ), je devais ' Emtpy 'les clés dconf suivantes. J'ai couru (dans un terminal):

dconf write /org/gnome/settings-daemon/plugins/media-keys/video-out ''
dconf write /org/gnome/settings-daemon/plugins/media-keys/screenshot ''

Avant, je recherchais avec les commandes bash suivantes les valeurs contenant '<Super>p' :

b="/org/gnome/settings-daemon/plugins/media-keys/"
for i in 'dconf list $b | sort'; do echo -n "$i: "; dconf read $b$i; done

Pour rechercher toutes les clés dconf , utilisez la commande:

dconf dump / | grep '<Super>p'

Si vous souhaitez éviter le terminal, exécutez le programme dconf-editor et recherchez la ou les clés là-bas ...

Modifier:

Après quelques mises à jour et redémarrages, le raccourci clavier ne fonctionnait plus. J'ai trouvé, qu'il y avait / était un bug dans gnome-settings-daemon qui définit <Super>p . Un hack est décrit ici .

Dans le processus de démarrage, /usr/bin/xbindkeys_autostart est exécuté lors de la connexion. Ce script recherche le fichier dans $HOME/.xbindkeysrc et charge les paramètres.

Comme je voulais mapper gnome-screenshot -c à <Super>p , j'ai créé ce fichier avec le contenu suivant (et non mappé les paramètres dans ubuntu / compiz): ​​

# Content of $HOME/.xbindkeysrc
"gnome-screenshot -c"
mod4 + p
    
réponse donnée setempler 13.02.2015 - 18:50
la source
7

Ceci est toujours un problème avec Ubuntu 12.10 publié le 18 octobre 2012. un correctif de bogue pour cela semblait être dans les travaux de sorte qu'au moins il existe un moyen plus facile de reconfigurer les raccourcis clavier, mais il a depuis été marqué comme invalide car il était censé avoir été corrigé dans gnome-settings-daemon .

En fin de compte, ce problème est dû à certains fournisseurs de matériel qui codent en dur la vidéo sur Super-P .

Il y a eu des conversations mises à jour sur le suivi des bogues depuis réponse actuellement acceptée suggérant de ne pas désactiver xrandr, mais de désactiver les clés de média :

Essayez ce qui suit:

  1. Installez le package dconf-tools , puis exécutez dconf-editor .
  2. Dans l’arbre de gauche, naviguez sur org - & gt; gnome - & gt; settings-daemon - & gt; plugins - & gt; media-keys .
  3. Décochez la case active .

Ou la version de ligne de commande de ceci est:

dconf write /org/gnome/settings-daemon/plugins/media-keys/active false

    
réponse donnée aculich 26.01.2012 - 04:05
la source
3

Sur Ubuntu 18.04 , j'ai trouvé deux raccourcis différents pour SUPER + P , qui peuvent être désactivés avec dconf-editor .

D'abord, vous devez installer dconf-editor , s'il n'est pas déjà installé. Cela peut être fait dans le terminal avec la commande suivante:

sudo apt install dconf-editor

Ensuite, vous pouvez le lancer depuis le terminal:

dconf-editor

Dans dconf-editor :

  • Accédez à: / org / gnome / mutter / keybindings / switch-monitor
  • Si le champ "Valeur personnalisée" contient ['<Super>p', 'XF86Display'] , alors:
    • Désactiver "Utiliser la valeur par défaut"
    • Dans le champ "Valeur personnalisée", tapez ce qui suit: []
  • Accédez à: / org / gnome / settings-daemon / plugins / media-keys / video-out
  • Si le champ "Valeur personnalisée" contient '<Super>p' , alors:
    • Désactiver "Utiliser la valeur par défaut"
    • Dans le champ "Valeur personnalisée", supprimez tout.
réponse donnée David 22.05.2018 - 03:15
la source
2

Même si la désactivation du plugin xrandr ne fonctionne pas pour vous (comme moi), je vous suggère d’essayer (cela fonctionne pour moi):

Allez dans l'éditeur dconf via la commande "dconf-editor" dans un terminal, puis allez sur:

/org/gnome/mutter/keybindings/switch-monitor

et désactivez "use default value" et supprimez:

'<Super>p',
    
réponse donnée Kailackous 24.10.2017 - 11:04
la source

Lire d'autres questions sur les étiquettes