Comment puis-je me débarrasser du message "kvm: désactivé par le BIOS"?

28

Je reçois un message:

kvm:disabled by bios

après la mise à niveau de mon noyau vers 3.8.x. Je n'ai jamais installé le package KVM. Je ne peux pas non plus activer la virtualisation à partir de mon BIOS, à cause d’un bogue du BIOS. Je veux juste me débarrasser de ce message étrange. J'ai essayé de supprimer tout module du noyau en utilisant modprobe mais cela n'a pas fonctionné.

    
posée Anam Ahmed 02.03.2013 - 19:52
la source

4 réponses

13

Créez un fichier appelé /etc/modprobe.d/blacklist-kvm.conf :
(Par exemple, vous pouvez utiliser gedit gksu gedit /etc/modprobe.d/blacklist-kvm.conf ou nano sudo nano /etc/modprobe.d/blacklist-kvm.conf )

Mettez-y les trois lignes suivantes:

blacklist kvm
blacklist kvm_intel
blacklist kvm_amd

Je ne suis pas sûr que cela fonctionne pour vous, car je n'ai pas de système adapté également désactivé par le BIOS. Mais c'est une manière raisonnable de désactiver KVM sur Debian ou Ubuntu, vous devriez donc essayer de voir si cela fonctionne aussi pour désactiver votre message.

    
réponse donnée Robie Basak 26.06.2013 - 11:28
la source
16

Qu'est-ce qui a fonctionné pour moi:

1) Allumez l'ordinateur et appuyez sur f2 pour voir le BIOS lorsque vous voyez un écran avec un arrière-plan noir.

2) Allez dans l'onglet "Configuration".

3) Sélectionnez l’option "Intel Virtual Technology" et activez-la en appuyant sur F5 ou F6.

4) Appuyez sur F10 pour enregistrer et quitter. Lorsqu'un message vous invite à confirmer cette action, sélectionnez oui.

5) Votre ordinateur s’éteindra pendant 10 secondes. Ensuite, il démarrera et chargera votre système d'exploitation sans afficher cette erreur.

    
réponse donnée pablofiumara 03.11.2013 - 08:05
la source
4

Tout d’abord, vous voudrez peut-être voir si KVM est chargé dans le noyau. Pour ce faire, exécutez quelque chose comme ceci:

lsmod | grep kvm

Si vous obtenez une réponse, vous voudrez peut-être empêcher kvm de fonctionner. Pour ce faire, cela aidera:

modprobe -r kvm

N'oubliez pas de suivre pour tout autre module kvm. Dans mon cas, il y a aussi un module kvm_intel , donc je dois aussi courir

modprobe -r kvm_intel

Pour empêcher que kvm soit activé au démarrage, vous devez rechercher le fichier situé sur /etc/modules et le modifier pour que KVM ne se lance pas au démarrage. Après avoir modifié votre fichier /etc/modules , redémarrez votre ordinateur et vérifiez si le problème persiste.

    
réponse donnée NlightNFotis 26.06.2013 - 09:42
la source
0

Vous pouvez soit supprimer kvm

sudo apt-get purge qemu-kvm

ou ignorer ce message, il ne fait de mal à rien.

Peut-être existe-t-il une mise à jour de bios?

    
réponse donnée Panther 02.03.2013 - 19:55
la source

Lire d'autres questions sur les étiquettes