Pas de sortie audio HDMI - APLAY ne détecte pas le GPU NVIDIA

2

Lorsque je connecte la configuration de mon cinéma à domicile à un nouveau HP Omen 15 avec Linux Mint 18.2, il n’est pas possible de régler la sortie audio sur HDMI, malgré le bon fonctionnement du signal vidéo.

Autre questions pas été utile / réussi.

C'est principalement le problème de ce billet de forum et aucune des solutions proposées n'a fonctionné.

PulseAudioVolumeControl n'indique qu'un seul périphérique pour lequel sélectionner des profils (il s'agit de l'audio intégré). Malgré tout, il y a une profusion de profils HDMI que je peux choisir pour cela.

Aucun, mais le réglage analogique standard fonctionne.

L'installation de oem-audio-hda-daily-dkms ne change rien.

L'utilisation des pilotes NVidia plus récents ne change rien.

aplay -l donne:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Le GPU n'apparaît pas sous la carte 1, contrairement à d'autres versions résolues de ce problème.

Le GPU n'apparaît pas non plus dans alsamixer .

Je n'ai trouvé aucun moyen de faire reconnaître les pilotes NVidia HDA.

Modifier: Sinon, le problème peut être qu'il ne s'agit que de périphériques PCH dans la sortie aplay et pas de périphériques HDMI réels ... mon ancien ordinateur portable MSI ne montre pas non plus de carte NVidida, mais de cartes Intel HDMI et PCH dans aplay -l, et avec celui-ci (également Linux Mint 18.2), le son HDMI fonctionne sans problème.

    
posée polymachine 22.09.2017 - 16:38
la source

2 réponses

3

Peut-être pertinent :

For some reason, a lot of recent laptops are set up to boot with the GPU's PCI audio function disabled. I haven't done much investigation, but you can turn on the audio function and make the kernel see it by setting the appropriate PCI configuration bit and then telling the kernel to rescan the PCI bus on the PCI bridge the GPU is connected to.

Unfortunately, the kernel won't see the audio function unless you remove the graphics function first, which temporarily breaks the console. Because of that, it works best if you write a script to do it so you don't have to SSH into the system or try to type the commands into the console blind. Obviously, you have to stop the X server first so that you can unload the NVIDIA drivers.

For example, on my system, the GPU is at 01:00.0 and its parent PCI bridge is 00:01.0. So the script I use is:

setpci -s 01:00.0 0x488.l=0x2000000:0x2000000
rmmod nvidia-drm nvidia-modeset nvidia
echo 1 > /sys/bus/pci/devices/0000:01:00.0/remove
echo 1 > /sys/bus/pci/devices/0000:00:01.0/rescan
modprobe nvidia-drm
xinit -- -retro

You can figure out your PCI topology with "lspci -t" but interpreting the results is pretty tricky.

Aaron Plattner
NVIDIA Linux Graphics

    
réponse donnée 27.09.2017 - 11:38
la source
1

L'audio HDMI provient de l'audio intégré et votre commande aplay -l les répertorie déjà. Vous semblez avoir 3 ports HDMI de sortie, alors assurez-vous d’avoir choisi le bon port de sortie HDMI. Vous semblez avoir Intel HD Audio, pas NVidia HD Audio, bien que dans la plupart des cas, le chipset audio provienne d’un fabricant tiers.

Ce que j’ai trouvé, c’est d’exécuter alsamixer, d’appuyer sur F6, de sélectionner HDA ou autre (dans votre cas, ce serait Intel HDA ou autre), puis de faire défiler jusqu’à S / PDIF et de l’activer. S / PDIF 0 est activé, mais vous devez également activer S / PDIF.

Dans pavucontrol, accédez à l'onglet Configuration, puis dans Audio intégré, sélectionnez Sortie stéréo numérique.

    
réponse donnée 19.05.2018 - 17:26
la source

Lire d'autres questions sur les étiquettes