nautilus se connecter au serveur via ssh n'est plus présent dans Ubuntu 14.04

26

Je viens de passer à ubuntu 14.04 et je constate que la connexion à un autre serveur via SSH ne fait plus partie de l’environnement nautilus. Quelqu'un peut-il me diriger comment réactiver cette fonctionnalité.

merci, Wayne

    
posée Wayne Gregori 28.04.2014 - 02:05
la source

8 réponses

33

Il est toujours là dans "Fichiers> Connect to ..."

Entrez sftp://[email protected]/folder/ et vous devriez être prêt à partir.

    
réponse donnée Jo-Erlend Schinstad 28.04.2014 - 03:23
la source
10

terminal ouvert

ctrl + Alt + T

tapez:

nautilus-connect-server

Entrez votre adresse IP ssh:

ssh://youripaddress

Entrez votre nom d'utilisateur et votre mot de passe:

Vous avez terminé: Après une connexion réussie, vous verrez comme ceci:

J'espère que cela vous aidera.

    
réponse donnée Anuj TBE 15.08.2014 - 14:42
la source
6

Le problème

Lorsque vous tentez d’accéder à un système de fichiers distant via sftp in nautilus (entrez ^ L pour accéder à la barre d’emplacement, entrez sftp://[email protected]/export/dumps/client/user/ comme uri, le répertoire de travail en cours est ajouté: /home/user/sftp:/[email protected]/.. et erreur message ( /home/user étant le répertoire de travail en cours):

**Unable to find the requested file. Please check the spelling and try again.**
Unhandled error message: Error when getting information for file '/home/user/sftp:/[email protected]/...': No such file or directory.

Réponse courte

Au moins sur mon système, il semble que sshfs n’a pas été installé lors de la mise à niveau vers 14.04. Vérifiez s'il est installé:

apt-cache policy sshfs

Pour moi, l’installer:

sudo apt-get install sshfs

résolu le problème. (Vous devez redémarrer tout le bureau gnome pour que cela devienne efficace, vous pouvez donc tout aussi bien redémarrer après l’avoir installé si vous êtes sur un ordinateur de bureau sans vous soucier des temps d’arrêt et des fonctionnalités du serveur)

Le point de menu pour accéder à un serveur distant (qui se trouvait dans le menu File ) est maintenant visible dans le volet de gauche sous Réseau - Connexion au serveur . Il est également possible d'entrer un URI ( sftp://[email protected]/path ) dans la barre d'emplacement qui s'affiche lorsque vous appuyez sur Ctrl + L .

Réponse longue

Je me suis battu contre ce problème sous un autre angle (voir [la méthode ssh deja-dup ne fonctionne pas - écrit localement à la place] [1]) et trouver la raison de la mauvaise conduite mystérieuse m'a plongé dans les profondeurs de

  • gvfs
  • sshfs
  • fusionner

Processus de débogage:

essayer de monter via gvfs:

% gvfs-mount sftp://[email protected]/export/dumps/client/home/user
Error mounting location: volume doesn't implement mount

Si l'utilisateur n'est pas celui qui exécute le bureau actuel , gvfs-mount doit être précédé de dbus-launch :

dbus-launch gvfs-mount sftp://[email protected]/export/dumps/client/home/user

pouvoir monter le répertoire distant. Cependant, cela ne semble pas permanent, nous avons donc tous les éléments liés à gvfs dans un même shell:

dbus-launch bash
gvfs-mount sftp://[email protected]/export/dumps/client/home/user
[email protected]:~$ gvfs-mount -l
Drive(0): ST320LT020-9YG142
  Type: GProxyDrive (GProxyVolumeMonitorUDisks2)
Volume(0): 5,4 GB Volume
  Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
Volume(1): Nexus7
  Type: GProxyVolume (GProxyVolumeMonitorUDisks2)
Mount(0): user on server -> sftp://[email protected]/
  Type: GDaemonMount
nautilus &

Il semblerait que gvfs ait monté le répertoire personnel distant de user au lieu du chemin absolu demandé. Même si /export obtient un / supplémentaire pré-calculé. Dans le nautilus appelé dans la dernière ligne, un URI pointant vers le chemin absolu souhaité peut être saisi et monté une fois le problème sous-jacent résolu.

Essayer de monter via sshfs:

Dépendances supplémentaires (incomplètes):

  • L'utilisateur doit être membre du groupe fuse . Testez avec: grep <username> /etc/group , s'il est manquant: sudo usermod -a -G fuse <user> . Avec un groupe sans mot de passe, l'utilisateur doit se déconnecter / se reconnecter pour que cette modification prenne effet.
  • gvfs-backend doit être installé

(à suivre)

[1]: méthode ssh deja-dup t fonctionne - écrit localement à la place . Vérifiez avec apt-cache policy gvfs-backend

    
réponse donnée Tatjana Heuser 03.05.2014 - 13:03
la source
4

Vous pouvez également entrer:
ssh: // adresse IP

Par exemple:
ssh: //192.168.1.4

La boîte de dialogue qui en résulte vous demandera le nom d'utilisateur et le mot de passe sur la machine à laquelle vous essayez de vous connecter et vous donnera des options sur la manière de mémoriser le nom d'utilisateur et le mot de passe.

    
réponse donnée user275419 28.04.2014 - 17:09
la source
2

Vous pouvez le faire avec Nemo. Commencez par installer la version sans dépendances (ouvrez une fenêtre de terminal avec Ctrl + Alt + T et tapez):

sudo add-apt-repository ppa:webupd8team/nemo
sudo apt-get update
sudo apt-get install nemo nemo-fileroller

Lancez Nemo et, dans le menu Fichier , sélectionnez Se connecter au serveur , ce menu a l'option SSH dans type de serveur .

    
réponse donnée Mike 15.01.2015 - 12:24
la source
2

Dans les nouvelles versions du gestionnaire de fichiers Gnome, Nautilus (& gt; Ubuntu 16.04), cette fonctionnalité a été déplacée vers un nouvel emplacement:

  • Ouvrez le gestionnaire de fichiers
  • Cliquez sur Autres emplacements
  • Au bas de la fenêtre, vous verrez une boîte de dialogue de connexion

En cliquant sur la marque, vous obtiendrez des exemples sur la manière d’entrer dans le serveur et sur les protocoles pris en charge.

    
réponse donnée mniess 29.01.2018 - 17:18
la source
0

La réponse est

Entrez votre adresse IP ssh:

sftp: // youripaddress

pas ssh: // youripaddress

    
réponse donnée raspel 19.08.2014 - 15:56
la source
0

Veuillez d'abord vérifier votre paquet gvfs-backends .

$ dpkg -l | grep gvfs-backends
ii  gvfs-backends

S'il n'existe pas, installez-le s'il vous plaît.

$ sudo apt-get install gvfs-backends
    
réponse donnée Chu-Siang Lai 31.10.2014 - 10:30
la source

Lire d'autres questions sur les étiquettes