Comment réparer plymouth (écran de démarrage) dans toutes les versions d'Ubuntu!

26

Comment réparer le plymouth noir (écran de démarrage) noir ou cassé après l'installation des pilotes propriétaires nvidia dans Ubuntu (cela se produit généralement dans toutes les versions d'Ubuntu)? Quelle que soit la version des pilotes nvidia que j'installe, le bug est toujours présent.

    
posée Nolt 21.10.2013 - 00:18
la source

3 réponses

43

Voici une solution pour résoudre le problème de l'absence de plymouth (écran de démarrage) dans Ubuntu après l'installation d'un pilote propriétaire nVidia. Peu importe la version d'Ubuntu que vous utilisez, elle devrait fonctionner de toute façon.

Ouvrez votre terminal et tapez

sudo apt-get install v86d

Alors

sudo -H gedit /etc/default/grub

Trouvez cette ligne

#GRUB_GFXMODE=640x480

et changez pour celui-ci ( bien sûr choisissez votre résolution )

GRUB_GFXMODE=1440x900
GRUB_GFXPAYLOAD_LINUX=keep

Remarque: Vous pouvez essayer GRUB_GFXMODE=1440x900x24 , mais méfiez-vous de la spécification de la profondeur de couleur. Vous devez spécifier une valeur prise en charge. Si ne fonctionne pas alors plutôt le supprimer. Plus d'informations dans le manuel .

Notez également que les anciennes cartes graphiques Nvidia nécessitent la propriété GRUB_GFXMODE au format <width>x<height>-<depth> (par exemple 1920x1200-24 , mais pas 1920x1200x24 ).

Enregistrer le fichier et taper le terminal

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u
sudo update-grub

Cela a fonctionné pour moi dans toutes les versions d'Ubuntu. Essayez-le:)

    
réponse donnée Nolt 21.10.2013 - 13:07
la source
5

Si la solution ci-dessus ne fonctionne pas, vérifiez que $ vt_handoff est utilisé dans le fichier /boot/grub/grub.cfg

Dans le fichier, recherchez la ligne commençant par:

linux   /boot/vmlinuz ...

dans la section appropriée du menu de démarrage (par exemple, première occurrence de cette ligne si vous souhaitez restaurer l’écran de démarrage pour la première option de démarrage du menu grub) et assurez-vous que cette ligne se termine par

... quiet splash $vt_handoff

Voici l'exemple dans mon cas (ligne commentée remplacée par une deuxième ligne), remplacez le xxxx par l'UUID existant de la partition de démarrage:

#   linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=xxxx ro   nmi_watchdog=0
    linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=xxxx ro   quiet splash $vt_handoff
    
réponse donnée eosphere 19.10.2014 - 18:03
la source
1

Les pilotes Nvidia proprietarty ne prennent pas en charge KMS, jusqu'à récemment. KMS est nécessaire pour que Plymouth (écran de démarrage) fonctionne. C'est un problème de Nvidia (pas d'ubuntu canonique). Je vous recommande de le laisser comme ça (cela n'affecte pas votre utilisation quotidienne) et d'attendre nvidia 364.12 ou plus récent dans le dépôt Ubuntu. Avec nvidia 364.12 plymouth works.

Si vous êtes impatient, vous pouvez utiliser ceci:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-364
    
réponse donnée john9983 17.07.2016 - 11:10
la source

Lire d'autres questions sur les étiquettes