Quels paquets dois-je installer pour ffmpeg et libmp3lame?

25

Sur mon bureau Ubuntu 10.4, j'utilise ffmpeg pour convertir des vidéos dans un format que mon lecteur de DVD comprend. Sur mon ordinateur portable fonctionnant en 10.10, je ne parviens pas à utiliser la même commande, quels sont les paquets manquants?

ffmpeg -i infile.flv \
-threads 2 -vcodec mpeg4 -vtag divx -acodec libmp3lame \
outfile.avi

#...snip
Unknown encoder 'libmp3lame'

En utilisant apt-cache search libmp3lame , on m'a dit qu'il existait libmp3lame0 et libmp3lame-dev, les deux que j'ai installés. Utiliser acodec libmp3lame0 ne fonctionne pas non plus.

    
posée matt wilkie 17.11.2010 - 22:58
la source

3 réponses

39

sudo apt-get install ffmpeg libavcodec-extra-52

Si le paquetage est introuvable, essayez:

sudo apt-get install ffmpeg libavcodec-extra-53

vous pouvez également essayer d’installer le package libmp3lame0 :

sudo apt-get install libmp3lame0
    
réponse donnée danizmax 17.11.2010 - 23:11
la source
8

Installez l'encodeur en exécutant la commande suivante

sudo apt-get install libavcodec-extra-53
    
réponse donnée user262028 25.03.2014 - 21:01
la source
0

Essayez ceci, Ouvrez le gestionnaire de paquets Synaptic et réinstallez ffmpeg. Essayez également d'installer winff dans Synaptic, cela vous donnera une interface graphique pour ffmpeg. Modifier... Voir aussi lien pour l'ajout de "libavcodec-extra-52, libavutil-extra-49 et libavformat-extra- 52 du dépôt multivers "

    
réponse donnée deleted 16.01.2011 - 20:59
la source

Lire d'autres questions sur les étiquettes