Comment arrêter de clignoter constamment les LEDs WiFi?

26

J'ai un Dell E6510 et après l'installation d'Ubuntu et la connexion à un réseau sans fil, mon voyant Wifi continue de clignoter, probablement en réponse au trafic.

Cela est vraiment ennuyeux car cela attire toujours l’attention de l’écran. Y a-t-il un moyen de désactiver cette fonctionnalité et de laisser le Wi-Fi rester allumé en permanence tant qu'il dispose d'une connexion wifi?

Voici mon lspci pour le wifi:

Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
    
posée Stefan Thyberg 08.11.2010 - 13:22
la source

4 réponses

23
  1. Ouvrez le terminal:

    Applications & gt; Accessoires & gt; Terminal ou Ctrl + Alt + t

  2. Entrez les informations suivantes dans le terminal:

    gksudo gedit /etc/modprobe.d/wlan.conf
    
  3. Copiez et collez la ligne ci-dessous:

    options iwlcore led_mode=1
    
  4. Enregistrez le fichier.

  5. Redémarrez l'ordinateur portable.

Ceci est un bogue connu: Bogue n ° 250211

    
réponse donnée Sid 08.11.2010 - 14:28
la source
33

Désactivation du voyant DEL pour les cartes sans fil Intel (et certaines cartes Atheros)

  

Remarque: basée sur une étude approfondie de tous les pilotes sans fil du noyau (c.-à-d. sans-fil compatible , seules les cartes Intel et un module de prise en charge des chipsets Atheros permettent de contrôler le comportement des voyants). le code de contrôle dans la plupart des pilotes est assez simple, donc si vous avez une connaissance de base du C, de la construction de modules du noyau et de la lecture occasionnelle des fiches, il est assez facile de désactiver le clignotement des LED pour presque toutes les pilote source.

  • Appuyez sur Alt + F2 et tapez gksudo gedit /etc/modprobe.d/iwled.conf (ou ouvrez ce fichier dans votre éditeur préféré)
  • Ajoutez la ligne options MODULE_NAME led_mode=1
    • MODULE_NAME est répertorié ci-dessous pour votre version Ubuntu et votre modèle de carte
    • Remplacez led_mode par l'option appropriée si elle est indiquée, pour les cartes Intel 2200BG / 2900ABG ou Atheros
  • Enregistrez et quittez l'éditeur; redémarrer

1. Ubuntu 13.04 (Ringtal Ringtail) - série de noyau 3.8

  • iwlwifi pour les séries Intel Centrino Wireless-N 1xx, 1xxx, 2xx, 2xxx, 5xxx, 6xxx
  • iwlegacy pour la série Intel Wireless 3945 (testée), 4965
  • ipw2200 avec led=0 pour Intel Pro / Wireless 2200BG, 2915ABG
  • ath9k avec blink=0 pour les cartes sans fil Atheros utilisant le pilote ath9k

2. Ubuntu 12.04 (Precise) - série de noyaux 3.2

  • iwlwifi pour les séries Intel Centrino Wireless-N 1xx, 1xxx, 2xx, 2xxx, 5xxx, 6xxx
  • iwl-legacy pour la série Intel Wireless 3945, 4965
  • ipw2200 avec led=0 pour Intel Pro / Wireless 2200BG, 2915ABG
  • ath9k avec blink=0 pour les cartes sans fil Atheros utilisant le pilote ath9k

3. Ubuntu 11.10 (Oneiric) - série de noyau 3.0

  • iwlagn pour les séries Intel Centrino Wireless-N 1xx, 1xxx, 2xx, 2xxx, 5xxx, 6xxx
  • iwl-legacy pour la série Intel Wireless 3945, 4965
  • ipw2200 avec led=0 pour Intel Pro / Wireless 2200BG, 2915ABG
  • ath9k avec blink=0 pour les cartes sans fil Atheros utilisant le pilote ath9k

4. Ubuntu 11.04 (Lucid) - série de noyau 2.6

  • iwlcore pour les séries Intel Centrino Wireless-N 1xx, 1xxx, 2xx, 2xxx, 3945, 4965 , 5xxx, 6xxx
  • ipw2200 avec led=0 pour Intel Pro / Wireless 2200BG, 2915ABG
  • ath9k avec blink=0 pour les cartes sans fil Atheros utilisant le pilote ath9k

5. Ubuntu 10.04 (Lucid) - série de noyau 2.6

  • La valeur par défaut pour les cartes Intel Centrino prises en charge au 10.04 est de simplement garder le voyant allumé si le réseau sans fil est activé (et désactivé), donc ce "mod" ne devrait pas être nécessaire (merci htorque!)
  • ipw2200 avec led=0 pour Intel Pro / Wireless 2200BG, 2915ABG
  • ath9k avec blink=0 pour les cartes sans fil Atheros utilisant le pilote ath9k
réponse donnée ish 30.07.2012 - 07:15
la source
3

Je crois que 'problem' ne peut être résolu par Ubuntu lui-même. Il est tout à fait normal que les LED d'activité clignotent sur le trafic (la LED HD devrait faire la même chose). Ils travaillent directement au niveau du matériel, en contournant le système opérationnel.

Mon conseil est d’utiliser un petit morceau de ruban adhésif pour couvrir la LED:)

    
réponse donnée OpenNingia 08.11.2010 - 13:27
la source
0

Dans mon E6510, le fichier s'appelait /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

J'utilise Ubuntu 11.04 et modinfo iwlcore montre qu'il existe un paramètre led_mode , donc cela fonctionne bien.

    
réponse donnée Peter Torpman 07.02.2011 - 10:17
la source

Lire d'autres questions sur les étiquettes