webex ne fonctionne pas dans Ubuntu 14.04 Help Help [duplicate]

26

webex ne fonctionne pas dans Ubuntu 14.04. Dois-je installer java 32bit et fire fox pour que cela fonctionne? Existe-t-il une option dans le 64 bits lui-même?

    
posée Eldho 03.05.2014 - 05:05
la source

7 réponses

21

Enfin, cela a résolu pour moi

Installez Oracle Java pour résoudre ce problème

Appuyez sur Ctrl + Alt + T sur votre clavier pour ouvrir une fenêtre de terminal. Quand il s'ouvre, copiez et collez la commande ci-dessous et appuyez sur Entrée. Saisissez votre mot de passe utilisateur à l’invite pour ajouter le référentiel PPA à votre système.

sudo add-apt-repository ppa:webupd8team/java

Après cela, mettez à jour les listes de paquets via:

sudo apt-get update

Pour installer Oracle Java 8, exécutez:

sudo apt-get install oracle-java8-installer

Modifiez le nombre 8 à 6 (ou 7) dans le code pour installer Java 6 (ou 7).

Lors de l'installation, il vous sera demandé d'accepter la licence, puis le programme d'installation commencera à télécharger le fichier Java depuis le site Web d'Oracle et à l'installer sur votre système.

Pour définir le Java par défaut, exécutez:

sudo apt-get install oracle-java8-set-default

Remplacez également le numéro 8 par la version Java souhaitée.

    
réponse donnée Eldho 04.06.2014 - 20:05
la source
18

Pour ceux qui utilisent le partage de bureau ne fonctionne pas dans Ubuntu 14.04 64 bits

  1. Vérifiez le répertoire de base existant de webex

    $ ls $HOME/.webex
    1670
    
  2. Commençons à partir de zéro

    $ rm -r .webex/
    
  3. Redémarrez Firefox et lancez une réunion

    $ ls $HOME/.webex 
    1530
    
  4. Vous pourrez démarrer une session, lancer une discussion, mais le partage de bureau peut ne pas fonctionner. Trouvez ensuite les bibliothèques manquantes:

    ldd $HOME/.webex/1530/*.so >>check.txt
    
  5. grep les lignes "introuvable":

    $ grep "not found" check.txt | sort -u
    libgtk-x11-2.0.so.0 => not found
    libgdk-x11-2.0.so.0 => not found
    libXmu.so.6 => not found  ---------------->>>
    libXtst.so.6 => not found
    libjawt.so => not found  ----------->>>
    libXmu.so.6 => not found
    libpangoxft-1.0.so.0 => not found
    libXft.so.2 => not found
    libpangoft2-1.0.so.0 => not found
    libpangox-1.0.so.0 => not found
    
  6. Installez le programme apt-file.

    sudo apt-get install apt-file
    apt-file update
    
  7. rechercher chacune des bibliothèques non trouvées.

    $ apt-file search libXmu.so.6
    libxmu6: /usr/lib/x86_64-linux-gnu/libXmu.so.6
    libxmu6: /usr/lib/x86_64-linux-gnu/libXmu.so.6.2.0
    libxmu6-dbg: /usr/lib/debug/usr/lib/x86_64-linux-gnu/libXmu.so.6.2.0
    
  8. Une fois les bibliothèques connues, nous pourrions les utiliser pour les installer. Chacun de ces paquets n’a pas été installé car certains étaient des dépendances.

    sudo apt-get install -y libgtk2.0-0:i386 libxmu6:i386 libgcj14-awt:i386 libpangoxft-1.0-0:i386 libxft2:i386 libpangoft2-1.0-0:i386 libpangox-1.0-0:i386
    
  9. Pas besoin de redémarrer le navigateur ou votre ordinateur. Votre web-ex va commencer à fonctionner.

réponse donnée Eldho 14.01.2015 - 06:00
la source
5

En supposant qu’un système 64 bits soit utilisé (le scénario le plus courant de nos jours), il existe deux approches pour faire fonctionner WebEx dans Ubuntu 14.04LTS:

  1. Faites que ça marche "nativement"
  2. Utilisez une version 32 bits installée manuellement de Firefox / Java.

Bien que le numéro 1 soit préférable en raison des mises à jour de sécurité automatiques et de l’encombrement moindre, je n’ai eu que le numéro 2 pour travailler correctement. Par conséquent, je documente les deux approches, en espérant que quelqu'un corrigera mon erreur avec l'approche n ° 1.

1. Approche autochtone (ne fonctionnait pas pour moi)

  • Installer Firefox
  • Installer JDK
  • Rejoignez une réunion de test WebEx pour créer une session dans $HOME/.webex/ . Il aura un nom de dossier numérique
  • vérifier les dépendances .so non résolues:
ldd $HOME/.webex/????/*.so > $HOME/check.txt
grep "not found" $HOME/check.txt | sort | uniq
  • Trouvez les paquets pour les bibliothèques manquantes (apparemment, vous pouvez ignorer la libjawt.so manquante, elle apparaît toujours manquante après l’installation de libgcj12-awt: i386 ')
sudo apt-get install apt-file
sudo apt-file update
apt-file search 
  • Installez les bibliothèques manquantes (ajoutez: i386 puisque WebEx est 32 bits), par exemple:
sudo apt-get install -y libasound2:i386
  • Lorsque vous avez terminé, rejoignez à nouveau une réunion de test

Statut:

  • L'audio ne fonctionne pas encore
  • Je ne vois pas la vidéo de mon homologue

2. Firefox / Java 32 bits autonome installé manuellement

Important Important: vous allez installer manuellement des logiciels dont les vulnérabilités ne sont pas encore connues. Vous devrez le tenir à jour vous-même.

Vue d'ensemble:

  • Téléchargez la dernière version de 32 bits de Firefox pour Linux
  • Téléchargez la dernière version Oracle Java 32 bits pour Linux
  • Lier le Java 32 bits dans le dossier des plugins Firefox
  • Créer un script pour démarrer Firefox 32 bits
  • Créer une entrée de bureau pour Firefox 32 bits

Pour ce faire, ouvrez un terminal et entrez les commandes suivantes. Notez que le nom des téléchargements est correct au 13 mai 2015 et sont susceptibles de changer très prochainement.

cd
mkdir webex
cd webex
wget http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/38.0/linux-i686/en-US/firefox-38.0.tar.bz2
wget -O java.tar.gz http://javadl.sun.com/webapps/download/AutoDL?BundleId=106238
tar -C . -zxf java.tar.gz
tar -C . -jxf firefox-38.0.tar.bz2
mkdir firefox/browser/plugins
ln -s ~/webex/jre1.8.0_45/lib/i386/libnpjp2.so ~/webex/firefox/browser/plugins/libnpjp2.so
nano ~/webex/webex.sh
chmod u+x ~/webex/webex.sh
sudo nano /usr/share/applications/webex.desktop 
sudo update-desktop-database

Contenu de ~/webex/webex.sh . Remplacez yuv par votre nom d'utilisateur et mettez à jour le nom du dossier JAVA_HOME en fonction de la version téléchargée / installée

#!/bin/bash
export ENV_HOME_32=~/webex
export JAVA_HOME=$ENV_HOME_32/jre1.8.0_45
export FIREFOX_HOME=$ENV_HOME_32/firefox
export PATH=$FIREFOX_HOME:$JAVA_HOME/bin:$PATH
firefox --no-remote -P WebEx

Contenu de /usr/share/applications/webex.desktop . Remplacez yuv par votre nom d'utilisateur et créez une image significative dans ~/webex/webex.jpg

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
StartupNotify=true
Icon=/home/yuv/webex/webex.jpg
Name=WebEx
Comment=32 Bit firefox for WebEx
Exec=/home/yuv/webex/webex.sh
Categories=Application;Productivity;Collaboration

Test:

  • dans XFCE, allez dans le menu Autre et démarrez WebEx
  • Première fois: créer un profil WebEx

Statut:

  • J'ai pu participer à une conférence, parler et écouter, et voir l'autre webcam
  • Je n'ai pas pu diffuser ma webcam, j'ai besoin d'en savoir plus
  • participer à une réunion de test: lien
réponse donnée Yuv 14.05.2015 - 02:30
la source
1

J'ai eu ce problème à la fois dans Ubuntu 12.04 et 14.04

Le problème semble être un problème de sécurité avec Java (consultez cette question Impossible de démarrer la session Webex. Problème de permission Java? )

La solution sur ce thread a fonctionné pour moi:)

1) Ouvrez Java Web Start 2) Dans l'onglet Sécurité, ajoutez votre serveur Webex ( lien ) à la liste des sites d'exception

.

Fait

    
réponse donnée dsmalinsky 12.05.2014 - 19:53
la source
1

Voici le support officiel de Webex - Linux (mais même avec cela ne fonctionnera pas correctement: -S) * Il est vraiment dommage que Cisco Webex ne fonctionne toujours pas correctement sous Linux.

lien

    
réponse donnée warfares 23.05.2014 - 17:52
la source
0

Pour moi, le problème n’a pas fonctionné tant que j’ai installé des fichiers Java 32 bits conformément aux instructions lien

Ouvrez un terminal et lancez les commandes suivantes:

sudo apt-get -y remove icedtea-7-plugin:i386 icedtea-netx:i386
sudo apt-get install openjdk-7-jre:i386 libxmu6:i386 icedtea-7-plugin firefox
sudo update-alternatives --auto mozilla-javaplugin.so

Ensuite, l’utilisation de WebEx dans Firefox a fonctionné.

    
réponse donnée Sam King 23.03.2016 - 20:42
la source
0

J'ai aussi cette erreur: Application bloquée. Cliquez pour plus de détails . Les détails parlaient des domaines https://meetings.webex.com et https://akamaicdn.webex.com qui me servaient des fichiers JAR, mais qui ne figuraient pas sur ma "Liste des sites d’exceptions" Java.

J'ai suivi les instructions pour mettre à jour ma liste donnée à »Java Site d'exception de sécurité pour WebEx Linux Sagas . À savoir:

  • Exécutez le Panneau de configuration Java: $ JAVA_HOME / bin / ControlPanel, qui pour moi est: / usr / lib / jvm / java-8-oracle / bin / ControlPanel
  • Cliquez sur l'onglet Sécurité et ajoutez des exceptions si nécessaire.
réponse donnée nealmcb 11.08.2016 - 18:34
la source

Lire d'autres questions sur les étiquettes