Comment désactiver IPv6 sur Ubuntu?

26

J'ai désactivé IPv6 sur une boîte Ubuntu qui utilise ssh et rsync. Mais les deux écoutent toujours sur une adresse IPv6. Comment dois-je résoudre ce problème?

[email protected]:~# sysctl net.ipv6.conf.all.disable_ipv6
net.ipv6.conf.all.disable_ipv6 = 1
[email protected]:~# sysctl net.ipv6.conf.default.disable_ipv6
net.ipv6.conf.default.disable_ipv6 = 1
[email protected]:~# sysctl net.ipv6.conf.lo.disable_ipv6
net.ipv6.conf.lo.disable_ipv6 = 1

Et

[email protected]:~# ss -lnp6
State      Recv-Q Send-Q        Local Address:Port    Peer Address:Port
LISTEN     0      128            :::22                 :::*      users:(("sshd",1505,4))
LISTEN     0      5              :::873                :::*      users:(("rsync",3423,5))
    
posée Abhishek Chanda 16.09.2013 - 08:09
la source

5 réponses

40

Cela a fonctionné pour moi:

Ajoutez ces lignes au bas de sysctl.conf

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Ensuite, exécutez sudo sysctl -p ou reboot

source: lien

Bien sûr, cela n’empêchera pas d’essayer aveuglément d’utiliser ipv6, vous devez donc modifier /etc/default/bind9 comme suit:

# run resolvconf? 
RESOLVCONF=yes 
# startup options for the server 
OPTIONS="-4 -u bind"

source: lien

    
réponse donnée boatcoder 24.11.2013 - 17:33
la source
21

Pour vérifier si IPv6 est activé ou désactivé, depuis une fenêtre de terminal:

$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

0 signifie qu’il est activé et 1 est désactivé.

Pour désactiver IPv6

$ sudo su -
# nano /etc/sysctl.conf

et ajoutez ces lignes au fichier sysctl.conf

#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Enregistrez le fichier sysctl.conf avec la nouvelle configuration, puis redémarrez votre système

# reboot

Vérifiez à nouveau votre système

$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Maintenant, vous devriez voir "1" signifie que IPv6 a été désactivé sur votre système.

De lien

    
réponse donnée user223973 23.12.2013 - 03:41
la source
3
  1. Ouvrez un terminal et tapez la commande suivante (si vous n'utilisez pas Gedit, remplacez-le par votre éditeur de texte tel que Kate, etc.).

    sudo gedit /etc/default/grub
    
  2. Et recherchez ceci:

    GRUB_CMDLINE_LINUX
    

    Modifiez-le pour qu'il ressemble à ceci:

    GRUB_CMDLINE_LINUX="ipv6.disable=1"
    
  3. Maintenant, mettons à jour le GRUB:

    sudo update-grub2
    

    Ou si vous n’utilisez pas GRUB 2, faites:

    sudo update-grub
    
  4. Enfin, redémarrez votre système.

réponse donnée nicoX 16.09.2013 - 12:53
la source
0

Désactiver l’écoute des adresses ipv6 pour certains services.

sshd / etc / default / ssh

# Options to pass to sshd
SSHD_OPTS="-4"

avahi-daemon /etc/avahi/avahi-daemon.conf

[server]
use-ipv4=yes
use-ipv6=no

java /etc/java-7-openjdk/net.properties

http.nonProxyHosts=localhost|127.*
ftp.nonProxyHosts=localhost|127.*

Puis redémarrez les services

service restart sshd
service restart avahi-daemon
service restart tomcat7

Dans mon cas, Tomcat utilisait java avec ipv6. Peut différer pour vous.

    
réponse donnée Ulrich-Lorenz Schlüter 22.04.2015 - 16:24
la source
0

Il suffit de faire tourner IPv6 sur votre ordinateur, pourquoi vous avez toujours voulu le faire. Ajoutez simplement une ligne à un fichier de configuration. Oui, vous devez être root pour créer le fichier.

$ cat <<EOF >/etc/modprobe.d/blacklist-ipv6.conf
# To turn off IPv6, though you don't need too.
# But anyways.
blacklist ipv6

# eof
EOF

Il suffit de redémarrer ou d'essayer:

$ sudo rmmod ipv6
    
réponse donnée Anders 22.03.2016 - 02:37
la source

Lire d'autres questions sur les étiquettes