GUI / Unity tombera en panne en 16.04 LTS après les mises à jour 2018-01-04, compiz segfaults

37

Les dernières mises à jour (01/04/2018) font que mon portable plante constamment l'interface graphique / Unity:

(processeur Intel Pentium su4100)

syslog:

Jan  5 11:38:53 1810 kernel: [ 1850.327738] compiz[11911]: segfault at 0 ip 00007f6c7baf0c16 sp 00007ffd5ec71c60 error 4 in i965_dri.so[7f6c7b513000+82d000]

Après la connexion, je me retrouve avec un bureau vide, juste un fond d'écran, l'interface utilisateur graphique / Unity est dans une boucle de crash:

  • Pas de panneau,
  • pas de tiret
  • ne peut pas démarrer un programme.
  • le lanceur disparaît
  • la barre latérale disparaît
  • panne du système
  • la clé Windows ne fonctionne pas
  • L'onglet
  • alt ne fonctionne pas

L'ordinateur n'est tout simplement pas utilisable. Identique pour la connexion de l'invité. Seule chose fonctionne: ouvrez un terminal CTRL ALT 3 pour examiner les fichiers journaux.

J'ai forcé en quelque sorte Mode graphique bas sur l'unité pour me connecter et classer le bogue, mais encore beaucoup de problèmes:

  • Dash ne fonctionne pas
  • L'onglet
  • alt ne fonctionne pas
  • les fenêtres disparaissent parfois pendant quelques secondes

Rapport de bogue

Des idées pour une solution / solution de contournement?

MISE À JOUR

  

Si vous rencontrez les mêmes problèmes, suivez le lien menant à mon bug   signaler et marquer là que vous êtes affecté aussi. Ou déposez les vôtres. S'il vous plaît laisser un commentaire   si vous le souhaitez ou si vous le souhaitez - c'est un problème désagréable - mais une réponse devrait   offrir un correctif ou une solution de contournement pour que les utilisateurs puissent à nouveau utiliser cet ordinateur.

Sans rapports de bogues appropriés , Ubuntu ne peut pas résoudre les problèmes.

    
posée Janghou 05.01.2018 - 11:59
la source

2 réponses

31

UPDATE APRIL

J'ai été frappé à nouveau par ce bug / symptôme le 26 avril 2018. Je pouvais le résoudre en appliquant le correctif de mars ET en nettoyant en plus le répertoire de crash.

rm ~/.config/upstart/lowgfx.conf
sed -i 's/-lowgfx//' ~/.config/compiz-1/compizconfig/config
rm -r ~/.cache/
sudo rm -r /var/crash/*
reboot

MISE À JOUR Mars 2018.

Il semble qu'un bug avec plus ou moins les mêmes symptômes ait frappé quelques utilisateurs au début de mars 2018. Ce nouveau bogue se trouve dans compiz-config, pas dans compiz. Et c'est moins grave: la session invité et le mode graphique bas fonctionnent correctement. Nouveau rapport de bogue .

Correction (pour la plupart des utilisateurs):

rm ~/.config/upstart/lowgfx.conf
sed -i 's/-lowgfx//' ~/.config/compiz-1/compizconfig/config
rm -r ~/.cache/
reboot

Explication: Supprimez tout fichier lowgfx.conf et modifiez profile = unity-lowgfx à profile = unity dans du code%. Nettoyez le répertoire .cache de votre répertoire personnel. Redémarrez. Remettez-le à tout le monde . rapport de bug.

Si vous êtes touché en mars et que la solution ci-dessus ne fonctionne pas, laissez un message sur le rapport de bug . Essayez la solution 3 (voir ci-dessous). Sinon, essayez de modifier les paramètres de compilation dans CCSM. Ou supprimez / nettoyez votre répertoire ~ / .cache.

Bug corrigé (janvier)

Ce bogue est corrigé maintenant . Les mises à jour sont dans les mises à jour Xenial, une mise à jour résoudra donc le problème.

 sudo apt update && sudo apt upgrade -y

Vous pouvez désactiver les propositions:

 System Settings -> Software & Updates -> Tab Developer options -> uncheck proposed

Vous pouvez annuler toutes vos solutions de contournement.

Contexte

Ce bogue est reconnu et causé par les mises à jour de mesa de 2018-01- 04 à 17.2.4. Le bogue est maintenant marqué comme une copie d'un bogue antérieur déposé le 2017-12-01 . , malheureusement, ce bogue a été mal classé .

Seuls les anciens Intel, ~ 2006-2011, avec des graphismes intégrés (gen4 / 5) sont affectés, ce qui explique pourquoi ils ont passé des tests. Et cela semble seulement affecter Unity, pas Gnome ou LXDE.

L'information suivante est obsolète

Le correctif de ce bogue sera disponible sous xenial-proposal prochainement. Aidez Ubuntu en testant ce nouveau package. Consultez lien pour obtenir de la documentation sur la manière d'activer et d'utiliser le format proposé. Veuillez nous faire part de vos commentaires à la page de rapport de bogue pour vous aider à mettre cette mise à jour à disposition des autres utilisateurs d'Ubuntu. Voir le commentaire 48 pour plus d'informations.

Pour activer la proposition (veuillez d'abord lire les informations ci-dessus) :

 System Settings -> Software & Updates -> Tab Developer options -> check proposed

Installer les correctifs

  sudo apt-get install libgl1-mesa-dri/xenial-proposed
  sudo reboot

Ensuite, ajoutez un fichier .config/compiz-1/compizconfig/config

 Package: *
 Pin: release a=xenial-proposed
 Pin-Priority: 400

Cela vous protégera de la mise à jour de tous les packages du référentiel proposé lors de votre prochaine visite sur /etc/apt/preferences.d/proposed-updates . Vous ne le voulez pas.

Si vous ajoutez ce fichier avant que vous installez les correctifs, vous recevrez un message d'erreur de dépendance.

Si vous avez utilisé un PPA comme solution de contournement, vous devez d'abord le supprimer.

 sudo ppa-purge ppa:paulo-miguel-dias/pkppa
 sudo reboot

Jusqu'à ce que ce bogue soit résolu, quelles sont les solutions de contournement?

1. Installez lubuntu-desktop (LXDE) à part de l'unité

sudo apt-get install lubuntu-desktop

Cela va prendre environ 400 Mo et installer des choses comme Abiword, vous pouvez les supprimer plus tard pour économiser de l’espace disque. Choisissez simplement Lubuntu lors de la connexion. Supprimez à nouveau lubuntu-desktop lorsque le bogue est résolu.

2. Rétrograder les paquets mesa

Ceci est décrit dans le rapport de bogue. Il peut avoir des effets secondaires indésirables et des dépendances, alors décidez vous-même.

Comme il semble que ces 4 packages doivent être rétrogradés:

libegl1-mesa 17.2.4-0ubuntu1~16.04.2
libgbm1 17.2.4-0ubuntu1~16.04.2
libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.2
libwayland-egl1-mesa 17.2.4-0ubuntu1~16.04.2

Une façon est de les télécharger depuis le lien dans ce commentaire et suivez les instructions. sudo apt upgrade

Si vous utilisez Wine, vous aurez besoin des paquets i386 aussi.

Empêcher la mise à niveau automatique de ces 4 packages. N'oubliez pas de supprimer ce fichier une fois le bogue résolu.

3. Utilisez le mode graphique bas

Cela atténuera les bogues et vous donnera une interface graphique quelque peu fonctionnelle.Mais:

  • Dash ne fonctionne pas
  • L'onglet Alt ne fonctionne pas
  • Déconnexion, redémarrage et arrêt doivent être effectués avec le terminal, même chose pour les programmes qui ne sont pas dans le lanceur
  • super clé (windows) ne fonctionne pas

Cela dit: le programme de lancement, le changement d’espace de travail et les raccourcis clavier fonctionnent, alors diffusez simplement vos programmes sur les espaces de travail:)

Créer un fichier dpkg -i *.deb

start on starting unity7
pre-start script
initctl set-env -g UNITY_LOW_GFX_MODE=1
end script

Déconnexion et connexion.

4. PPA

Mettez à jour mesa dans une version plus récente via un PPA . N'oubliez pas de purger le PPA lorsque le bogue est résolu. C'est probablement le meilleur choix. Veuillez lire les infos sur la page PPA avant d’appliquer le code suivant.

 sudo apt-add-repository ppa:paulo-miguel-dias/pkppa
 sudo apt update && sudo apt upgrade -y
 sudo reboot

Redémarrez et ça devrait aller. Sinon, laissez un message dans le rapport de bogue.

N'oubliez pas de purger le PPA lorsque le bogue est résolu.

 sudo ppa-purge ppa:paulo-miguel-dias/pkppa

5. Rétrograder de HWE au noyau stock (et mesa / x-server)

Le bug est causé par les mises à jour de mesa (17.2.4) et mesa est mis à jour le long des noyaux de la pile HWE. Le retour au noyau (4.4) résoudra le problème, il rétrogradera mesa à 11.2.

sudo apt install --install-recommends xserver-xorg xserver-xorg-core
xserver-xorg-video-all xserver-xorg-input-all xserver-xorg-video-intel 
server-xorg-video-qxl
sudo reboot

Ce sera supprimera tous les packages HWE. Probablement la solution la plus sûre.

Espérons que ce bogue bug sera bientôt résolu. Envisagez d’aider Ubuntu à tester.

    
réponse donnée Janghou 07.01.2018 - 12:28
la source
0

Cela m'a récemment affecté le 17.10 (i7-6700K, Intel HD530). J'ai mis à jour le PPA MESA suggéré ici qui ne résout pas le problème, mais en parcourant manuellement mes plug-ins compiz dans CCSM, il semble que le plug-in Grid était spécifiquement celui qui causait des problèmes pour moi.

Désactiver la grille fonctionne pour moi; l'activation de la grille, mais la désactivation de tous les paramètres de prévisualisation dans l'onglet Apparence semble également fonctionner (je ne veux vraiment pas perdre la fonctionnalité de la grille si je peux l'éviter).

Absolument le pire bug que j'ai jamais rencontré sur Ubuntu: (

    
réponse donnée owenjm 27.03.2018 - 01:41
la source

Lire d'autres questions sur les étiquettes