Ubuntu 16.04 Scintillement de l'écran de 6ème génération Skylake

29

J'ai un Lenovo ThinkPad t460s ici. C'est la version PCI SSD de NVMe. Le processeur est i7 6600U (Skylake 6ème génération) avec Intel HD 520.

Il y a environ un mois (à partir de mars 2016), j'ai installé Ubuntu GNOME 16.04 Bêta 1. En plus des problèmes connus (problèmes des boutons physiques de Touchpad, problèmes de couvercle), tout semblait fonctionner correctement.

A cette époque, j'utilisais la version 4.4.0-7 du noyau. Quelques jours plus tard, il y a eu plusieurs mises à jour du noyau (4.4.0-12, 4.4.0-14 et 4.4.0-15). Soudain, je vivais un scintillement de l'écran. C'était vraiment moche et je ne pouvais plus travailler. J'ai donc rétrogradé la version du noyau en 4.4.0-7 et l'ai mise en attente (via apt-mark hold). L'éclatement de l'écran a disparu. Maintenant, j'ai des artefacts graphiques lors de la navigation (firefox, chrome). Je pense que j'ai réussi à m'en débarrasser en désactivant les options de "défilement régulier".

Quelqu'un d'autre connaît-il des problèmes similaires? Ou quelqu'un a-t-il déjà trouvé une solution à ce problème?

PS: J'étais en train d'installer Ubuntu GNOME 16.04 Final Beta il y a quelques jours et j'ai essayé la version 4.4.0-16 du noyau, ce qui a résolu le problème avec les boutons physiques du touchpad. Mais malheureusement, le scintillement de l'écran n'a pas été résolu. Je suis donc revenu à la version 4.4.0-7 du noyau, comme décrit ci-dessus à nouveau.

    
posée hakunamatata 01.04.2016 - 18:17
la source

17 réponses

8

UPDATE: Hier, j'ai récemment installé Ubuntu GNOME 16.04. Il est venu avec une version du noyau à jour: 4.4.0-18. Il semble avoir résolu le problème du scintillement de l'écran pour moi (du moins jusqu'à présent). En outre, les boutons physiques du pavé tactile fonctionnent comme prévu (par exemple, le défilement et le glisser-déposer fonctionnent). Il semble y avoir quelques déchirures dans les navigateurs Web (Firefox et Chrome). Mais ce n'est pas vraiment comparable au problème du scintillement de l'écran auparavant. Dans Firefox, j'ai réussi à me débarrasser de l'écran en désactivant l'option "défilement régulier". Malheureusement, la même procédure ne semble pas aider dans le chrome.

    
réponse donnée hakunamatata 13.04.2016 - 16:45
la source
20

@brianjcohen m'a conduit dans la bonne direction. Le rapport de bogue sur le chrome a eu de bonnes discussions sur certains aspects du problème, mais apparemment, il s’agit plutôt d’un problème x.org avec les options du pilote Intel. Vous pouvez vous y référer si vous souhaitez:

lien

Pour le corriger, créez ou modifiez le fichier à /usr/share/X11/xorg.conf.d/20-intel.conf en tant que root avec les éléments suivants:

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "sna"
    Option "TearFree" "true"
    Option "DRI" "3"
EndSection
  • D'après la discussion, AccelMethod devrait être par défaut sna , mais apparemment, ne pas le définir explicitement comme tel pourrait entraîner le blocage de X. sna est nettement plus rapide que de le réduire à uxa .
  • TearFree aide à prévenir les déchirures dans le rendu vidéo
  • DRI est une méthode sur la façon dont le pilote rend les choses, je pense que c'était l'option clé. Vous pouvez en savoir plus sur ce que c'est ici: lien
  • Vous pouvez également lire la page de manuel à man 4 intel
réponse donnée basicdays 10.07.2016 - 00:05
la source
5

Essayez:

Passer du pilote Intel de SNA à UXA m'a beaucoup aidé (sur un Dell Skylake ici).

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

Ajoutez ceci à la configuration de xorg en l’ajoutant à un fichier dans /usr/share/X11/xorg.conf.d

    
réponse donnée Mike O'Connell 01.04.2016 - 21:33
la source
5

J'ai eu ce problème sur mon nouveau stock 16.04 Lenovo X1 Carbon (noyau 4.4.0-33, graphismes Skylake GT2). J'ai essayé deux des réponses ci-dessus (basicdays et Mike O'Connell) mais aucune n'a fonctionné. Le premier a rendu les graphiques trop lents; ce dernier n'a pas réussi à initialiser les graphiques du tout.

Finalement, j'ai résolu le problème par l’autre méthode mentionnée ici . , c'est-à-dire que j'ai supprimé le pilote graphique spécifique à Intel. Tout semble bon pour l'instant - pas de scintillement dans Chrome et un comportement plus glitch dans d'autres applications semble avoir disparu aussi.

En bref, lancez ceci puis redémarrez et tout devrait être bon:

sudo apt-get purge xserver-xorg-video-intel
    
réponse donnée rog 24.08.2016 - 17:56
la source
2

Un utilisateur de reddit a signalé que le noyau 4.6.0-994-générique de la branche Intel DRM ( lien ) a corrigé le scintillement de son écran.

    
réponse donnée Massimiliano 22.04.2016 - 16:18
la source
2

Je ne suis pas sûr à 100% que c'est le même problème que tout le monde connaît. Mais le problème que j'avais (Lenovo T460s, Skylake fonctionnant en 16.04) était que je ressentirais le scintillement d'une seule image et des arrêts occasionnels dans Google Chrome, surtout si des effets vidéo ou animés étaient sur la page. Le problème n'était pas reproductible dans Firefox. J'ai été en mesure de résoudre le problème en démarrant Chrome avec --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers, puis en réinitialisant tous les drapeaux expérimentaux par défaut en passant à chrome: // . L'explication, je crois, est que par défaut (et je ne suis pas sûr que ce soit spécifique à Ubuntu ou non), il existe, comme l'indique l'indicateur, des solutions aux bugs GPU connus activés, et je pense que ces solutions ne sont plus nécessaires et sont en réalité contreproductives.

Plus d’informations ici: lien

Pour ajouter ces commutateurs de démarrage à mon lanceur Chrome, j'ai effectué les opérations suivantes:

  1. Ouvrez le tableau de bord et tapez "chrome".
  2. Faites glisser l’icône Chrome vers n’importe quel dossier (j’ai utilisé mon dossier personnel)
  3. Cliquez avec le bouton droit de la souris sur l’icône dans mon dossier personnel et cliquez sur Propriétés
  4. Dans la zone de commande, ajoutez les commutateurs après "% U".
  5. Faites glisser l’icône Chrome sur mon lanceur pour la verrouiller.

Edit: J'utilise 4.4.0-22.39, et je n'ai pas essayé ceci sur les autres versions du noyau.

    
réponse donnée brianjcohen 09.05.2016 - 19:33
la source
1

J'ai eu le même problème et j'ai fini par désactiver tlp en /etc/default/tlp . changer TLP_ENABLE=1 en TLP_ENABLE=0 .

Il semble que la gestion de l’énergie provoque le scintillement.

cette solution peut affecter la durée de vie de votre batterie.

    
réponse donnée theo2021 02.05.2016 - 16:05
la source
1

Voici ce que je devais faire pour éliminer le déchirement et le scintillement de mon Ubuntu 16.04:

sudo apt-get install xserver-xorg-video-intel libva-intel-vaapi-driver

Créez et modifiez ~/.drirc :

<device screen="0" driver="dri2">
    <application name="Default">
    <option name="vblank_mode" value="0"/>
    </application>
 </device>

Créez et modifiez /usr/share/X11/xorg.conf.d/20-intel.conf :

Section "Device"
  Identifier "Intel Graphics"
  Driver     "intel"
  Option     "AccelMethod" "sna"
  Option     "TearFree" "true"
  Option     "DRI" "3"
EndSection

Le presque ci-dessus fait l'affaire. Cependant, il y a un bogue persistant du noyau dans les versions récentes du noyau (de 4.0 jusqu'à la dernière version 4.8), ce qui produit un scintillement identique à celui de cette vidéo: lien .

Cependant, si vous utilisez un noyau vraiment ancien, le scintillement cesse.

Téléchargez et installez un ancien noyau:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13.11.11-trusty/linux-image-3.13.11-03131111-generic_3.13.11-03131111.201411111336_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13.11.11-trusty/linux-headers-3.13.11-03131111_3.13.11-03131111.201411111336_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13.11.11-trusty/linux-headers-3.13.11-03131111-generic_3.13.11-03131111.201411111336_amd64.deb

sudo dpkg -i linux-headers-3.13.11-03131111_3.13.11-03131111.201411111336_all.deb linux-headers-3.13.11-03131111-generic_3.13.11-03131111.201411111336_amd64.deb linux-image-3.13.11-03131111-generic_3.13.11-03131111.201411111336_amd64.deb

La dernière chose à faire est de faire le noyau ci-dessus par défaut.

Modifiez /etc/default/grub et modifiez / ajoutez la ligne suivante:

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 3.13.11-03131111-generic"

Et enfin, mettre à jour grub:

sudo update-grub
    
réponse donnée Paweł Gościcki 13.09.2016 - 19:24
la source
1

J'ai trouvé les paramètres de démarrage du noyau suivants à essayer car ils affectent le scintillement de l'écran après avoir essayé certaines des corrections Xorg notées (non plus):

  • Désactiver les modes de veille RC6: i915.enable_rc6=0 OR
  • Désactiver le rafraîchissement automatique du panneau i915.enable_psr=0

Plus d’informations ici .

Pour les ajouter, créez et éditez /etc/modprobe.d/i915.conf avec

options i915.preliminary_hw_support=1 i915.enable_psr=0

ou essayez

options i915.preliminary_hw_support=1 i915.enable_rc6=0

J'ai ensuite redémarré pour utiliser ces nouvelles options de module et pour tester le scintillement par cycle veille / sommeil. Aucun ne semblait aider. Comme pour 16.10, la partie i915.preliminary_hw_support=1 peut ne pas être nécessaire.

    
réponse donnée m1st0 04.01.2017 - 22:22
la source
1

J'ai aussi eu le même problème sur un Lenovo Yoga 2 Pro exécutant 16.04 + Gnome Shell.

Vidéo: lien

Le clignotement de l’écran se produit parfois après 10 minutes ou 2 heures. Il s'arrêtait pendant que la souris bougeait, et j'ai pu l'arrêter temporairement pendant une heure ou deux en changeant de console via ctrl-alt-f1. J'ai tout essayé dans ce fil sans succès, mais je suis tombé sur un rapport de bogue qui mentionnait de changer les noyaux 4.4.0-040400. Je suis depuis 12 heures depuis la mise à jour du noyau depuis la version 4.6, et le scintillement est parti!

C'est le noyau que j'ai utilisé. Installez-les simplement et désinstallez l'ancien noyau. lien

    
réponse donnée Sean Hanson 08.04.2017 - 13:47
la source
0

Le noyau 4.6.0-994-generic, à partir du lien posté par Massimiliano, a résolu le problème pour moi.

J'ai un Chromebook Acer avec un processeur i5-5200U. Le symptôme était que je commençais à clignoter lors du premier démarrage de l'ordinateur portable. Je devrais fermer et ouvrir le couvercle à quelques reprises pour régler le problème.

Depuis que j'ai installé 4.6.0-994-generic, cela fonctionne correctement.

    
réponse donnée Alfy 06.05.2016 - 03:23
la source
0

Je viens de mettre à jour vers 16.04 à partir de 15.10 sur un Dell inspiron 3000 avec des graphiques nvidia geforce. Il y avait un scintillement très agaçant. La chose qui m'a résolu était de changer la luminosité de l'écran par défaut. Plus clair ou plus bas l'a corrigé. Revenir au niveau par défaut a provoqué le scintillement.

    
réponse donnée Glen 21.05.2016 - 09:06
la source
0

J'ai eu le même problème sur un XPS 13 9350. (Noyau 4.4.0-22-generic) Je ne sais plus quel est le problème. Je pense qu'il commence après l'installation de Skype?! Il n'y avait pas de scintillement après l'installation d'ubuntu. ça commence quelques jours plus tard et je pense que ça commence après l'installation de skype? Mais je ne suis pas sûr - (

l’installation du dernier noyau (4.6.0-040600-generic) a résolu le problème.

voici un moyen simple d’installer la dernière version du noyau: lien

merci Massimiliano il apporte le meilleur conseil !!!

    
réponse donnée timbo 22.05.2016 - 22:26
la source
0

J'étais confronté au même problème ici avec mon Dell XPS13 Intel® HD Graphics 520 (Skylake GT2). J'utilise Ubuntu 16.04 Xenial et je viens de résoudre ce problème dans System Settings - & gt; Logiciel & amp; Mises à jour - & gt; Pilotes supplémentaires, activant le microprogramme «Utilisation du microprogramme du processeur pour les processeurs Intel intel-microcode (propriétaire)», puis redémarrage. J'espère que ça marche pour vous aussi!

    
réponse donnée Nepheline 04.06.2016 - 22:23
la source
0

J'ai eu le même problème en testant Mint 18 sur Samsung 9, i7-6500u.

Conformément à l'affiche ci-dessus qui l'a résolu en désactivant tlp, j'ai constaté que le scintillement ne se produit que lorsque j'utilise powertop pour sélectionner:

"Autosuspend pour périphérique USB inconnu 1-5 (8087: 0a2b)

de "mauvais" à "bon", c’est-à-dire allumer cette autosuspend avec "bon" provoque le scintillement, "mauvais" ne le fait pas.

Avec cette gauche "mauvaise", mon affichage est stable.

    
réponse donnée Robert John Freeman 05.10.2016 - 09:21
la source
0

J'ai eu un problème similaire et j'ai atteint ce sujet en cherchant une solution.

Bien que la mise à niveau du noyau vers la version 4.8 ait amélioré la situation, la solution pour moi consistait à installer des pilotes Intel Graphics pour Linux:

lien

Notez que pour Ubuntu 16.04, vous avez besoin de la v2.0.2 et non de la dernière version (actuellement v2.0.3)

lien

    
réponse donnée Romi Kuntsman 04.12.2016 - 11:01
la source
0

Est-ce celui avec les lignes noires? J'ai ce même problème sur mon ultrabook de Samsung, cela ne se produit qu'à pleine résolution "1080P" sur mon port HDMI. J'ai remarqué que cela semble se produire surtout si l'écran est très lumineux, principalement s'il y a un arrière-plan blanc comme dans "Fichiers ou un navigateur Web", mais il n'est pas vraiment affecté par les applications intensives comme "jouer des films 1080p" seuls les réglages de couleur ou de luminosité semblent désactiver le réglage?

ce n'est pas un correctif mais c'est une solution de contournement jusqu'à ce qu'ils publient une mise à jour qui résout le problème.

Définir la résolution de 1080p au maximum semble l’arrêter, vous pouvez essayer si vous avez encore des problèmes:)

EDIT: Essayez également le noyau 4.8.10 C'est le "seul" noyau qui fixe définitivement les lignes noires à 1080P avec une sortie HDMI intel HD4000, toutes les autres versions semblent avoir annulé ce correctif depuis celui-là, même 4.9 ne le répare pas. Utilisez l'utilitaire de mise à jour du noyau Ubuntu pour lui donner un coup de pouce "Ukuu" je pense que c'est appelé?

    
réponse donnée Damien Gorlick 09.06.2016 - 06:28
la source

Lire d'autres questions sur les étiquettes