Comment résoudre une ancienne erreur GLIB

5

Je suis en train d’installer GTK + mais il a besoin de plusieurs prérequis. Ce sont

  • glib - 2.0 & gt; = 2.35.3
  • atk - & gt; = 2.7.5
  • Pango- & gt; = 1.32.4
  • gdk-pixbuf-2.0 & gt; = 2.27.1

Maintenant, j'ai mis à niveau ma glib-2.0 vers 2.38.2 et j'ai essayé de mettre à jour atk, pango et gdk-pixbuf

checking for GLIB - version >= 2.31.2... 
'pkg-config --modversion glib-2.0' returned 2.38.2, but GLIB (2.32.4)
was found! If pkg-config was correct, then it is best
to remove the old version of GLib. You may also be able to fix the error
by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
/etc/ld.so.conf. Make sure you have run ldconfig if that is
required on your system.
If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
to point to the correct configuration files

configure: error: 
GLIB 2.31.2 or better is required. The latest version of
GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
but not in the same location as pkg-config add the location of the file
glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

J'ai tourné en rond ces dernières heures pour essayer de faire fonctionner ce système, si quelqu'un pouvait l'aider serait très apprécié. Merci d'avance

    
posée Hakim_Djzarie 20.02.2014 - 23:05
la source

2 réponses

3

J'ai le même problème que vous.

J'ai défini PKG_CONFIG_PATH et LD_LIBRARY_PATH comme

PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
LD_LIBRARY_PATH=/usr/local/lib

voir lien

Mais ça n'a pas marché. Puis j'ai trouvé quelqu'un le résoudre comme

echo $LD_LIBRARY_PATH
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

voir lien

Et ça a marché!

    
réponse donnée Seyer 16.03.2014 - 15:55
la source
0

Je l'ai testé tant de fois, et je vérifié que si nous installons glib de la source, nous avons des options:

  1. Si avec faire ./configure --prefix=/usr --with-pcre=system , comme dans , cela signifie que nous avoir glib installé dans /usr/lib path . Donc, nous devons faire export LD_LIBRARY_PATH=/usr/lib .
  2. Si nous n'utilisons pas --prefix= , le chemin par défaut est /usr/local/lib/ . Donc, si pkg_config trouve deux bibliothèques installées, nous devons créer export LD_LIBRARY_PATH=/usr/local/lib si nous avons installé le chemin par défaut.

J'espère que ça aide quelqu'un.

    
réponse donnée R. Rodrigues 17.08.2017 - 17:18
la source

Lire d'autres questions sur les étiquettes