Comment désactiver les pilotes de l'écran tactile?

36

J'ai un écran tactile, mais les pilotes ne fonctionnent pas correctement et interfèrent avec ma souris.

Est-il possible de désactiver mon écran tactile pour pouvoir fonctionner correctement à nouveau?

    
posée mnr 10.10.2012 - 16:21
la source

5 réponses

44

Vous pouvez essayer de désactiver le périphérique d'entrée à l'aide de la commande xinput . Tout d’abord, voyez quels périphériques d’entrée vous avez, tapez simplement:

xinput

Et vous devriez voir une liste comme celle-ci:

$ xinput 
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=9    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
...

Ensuite, vous pouvez désactiver le périphérique d'entrée souhaité avec cette commande:

xinput disable 9

Où 9 est l'id du périphérique que vous souhaitez désactiver. Vous pouvez également utiliser le nom du périphérique entre guillemets.

Dans la version 1.5.99.1 de xinput, vous devez faire xinput set-prop 9 'Device Enabled' 0 à la place. Bizarrement, sur xinput v1.6.2, la première méthode fonctionne.

    
réponse donnée romaia 26.12.2012 - 05:00
la source
26

La solution xinput n'a pas fonctionné pour moi. J'ai plutôt suivi les instructions de ce fil . Cela le désactivera au démarrage.

  1. Éditer /usr/share/X11/xorg.conf.d/10-evdev.conf
  2. Ajoutez Option "Ignore" "on" à la fin de la section avec l'identificateur touchscreen
  3. redémarrer

  • Pourmémoire(Google),j'aiunSamsungSeries7etmonécrantactileétaitrépertoriésouslenomdeELANTouchscreendansxinput.
  • JFTRaussi, dans cette question la différence de consommation d'énergie est généralement négligeable.
réponse donnée anon 23.06.2014 - 02:05
la source
3

Editez le fichier avec

sudo nano /usr/share/X11/xorg.conf.d/10-evdev.conf

Modifiez MatchIsTouchscreen de "on" à "off" dans la section Touchscreen de sorte à ressembler à ceci:

Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "off"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

Enregistrer, nommer et quitter

L'écran tactile est désactivé et n'est plus détecté dans la liste xinput.

    
réponse donnée Shawn Moore 16.06.2017 - 01:23
la source
0

Si votre écran tactile est un écran tactile similaire à un moniteur USB, vous pouvez ajouter le pilote de noyau par défaut usbtouchscreen dans le fichier de liste noire de modprobe ( /etc/modprobe.d/blacklist.conf ) et utiliser votre pilote personnalisé tel que touchkit ou evtouch .

    
réponse donnée Soner 12.05.2013 - 09:50
la source
0

Comme identifiant pour les changements de xinput au redémarrage, j'ai ajouté un simple écran d'une ligne au chargement de la session:

#!/bin/bash
xinput --list | awk '/Atmel Atmel maXTouch Digitizer/ {print $7}' | awk '{split($0,a,"="); print a[2]}' | xargs xinput disable

Le nom de mon appareil est "Atmel Atmel maXTouch Digitizer", modifiez-le avec votre appareil (utilisez xinput --list pour le nom de l'appareil).

    
réponse donnée Emin Mastizada 20.02.2018 - 14:11
la source

Lire d'autres questions sur les étiquettes