Message 'E: dpkg a été interrompu, vous devez exécuter manuellement' sudo dpkg --configure -a 'pour corriger le problème.'

30

Chaque fois que j'essaie d'obtenir la mise à jour, je reçois l'erreur à la dernière ligne:

Ign http://in.archive.ubuntu.com trusty-updates/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-updates/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-updates/universe Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/main Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/universe Translation-en_IN
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Et puis, en fonction de l’erreur demandée lors de mon exécution:

$ sudo dpkg --configure -a
dpkg: error: parsing file '/var/lib/dpkg/updates/0009' near line 0:
 newline in field name '#padding'

Quoi maintenant? Puis-je sortir de l'erreur?

J'ai essayé cette lien .

    
posée user284303 15.06.2014 - 13:55
la source

2 réponses

62

Vous avez renvoyé un mauvais lien. Essayez les commandes ci-dessous sur le terminal pour supprimer tous les fichiers du répertoire /var/lib/dpkg/updates ,

cd /var/lib/dpkg/updates
sudo rm *

Puis lancez la commande ci-dessous pour obtenir les plus récentes,

sudo apt-get update
    
réponse donnée Avinash Raj 15.06.2014 - 14:05
la source
1

Ça marche pour moi! J'essayais d'installer le pilote sans fil lorsque cette erreur est survenue. J'ai dû supprimer les fichiers et aussi les fichiers de verrouillage.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
cd /var/lib/dpkg/updates
sudo rm *
sudo apt-get update

et ensuite, vous pouvez exécuter apt-get install sur le package que vous souhaitez installer

    
réponse donnée Aerosum 19.07.2014 - 05:36
la source

Lire d'autres questions sur les étiquettes