Un bruit étrange dans les écouteurs quand aucun son n'est joué

28

Il y a un bruit étrange de la part de mes écouteurs sur le Lenovo T440. Le son est comme quand vous accordez votre radio, mais vous obtenez une mauvaise fréquence et vous entendez un bruit désagréable. Le bruit commence lorsque Ubuntu 14.04 démarre et se termine après un arrêt. Il ne sort que par mes écouteurs, il n'y a pas de bruit à travers les haut-parleurs.

La chose étrange est que le bruit disparaît quand un son est joué ou si j'entre les préférences sonores. Mais lorsqu'un son est arrêté, il réapparaît après 10 secondes ou moins. De plus, le bruit diminue (ou peut-être même disparaît) si je mets mon chargeur pour ordinateur portable et arrête la musique.

Quel que soit le changement de volume, le niveau de bruit est le même. Il semble que la sortie ne soit pas désactivée après l'arrêt du son.

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC292 Analog [ALC292 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
    
posée user276016 29.04.2014 - 22:20
la source

9 réponses

25

Vous avez le même problème sur Dell XPS15 (modèle 9550, 2015 dans Xenial). Résolu dans alsamixer et en désactivant le canal loopback .

$ alsamixer

Naviguer vers loopback (complètement à droite, avec la clé ) et le définir sur Disabled à l'aide de la clé .

  • Aucun redémarrage nécessaire;
  • Aucune racine nécessaire;
  • Est-ce permanent pour autant que j'ai remarqué.
réponse donnée le hollandais volant 15.08.2016 - 18:53
la source
11

J'ai eu le même problème avec Dell Inspiron 3542 sous Ubuntu 14.04.2

Le problème semble être dans la fonctionnalité audio powersave.

Le bruit s'arrête lorsque j'ouvre les réglages du son ou lorsque je joue audio / vidéo. Le bruit recommence lorsque j'arrête la lecture audio / vidéo et ferme les réglages du son.

Cette solution a fonctionné pour moi: Modifier le fichier

$ sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave

changer la ligne

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

à

INTEL_AUDIO_POWERSAVE=false

Redémarrer.

Je n'ai plus eu à faire de bruit après ça.

    
réponse donnée mmindia 26.04.2015 - 04:17
la source
6

Il est possible que votre interface audio passe en économie d’énergie.

Si les commandes suivantes suppriment le problème jusqu'à ce que vous redémarriez ou que vous changiez d’alimentation, cela a quelque chose à voir avec les économies d’énergie:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller
echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
    
réponse donnée kvbx 09.10.2014 - 15:02
la source
5

J'ai eu le même problème. Je crois que c'est le bruit que votre microphone capte.

Allez dans Sound Settings , sous l'onglet Input , cochez la case Mute près de Settings for <microphone_name> Microphone (sans la case Mute en haut).

Cela devrait faire l'affaire.

    
réponse donnée Dean 09.10.2014 - 14:50
la source
3

J'ai eu exactement le même problème et aucune des méthodes ci-dessus n'a fonctionné pour moi.

Mon ordinateur portable est ASUS ROG-G501JW et la carte son est Realtek.

J'ai trouvé la solution dans ce fil de discussion: Des bruits blancs et sifflants dans les écouteurs, absents de Windows .

La définition de cette ligne dans /etc/modprobe.d/alsa-base.conf a résolu tous mes problèmes:

options snd-hda-intel model=dell-headset-multi
    
réponse donnée HatsOn 09.01.2017 - 22:19
la source
2

Avez-vous tlp activé?

Si oui, éditez / etc / default / tlp et définissez les valeurs de l'option d'économie d'énergie sur 0

SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=0

cela a fait l'affaire pour moi

    
réponse donnée Foxtur 09.05.2014 - 04:48
la source
0

J'ai eu ce problème sur Dell 3542 avec Ubuntu 16.04 GNOME et il a commencé à se produire après avoir installé TLP pour économiser de l'énergie. Donc, après avoir vu ici que le problème est lié à l'économie d'énergie, j'ai simplement désinstallé TLP et le problème a disparu.

    
réponse donnée Mita_ 06.11.2016 - 14:12
la source
0

J'ai eu ce problème sur Asus X200ca avec ElementaryOS Loki (Ubuntu 16.04) et les autres distributions Linux que j'avais utilisées. J'ai corrigé le problème avec

  • exécutez alsamixer (pas en mode sudo)
  • Accédez à Auto-mute Mode (en utilisant la flèche droite)
  • Modifiez-le pour activer (en utilisant la flèche vers le haut)

Maintenant, je n'ai plus le problème.

    
réponse donnée Jonathan Sudibya 23.01.2017 - 09:08
la source
0

J'ai trouvé une cause inhabituelle de mon bruit de fond excessif ... ma Civilization 5 (exécutée via Steam) ne sortait pas correctement. Le bruit de fond que j'entendais venait du jeu. J'ai utilisé "htop" pour trouver et tuer tous les processus de civilisation et, bien sûr, le bruit a diminué à chaque fois que j'ai tué un processus du jeu.

Donc, pas un problème Ubuntu ni audio; c'était en fait une application particulière (qui ne sort jamais de toute façon).

    
réponse donnée Cranky 18.11.2017 - 22:36
la source

Lire d'autres questions sur les étiquettes