Comment contrôler la luminosité

24

Je n'ai rien installé moi-même, mais seulement Ubuntu 12.04 LTS sur un Acer 4741g.

J'utilise Fn + à gauche / right pour changer la luminosité, mais a échoué.

Comment puis-je contrôler les niveaux de luminosité?

    
posée homelesser 30.04.2012 - 13:02
la source

12 réponses

39

Essayez ceci:

  1. Ouvrez un terminal ( Ctrl + Alt + T ).
  2. Ensuite, tapez sudo nano /etc/default/grub . Il vous demandera votre mot de passe. Saisissez-le.
  3. Autour de la 11ème ligne, il y aura quelque chose comme: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" . Changez-le en GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  4. Sauvegardez le fichier avec Ctrl + O suivi de Ctrl + X . Exécutez ensuite sudo update-grub dans le terminal.
  5. Redémarrez et voyez si le réglage du rétroéclairage fonctionne. Sinon, annulez les modifications que vous avez effectuées ci-dessus en appelant l'éditeur de texte comme aux étapes 1 et 2.

J'espère que ça aide.

Fonctionne pour Acer Aspire v3-571, Acer Aspire v3 571g, Hewlett Packard Bell EasyNote TS, Acer Aspire 4755G, Acer Aspire 5750-6866, Acer Aspire 5739, Lenovo T540p

    
réponse donnée Richard 30.04.2012 - 13:12
la source
13

OP indiqué dans Révisions 2 & amp; 3 de la question que les suivants ont fonctionné pour lui.

  

Je l'ai trouvé sur différents sites, il corrige le rétro-éclairage.

     

Exécutez la commande suivante dans Terminal:

gksu gedit /etc/default/grub
     

puis changez

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
     

à

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"
     

puis enregistrez et exécutez:

sudo update-grub 
     

puis redémarrez le système pour que les modifications prennent effet.

    
réponse donnée Aditya 13.04.2017 - 14:24
la source
11

Ubuntu 14.04 (13.10+) avec graphiques intel

Comment vérifier si la carte graphique est Intel

D'abord, vérifiez si votre carte graphique est Intel. Vous pouvez le vérifier depuis Paramètres système - & gt; Détails- & gt; Graphiques ou avec la commande suivante:

ls /sys/class/backlight

Vous devriez voir quelque chose comme:

ideapad  intel_backlight

Fixer le rétroéclairage

Assurez-vous que /usr/share/X11/xorg.conf.d/20-intel.conf existe. Si ce n'est pas le cas, créez-le vous-même et ajoutez ce qui suit:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Déconnexion et connexion. Terminé.

Merci à Abhishek

Republié une solution qui a fonctionné pour moi lien

    
réponse donnée Venkat Kotra 19.04.2014 - 14:43
la source
6

[Comme dans richy, mais] j'utilise GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

(Je suis sur un Aspire 5750-6866.) Cela fonctionne bien, les mêmes niveaux de contrôle que je possédais dans Windows.

J'avais l'habitude de bloquer ma luminosité au maximum avant de découvrir cela.

(Bien que les niveaux de luminosité restent réinitialisés après un redémarrage / mise en veille prolongée / arrêt)

    
réponse donnée WindowsEscapist 21.05.2012 - 16:42
la source
1

J'ai découvert une solution compatible avec mon ordinateur portable:

ajoutez ceci à /etc/rc.local :

echo 2 > /sys/class/backlight/acpi_video0/brightness
    
réponse donnée Robin 01.05.2012 - 21:26
la source
1

J'ai eu le même problème. J'ai un Travelmate P633-V et j'ai fait ce code pour le réparer.

Après avoir installé les scripts, mes fonctions FN-Left et FN-Right fonctionnent correctement.

Le script devrait fonctionner avec tous les périphériques Intel exposés / sys / class / backlight / intel_backlight

lien

    
réponse donnée Tony 02.12.2012 - 22:18
la source
1

J'ai eu ce problème quand je suis passé de 11.10 à 12.04. entrez dans le terminal code:

sudo gedit /etc/default/grub

Vérifiez ces lignes GRUB_CMDLINE_LINUX_DEFAULT et modifiez-le comme ci-dessous et enregistrez-le.

Après la mise à jour du grub

code: sudo update-grub

Code:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
'**GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"**'
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1" 
    
réponse donnée Sai Viswanath 14.12.2012 - 16:39
la source
1

Le moyen le plus simple et le plus rapide de le faire ... Utilisez cette commande

xrandr --output LVDS1 --brightness 0.5

Définissez la valeur entre 0 et 1 comme dans ce cas, il est de 0,5 Cela fonctionne pour moi Essayez ceci!

    
réponse donnée Sarthak killer 04.05.2013 - 08:43
la source
0

Essayez ce qui suit:

sudo gedit /etc/default/grub

Puis changez cette ligne: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" à GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" Ensuite, dans un type de terminal, sudo update-grub Redémarrez et voyez si le problème est résolu.

    
réponse donnée To Do 12.04.2013 - 19:08
la source
0

(Défaut) solution pour Ubuntu 12.04.1 :

Utilisez Ajouter des pilotes / Pilotes supplémentaires pour charger le pilote drom Cedar Trail (source fermée).

Pour Ubuntu 12.04.2 (et entièrement mis à jour 12.04 ), ce problème est résolu par des mises à jour plus récentes. pas nécessite le pilote propriétaire.

Si vous venez de faire une nouvelle installation de 12.04.2 , vous devez mettre à jour (et redémarrer) pour résoudre ce problème.

Au terminal, tapez sudo apt-get update && sudo apt-get upgrade puis sudo apt-get dist-upgrade .

Mise à jour: (28 avril 2013)

Étapes répétées, avec nouvelle installation. Cela n'a pas résolu le problème.

Lorsque la luminosité est fixe, tout réglage de la luminosité / luminosité (à l’aide des touches de fonction) ne semble pas fonctionner après cette correction.

En cours ...

    
réponse donnée david6 27.04.2013 - 11:40
la source
0

Même solution que le one-liner

Pour cette solution, aucune connaissance de nano n'est requise. Il est également pratique pour les scripts d’installation multi-machines.

sudo sed -i 's|^GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"|GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"|' /etc/default/grub && sudo update-grub
    
réponse donnée Serge Stroobandt 25.02.2014 - 22:37
la source
0

Je me débattais aussi avec ce problème. Mon ordinateur portable est un Acer Aspire E1-522. Je pourrais résoudre le problème de luminosité en passant du serveur X.Org X au pilote vidéo propriétaire AMD.

Pour ce faire, accédez à Software & amp; Mises à jour , puis accédez à l’onglet Pilotes supplémentaires . Là, vous pouvez probablement trouver le pilote propriétaire. Sélectionnez-le et cliquez sur Appliquer les modifications . Vous devrez redémarrer votre ordinateur pour savoir si cela vous a vraiment aidé.

    
réponse donnée marcelocra 05.03.2014 - 02:55
la source

Lire d'autres questions sur les étiquettes