Nvidia X Server Settings affiche uniquement 1 écran (ordinateur portable + moniteur externe connecté)

25

J'ai récemment installé une nouvelle copie d'Ubuntu 14.04 sur mon Dell M3800 doté d'une carte graphique Nvidia Quadro K1100M.

Plus tard, j'ai également connecté mon moniteur externe via HDMI (connecteur HDMI vers DVI). Ensuite, j'ai commencé à voir des performances d'écran médiocres sur l'écran de mon ordinateur portable. Par lenteur, je veux dire que mes frappes ou mes actions semblent toujours à la traîne. Assez drôle, cela semble se produire uniquement sur mon écran d'ordinateur portable, mon moniteur externe fonctionne correctement.

Je me suis assuré d'installer & amp; utiliser les pilotes propriétaires de Nvidia 331.38.

J'ai donc vérifié mes paramètres Ssytem & gt; Affiche. Et il affiche correctement 2 éboulis comme on le voit ci-dessous.

Mais alors je suis allé à Nvidia X Server settings & amp; il affiche un seul écran avec une résolution de grand écran, comme illustré ci-dessous.

Je pense que cela provoque des performances médiocres de mon ordinateur portable parce que je suppose que tant sur le moniteur externe et amp; mon écran d'ordinateur portable a un taux de rafraîchissement de l'écran différent.

Je viderais xorg.conf & amp; xandr de sortie ci-dessous,

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.38  ([email protected])  Wed Jan  8 19:53:14 PST 2014

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    BusID          "PCI:[email protected]:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:[email protected]:0:0"
EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
    Monitor        "Monitor0"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "ConstrainCursor" "off"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

xrandr output,

[email protected]:~/work$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 16384 x 16384
eDP-1-0 connected 1920x1080+0+0 344mm x 193mm
   1920x1080      60.0*+   59.9  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0     60.0  
   960x720        60.0  
   928x696        60.1  
   896x672        60.0  
   960x600        60.0  
   960x540        60.0  
   800x600        60.0     60.3     56.2  
   840x525        60.0     59.9  
   800x512        60.2  
   700x525        60.0  
   640x512        60.0  
   720x450        59.9  
   640x480        60.0     59.9  
   680x384        59.8     60.0  
   576x432        60.1  
   512x384        60.0  
   400x300        60.3     56.3  
   320x240        60.1  
VGA-1-0 disconnected
HDMI-1-0 connected 1920x1080+1920+0 598mm x 336mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1680x1050      59.9  
   1400x1050      59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
DisplayPort-1-0 disconnected
HDMI-1-1 disconnected

MISE À JOUR Après avoir enlevé le xorg.conf & amp; redémarrage. Voici son contenu.

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:[email protected]:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:[email protected]:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
EndSection
    
posée Chantz 25.08.2014 - 21:33
la source

10 réponses

3

Je suis tombé sur ce même problème, il se trouve que dans mon cas (peut-être aussi le vôtre), cela pose un problème matériel avec les cartes graphiques partagées dans les ordinateurs portables, où la carte Intel (économie d'énergie) est connecté au port HDMI et la carte nvidia (performance) ne l'est pas. Le pilote nvidia ne fonctionnera alors pas dans une configuration à double moniteur car il utilise par défaut la carte nvidia (performance). Je ne comprends pas la décision de conception (coût peut-être?).

J'ai trouvé que la solution dans mon cas consistait soit à basculer le mode par défaut en économie d'énergie dans les paramètres du pilote nvidia, soit à basculer vers le pilote nouveau (qui semble être le mode d'économie d'énergie par défaut). Je pourrais ensuite utiliser le second moniteur lorsque celui-ci est connecté via le port HDMI.

Essayez de passer en mode strict d’économie d’énergie et vérifiez si la configuration à deux moniteurs fonctionne avec les paramètres du système. Si c'est le cas, alors vous savez que vous avez ce problème de matériel bizarre. La manière dont les fabricants résolvent eux-mêmes ces problèmes dans d’autres systèmes d’exploitation, et pourquoi elle n’est pas corrigée dans les pilotes basés sur Linux, dépasse le cadre de mes connaissances.

Mais tout l’espoir n’est pas perdu. Il y a peut-être quelques autres (meilleures?) Réponses ici supporte les cartes graphiques hybrides (bourdon) ]. La version actuelle (3.2.1) de bumblebee est plutôt ancienne (2013) et je ne peux personnellement pas recommander de l'installer simplement parce que je ne l'ai pas fait, mais il semble que quelques utilisateurs ne rencontrent pas de problèmes. Il y a cependant une promesse de renaissance (consultez la section sur le développement des githubs du projet Bumblebee).

Que vous choisissiez de prendre la route bumblebee ou non, vous devriez vérifier les informations multi-écrans sur leur wiki [ lien ], c'est très instructif.

    
réponse donnée Patient-957 23.09.2016 - 02:59
la source
1

J'ai cet ordinateur portable et je l’utilise avec un écran externe 4k connecté via la prise de foudre (port d’affichage). Cela fonctionne très bien avec les deux écrans à 4k 60hz et je n'ai pas de xorg.conf. J'ai remarqué que l'utilisation du port HDMI peut ralentir les choses, alors que le port d'affichage est bien meilleur.

J'utilise 16.04, ce qui fonctionne très bien mais je n'ai pas exécuté 14.04 sur cet ordinateur portable, mais j'ai utilisé les deux versions de façon stable.

Je pense que le problème est que le pilote graphique n’est pas le bon. J'utilise nvidia-364 de lien et j'utilise les mises à jour à partir de là.

Incidemment, cet ordinateur portable et le dock owc thunderbolt fonctionnent très bien.

    
réponse donnée Amias 26.05.2016 - 11:41
la source
0

Sur chaque distribution Linux que j'ai utilisée chaque fois que j'ai utilisé, chaque fois que je branche un câble HDMI sur un autre moniteur, j'obtiens un changement de résolution et les éléments que vous signalez car les paramètres configurent la résolution de votre moniteur externe. Cependant, cela affecte également votre ordinateur portable car, pour définir les paramètres de l'autre moniteur, il doit d'abord les configurer sur votre ordinateur portable afin que le câble HDMI puisse diffuser ce que l'écran de votre ordinateur portable affiche à l'autre moniteur. Donc, à mon avis, il n'y a pas moyen de "réparer" cela.

Par exemple, je pourrais connecter un moniteur avec une résolution de 1366x768 mais je pourrais avoir un ordinateur portable avec une résolution de 1024x768. Les paramètres modifieront le réglage de la résolution et pourraient faire en sorte que l'ordinateur portable ait les bords de l'ébauche qui ne montrent pas la barre de menus d'Ubuntu. Cependant, ils ont été modifiés pour que le moniteur externe puisse le voir correctement.

    
réponse donnée The Killj0y 10.12.2015 - 17:42
la source
-1

Vérifiez si le bon pilote est utilisé:

$ lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2

Si ce n’est pas la liste noire du mauvais pilote:

$ sudo echo nouveau >> /etc/modprobe.d/blacklist.conf

redémarrez et regardez à nouveau quel pilote est utilisé.

Si le bon pilote est utilisé et que le problème persiste, vous devez configurer le fichier xorg.conf. Ici est un bon wiki, comment configurer le xorg.conf pour deux affichages

    
réponse donnée Arch User 06.09.2015 - 16:30
la source
-1

Vous pouvez essayer set screen0="buildtin", et screen1="monitor1", et c'est dans xorg.conf, et vous pouvez utiliser gedit depuis le terminal, et c'est dans ces deux sections:

      section monitor
      section screen

et cela pourrait bien fonctionner de cette façon.

    
réponse donnée Michael 11.09.2015 - 22:26
la source
-1

Allez simplement avec les pilotes NVidia officiels directement de NVidia! Pour votre carte, NVidia propose 352,63 lien et utilisez ce guide pour l'installer: lien

Cordialement

    
réponse donnée vit 22.01.2016 - 08:52
la source
-1

Malheureusement, c'est ainsi que fonctionne l’architecture à double affichage TwinView ... C’est ainsi que Nvidia a réussi à donner un moyen direct à une session X pour prendre en charge plusieurs moniteurs à la fois.

Vous pouvez essayer Xinerama mais malheureusement vous ne pourrez pas activer le compositing . lien

    
réponse donnée RomuloPBenedetti 06.02.2016 - 05:01
la source
-1

Cela peut être dû au fait que vos deux moniteurs fonctionnent dans une plage de 60 hrz. Essayez d'utiliser xrandr pour les définir manuellement sur 50, voire sur 40, et voir si cela vous aide. La plupart des cartes graphiques pour ordinateur portable ne supportent pas une fréquence de 120 hrz, ce qui est nécessaire pour deux moniteurs de plus de 60 ans.

    
réponse donnée Ufos 06.06.2016 - 11:25
la source
-1

la raison pour laquelle vous ne voyez pas l'affichage interne dans nvidia-settings lien

vous pouvez définir les paramètres de votre affichage interne via les paramètres système d'ubuntu - & gt; Affiche après avoir fait ce qui suit (je devais le faire car il a eu la résolution et quelque chose d'autre qui a gâché la mise en page sur l'affichage interne):

sudo apt-get installe compizconfig-settings-manager compiz-plugins

Comment faire fonctionner plusieurs écrans avec la station d'accueil?

Dans CCSM, allez à "Options générales" - & gt; "Paramètres d'affichage" et procédez comme suit: Désélectionnez "Détecter les sorties" Dans le tableau Outputs, définissez les résolutions de chacun de vos écrans. J'ai eu 1920x1080 + 0 + 0 comme la seule entrée dans laquelle j'ai ajouté 1920x1080 + 1920 + 0

capture d'écran des paramètres d'affichage du gestionnaire de paramètres compiz

Après cela, je suis allé dans les paramètres système d'ubuntu - & gt; Affiche et paramétré les paramètres de l’affichage interne.

    
réponse donnée shaun 21.08.2016 - 19:41
la source
-2

Votre problème peut être lié aux pilotes NVidia.

Essayez d’utiliser les nouveaux pilotes open source.

Allez à la page Additional Drivers et sélectionnez l’option "Open Source - Nouveau".

    
réponse donnée baestynator 04.12.2014 - 08:53
la source

Lire d'autres questions sur les étiquettes