Comment installer pgAdmin III pour postgreSQL 9.2?

24

J'ai un serveur Windows qui exécute postgresql 9.2. Je veux y accéder en utilisant pgAdmin III depuis mon poste de travail Ubuntu 12.10.

J'ai installé pgAdmin III à partir de synaptic et j'ai également essayé le téléchargement direct depuis le site postgreSQL à l'aide du programme d'installation du logiciel. Quoi qu'il en soit, je ne peux obtenir que pgAdmin III pour postgresql 9.1. Lorsque je lance pgAdmin III et que je pointe vers mon serveur, un message d'erreur m'indique que la base de données est 9.2 et que mon pgAdmin III est pour 9.1, n'est pas compatible avec 9.2.

Je peux accéder au serveur lui-même bien à partir de la boîte Ubuntu - J'ai des programmes Python qui frappent la base de données sans problèmes - mais j'ai besoin de pgAdmin III pour la version 9.2 sous Ubuntu 12.10.

Est-ce disponible? Où puis-je l'obtenir?

    
posée Vector 21.11.2012 - 11:41
la source

4 réponses

14

À partir de 2014, ce site Web décrit la manière de procéder pour Ubuntu et Debian: lien

Copier coller (2014-06-06) au cas où le site Web serait déconnecté, quoi qu'il arrive:

Packages PostgreSQL pour Debian et Ubuntu

Le groupe de développement global PostgreSQL (PGDG) gère un référentiel APT de packages PostgreSQL pour Debian et Ubuntu situé à l'adresse lien . Nous visons à construire des paquets de serveurs PostgreSQL ainsi que des extensions et des paquets de modules sur plusieurs versions de Debian / Ubuntu pour toutes les versions de PostgreSQL supportées. Actuellement, nous soutenons Debian 6.0 (Squeeze), 7.0 (Wheezy) et unstable (Sid) 64/32 bits (amd64 / i386) Ubuntu 10.04 (lucide), 12.04 (précis), 13.10 (saucé), 14.04 (fidèle) 64/32 bit (amd64 / i386) PostgreSQL 8.4, 9.0, 9.1, 9.2, 9.3, 9.4 bêta Extensions de serveur telles que Slony-I, divers langages PL et types de données Des applications comme pgadmin3, pgbouncer et pgpool-II Les paquets pour les anciennes versions de PostgreSQL et les anciennes distributions Debian / Ubuntu continueront à rester dans le référentiel; les mises à jour pour celles-ci seront fournies sur une base ad hoc.

Démarrage rapide

Créez /etc/apt/sources.list.d/pgdg.list. Les distributions sont appelées nom de code-pgdg. Dans l'exemple, remplacez Wheezy par la distribution réelle que vous utilisez:

deb http://apt.postgresql.org/pub/repos/apt/ wheezy-pgdg main

(Vous pouvez déterminer le nom de code de votre distribution en exécutant lsb_release -c.) Importez la clé de dépôt depuis lien , mettez à jour les listes de paquets et commencez à installer les paquets:

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install postgresql-9.3 pgadmin3

Sinon, ce script shell effectuera les étapes ci-dessus pour vous. 9.4 bêta uniquement: voir la FAQ sur les versions bêta Consultez la FAQ. Remarque: Ce dépôt fournit les méta-packages "postgresql", "postgresql-contrib" et "postgresql-client" qui dépendent des derniers packages postgresql-x.y, ..., similaires à ceux présents dans Debian et Ubuntu. Une fois la nouvelle version de PostgreSQL disponible, ces méta-packages seront mis à jour en fonction de la nouvelle version. Si vous souhaitez rester avec une version PostgreSQL particulière, vous devez installer des paquets spécifiques comme "postgresql-9.3" au lieu de "postgresql".

    
réponse donnée domen 06.06.2014 - 17:11
la source
56

C'est dans les dépôts.

sudo apt-get install pgadmin3

ou recherchez dans le centre de logiciels.

Si cette version est incorrecte, vous pouvez utiliser le PPA :

Si cela ne fonctionne pas, vous pouvez utiliser la source et la compiler vous-même à partir de source .

    
réponse donnée cprofitt 22.11.2012 - 17:32
la source
4

La version 16 de pgadmin3 ( lien ) est requise pour Postgres 9.2 et non dans le repo ou ce PPA pour Ubunutu 12.10.

Il semble que vous deviez le construire ou le mettre à niveau.

Je l'ai construit pour 12.10: lien - peut-être que ce binaire fonctionnera pour vous si vous êtes sur 12.10.

Si non et que vous devez le créer vous-même, assurez-vous d’installer

sudo apt-get install postgresql-server-dev-9.2
    
réponse donnée Tom Carchrae 01.08.2013 - 20:12
la source
0

Pour pgAdmin 4, vous pouvez également vous référer à cette page wiki: lien

J'ai essayé et installé pgAdmin 4 sur Ubuntu 16.04:

sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -cs)-pgdg main" > /etc/apt/sources.list.d/pgdg.list'
sudo apt-get install wget ca-certificates
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install postgresql-10 pgadmin4
    
réponse donnée Yuci 14.05.2018 - 16:58
la source

Lire d'autres questions sur les étiquettes