Comment empêcher l'ordinateur de dormir et / ou d'hiberner automatiquement?

25

J'utilise Ubuntu 12.04 et mon ordinateur portable * ne sortira pas de veille / suspension / veille prolongée. (Est-ce que le sommeil est la même chose que la suspension?) Je ne sais même pas laquelle de ces choses il fait. Quand j'ai fini de travailler pour la journée, je verrouille mon écran (Control-Alt-L). Lorsque je reviens le jour suivant, l'écran est en mode d'économie d'énergie et aucune saisie ou clic (sur le clavier / la souris USB ou le clavier / pavé tactile intégré) ni sur le bouton d'alimentation ne le ramènera à la vie. / p>

La seule façon de faire fonctionner ma machine est de maintenir le bouton d’alimentation enfoncé jusqu’à ce qu’elle s’éteigne, puis d’appuyer à nouveau sur le bouton d’alimentation pour le rallumer. De toute évidence, tout ce que j'avais ouvert la veille a pratiquement disparu - en particulier, mes machines virtuelles ont été grossièrement arrêtées sans aucun avertissement.

Cela me rend INSANE. Je passe la première heure de chaque journée de travail à essayer de faire en sorte que mon ordinateur cesse de se bloquer toute la nuit.

Ce que j'ai essayé:

  1. Modifier le org.freedesktop.upower.policy pour désactiver la suspension et la mise en veille prolongée.
  2. Définition des options de gestion de l’alimentation dans la section "Alimentation" de "Paramètres système".
  3. Examinez toutes les options de gestion de l'alimentation du BIOS (aucune ne semble pertinente pour la mise en veille / suspension / mise en veille prolongée).
  4. Lire chaque post / askubuntu du forum que je peux trouver et qui est tangentiellement lié au sujet.
  5. Ajoutez acpi = off aux arguments du noyau. (Le clavier et la souris USB ne fonctionnent pas, donc je n'ai pas attendu pour voir si la suspension était corrigée.)
  6. Ajoutez apm = off aux arguments du noyau.

Ma question: comment désactiver la mise en veille et / ou la mise en veille prolongée (ou tout autre élément similaire) de automatique dans Ubuntu 12.04. Je ne m'inquiète pas de savoir s'il est encore possible de dormir / suspendre / hiberner / quoi que ce soit en appuyant sur des boutons ou en exécutant des commandes ou en récitant des paroles de zeppelin. Je veux juste que mon ordinateur portable soit prêt pour le travail le matin.

* L’ordinateur portable est un Dell Latitude quelque chose ou autre. Je ne veux pas être trop précis car j'ai vu beaucoup de questions similaires se fermer pour être trop spécifique. Je pense que ma question est assez générique pour se poser - il s'agit d'une question sur la dernière version stable d'Ubuntu.

Lien vers dmesg

Lien vers /var/log/kern.log

EDIT:

Rien de ce que j’ai essayé jusqu’à présent n’a empêché Ubuntu de dormir la nuit, et quand il dort, rien de ce que j’ai essayé ne peut faire en sorte de le réveiller. J'ai vu quelques articles qui disent que les pilotes vidéo bogués peuvent causer des problèmes de réveil.

Hier soir, sur une intuition, j'ai essayé de passer en console (ctrl + alt + 1) avant de quitter le travail, juste pour voir ce qui se passerait. Ce matin, lorsque je me suis réveillé, l'ordinateur s'est instantanément réveillé sur la console. Je suis passé à Gnome (ctrl + alt + 7) et bien que l'écran ait paru gelé, j'ai tapé mon mot de passe, appuyé sur Entrée et préparé du café. Lorsque je suis revenu quelques minutes plus tard, mon bureau était prêt, comme je l'ai laissé la nuit dernière.

Je vais continuer à essayer ceci pour voir si c'est une solution fiable.

EDIT 2:

Pas de dés. Passer à la console après la déconnexion ne fait rien pour moi ... je dois toujours redémarrer mon ordinateur chaque matin. Ça me rend fou ... Je ne peux pas croire à quel point la suspension est erratique sur Ubuntu. Ou le fait qu'il ne peut pas simplement être désactivé.

    
posée Mark E. Haase 29.06.2012 - 16:34
la source

8 réponses

24

Voici les deux méthodes Gnome 3 communes qui désactivent généralement la suspension; sinon vous pouvez essayer de démarrer avec le paramètre acpi=off :

  1. Paramètres d'alimentation:

  2. gnome-tweak-tool (installez si nécessaire):

réponse donnée ish 29.06.2012 - 18:36
la source
14

Dans Paramètres système ou en effectuant une recherche dans Dash, accédez à Paramètres d'alimentation. Vous trouverez ce dont vous avez besoin là-bas;)

Et pour empêcher le verrouillage, accédez à Luminosité et verrouillage:

    
réponse donnée Dart 31.07.2012 - 23:23
la source
5

Pourquoi ne pas consulter l'indicateur d'application Caffeine . Il fait exactement ce que vous voulez et est très facile à utiliser.

    
réponse donnée digvijay91 29.06.2012 - 23:12
la source
4

Dans un économiseur d’écran de type tableau de bord, cliquez dessus. Lorsque la fenêtre s'ouvre, cliquez sur l'onglet Avancé et décochez Gestion de l'alimentation activée.

    
réponse donnée Mitch 29.06.2012 - 16:51
la source
2

Je ne sais pas si vous avez résolu ce problème avec suspension / hibernation, mais si ce n’est pas le cas, j’ai résolu le problème avec un script (j’ai eu le même problème et cela a fonctionné pour moi). :) Créez un script dans le répertoire /etc/pm/sleep.d / (" sudo gedit /etc/pm/sleep.d/ 00CPU ", par exemple) avec le contenu suivant:

#!/bin/sh
# Workaround for concurrency bug in xserver-xorg-video-intel 2:2.4.1-1ubuntu10.
# Save this as /etc/pm/sleep.d/00CPU

. "${PM_FUNCTIONS}"

case "" in
hibernate|suspend)
for i in /sys/devices/system/cpu/cpu*/online ; do
echo 0 >$i
done
;;
thaw|resume) 
sleep 10 # run with one core for 10 secs
for i in /sys/devices/system/cpu/cpu*/online ; do
echo 1 >$i
done
;;
*)
;;
esac

Ensuite, donnez simplement au script la permission d’exécuter ( sudo chmod 755 00CPU ) et ... c’est tout! Profitez de votre Ubuntu.

P.S .: désolé pour mon anglais. P.S.2 .: vous pouvez modifier la valeur "sleep 10", avec "sleep 5" par exemple, afin que votre cœur de deuxième processeur s'exécute un peu plus tôt.

Remarque: Cela semble être un problème de simultanéité avec certaines versions de noyaux et certains processeurs multicœurs.

    
réponse donnée Kaled Kelevra 23.02.2013 - 15:51
la source
2

@Kaled Kelevra, j'ai créé le fichier 00CPU et suivi toutes les étapes, malheureusement ma machine s'est encore endormie après 10 minutes.

Sur les forums ArchLinux , j'ai trouvé une solution qui me convenait. Voir la réponse # 21.

Voici comment j'ai corrigé le mien dans /etc/X11/xorg.conf :

Section "ServerLayout"

    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Evdev Mouse" "CorePointer"

  Option "BlankTime" "0"
  Option "StandbyTime" "0"
  Option "SuspendTime" "0"
  Option "OffTime" "0"

Je viens d'ajouter les 4 options que vous voyez ici. Testez-le et publiez-le. Bonne chance.

    
réponse donnée Buya Nami 28.03.2013 - 19:54
la source
1

Vous pouvez utiliser les gsettings pour activer ou désactiver l’inactivité du moniteur:

  • Désactiver la désactivation de l'écran
      

    gsettings set org.gnome.desktop.session idle-delay 0

  • Activer la désactivation de l'écran avec un délai de 5 min
      

    gsettings set org.gnome.desktop.session idle-delay 300

source: lien

    
réponse donnée streak 26.06.2017 - 18:59
la source
0

Avec 12.04, j'ai remarqué que mon ordinateur semble être très difficile à activer lorsque l'écran de veille / verrouillage a été appelé, en particulier lorsqu'il est verrouillé pendant plus de quelques minutes. Le système n'est pas vraiment suspendu ou hiberné - cela semble juste ainsi.

Je trouve que je peux attendre plusieurs minutes et que le système me demandera éventuellement mon identifiant et mon mot de passe et que je suis de retour en activité. Avant de me rendre compte que je reviendrais, je l’éteindrais comme vous.

Je ne sais pas pourquoi cela prend si longtemps, c'est probablement un bug. Cela aide-t-il simplement d'attendre 3 à 10 minutes? Si oui, nous voyons peut-être la même chose.

    
réponse donnée John S Gruber 30.06.2012 - 00:41
la source

Lire d'autres questions sur les étiquettes