Gardez Ubuntu Server en cours d'exécution sur un ordinateur portable avec le couvercle fermé?

26

J'ai décidé d'utiliser mon Eee PC 1001HA comme serveur domestique. Je l'ai connecté via Wi-Fi au routeur, exécutant Ubuntu Server 12.04. Tout fonctionne bien sauf ce problème ennuyeux:

quand je ferme le couvercle, le serveur ssh cesse de fonctionner et, je suppose, wlan0 aussi.

J'ai essayé le BIOS et rien, aucune option sur le couvercle. Mon wlan0 est un RaLink RT3090.

J'ai essayé ls -lrt /var/log entre les dérivés de couvercle, mais je ne peux pas comprendre ces journaux sataniques. Je peux les partager si nécessaire.

pm-powersave.log semble être mis à jour entre les mouvements de la paupière. Donc je suppose que je dois désactiver ce service "powersave". Puis-je faire ceci? Cela ne me dérange pas si le serveur fonctionne toute la journée.

N'oubliez pas qu'il n'y a pas d'interface utilisateur, c'est un netbook avec un couvercle et son connecté à l'adaptateur secteur.

edit: Ceci est juste une solution de contournement mais je peux cliquer sur le bouton d’alimentation et fermer rapidement le couvercle. De cette façon, le serveur démarre normalement et se connecte automatiquement au réseau sans fil. (trouvé ici )

    
posée ffunenga 25.05.2012 - 02:07
la source

6 réponses

48

Pour désactiver l’entrée en mode veille, j'ai dû modifier le fichier /etc/systemd/logind.conf et modifier la ligne:

#HandleLidSwitch=suspend

à

HandleLidSwitch=ignore

Alors fais

sudo service systemd-logind restart
    
réponse donnée user386160 09.03.2015 - 01:59
la source
9

juste pour confirmer, 14.04 utilisateur du serveur LTS ici sur un Dell X100e.

sudo apt-get install acpi-support
sudo vi /etc/default/acpi-support # and then set SUSPEND_METHODS="none"
sudo /etc/init.d/acpid restart

Fermeture instantanée du couvercle, pas de problèmes.

Il suffit de poster pour confirmer la solution des affiches précédentes en tant que seul correctif nécessaire. Pas besoin (actuellement) de faire autre chose en plus de cela.

    
réponse donnée Stephan 08.08.2014 - 10:52
la source
5

Tout cesse de fonctionner parce que ... l'ordinateur portable s'endort! (mode suspension).

Pour arrêter, il suffit de désactiver l’événement ACPI lid-button .

Modifiez /etc/acpi/event/lidbtn et commentez les deux dernières lignes:

  # /etc/acpi/events/lidbtn
  # Called when the user closes or opens the lid
  event=button[ /]lid  # comment this out with a # at the beginning
  action=/etc/acpi/lid.sh # same here 

Redémarrez, et ça devrait être ça.

    
réponse donnée ish 25.05.2012 - 03:00
la source
3

J'utilise 14.04 LTS avec ASUS EEE.

La solution de Stephan ci-dessus n'a pas fonctionné pour moi. Cependant, cette réponse a fonctionné.

    
réponse donnée Max 10.10.2014 - 09:36
la source
2

Je pense que définir l'option SUSPEND_METHODS="none" dans /etc/default/acpi-support fait la même chose

    
réponse donnée OmPS 11.01.2014 - 06:13
la source
0

Cela a fonctionné pour moi - mon installation d'Ubuntu Server n'avait pas non plus de / etc / acpi / event / lidbtn, mais j'ai installé le package acpi-support, puis il est apparu.

Le paquet installe tout un tas d’autres paquets liés à X11 mais n’active pas le mode graphique, ne vous inquiétez pas.

Une fois que j'ai commenté les deux dernières lignes comme ci-dessus, mon portable est resté en marche avec le couvercle fermé.

    
réponse donnée El Dubya 14.10.2013 - 05:00
la source

Lire d'autres questions sur les étiquettes