Ubuntu dernière version de LTS est maintenant disponible, pourquoi ne puis-je pas effectuer une mise à niveau depuis la version précédente? Et comment puis-je forcer la mise à niveau? [dupliquer]

24

Ubuntu Server 16.04 est maintenant disponible.

J'ai Ubuntu (serveur) 14.04.4 LTS, mais quand j'essaie de faire un do-release-upgrade , il me dit qu'il n'y a pas de mise à jour disponible.

  1. Pourquoi?

  2. Comment puis-je mettre à niveau mon serveur pour obtenir la nouvelle génialité?

[email protected]:~$ uname -a
Linux lounge 4.2.0-34-generic #39~14.04.1-Ubuntu SMP Fri Mar 11 11:38:02 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[email protected]:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:        14.04
Codename:       trusty

[email protected]:~$ do-release-upgrade 
Checking for a new Ubuntu release
No new release found
    
posée David 21.04.2016 - 21:17
la source

2 réponses

22

REMARQUE: Avec Ubuntu 18.04 LTS, il en va de même avec la première version qui doit sortir fin juillet 2018. Les étapes ci-dessous doivent être identiques, mais avertir que mon expérience de la mise à niveau du 16.04 au 18.04 ce temps ne s'est pas passé aussi bien. Je recommande d'attendre la publication du premier point (18.04.1) en juillet avant de procéder à la mise à niveau.

Comme il est dit dans les notes de version que LTS upgrades will be enabled with the 16.04.1 LTS point release, in approximately 3 months time.

Cependant, si vous ne voulez pas attendre, la commande suivante indiquera à votre installation Ubuntu d'installer la dernière version de devel-release :

AVERTISSEMENT: assurez-vous que votre système est à jour, que toutes les applications fonctionnent correctement et qu’il n’ya aucune erreur de partition. Recommandez d'exécuter fsck sur votre système à partir du mode de récupération avant de procéder à la mise à niveau.

Pour console / texte uniquement

sudo do-release-upgrade -d

Pour les interfaces graphiques depuis une fenêtre de terminal ou en utilisant Alt + F2

update-manager -d

qui exécutera update-manager et montrera qu'une nouvelle version 16.04 est disponible pour la mise à niveau. Suivez les instructions à l'écran pour passer à Ubuntu 16.04LTS .

NOTES de la mise à niveau que j'ai observée:

Le processus de mise à niveau désactive tous les référentiels tiers situés dans le dossier /etc/apt/sources.list.d/ . Il sauvegarde également vos anciens /etc/apt/sources.list à /etc/apt/sources.list.distUpgrade . Les fichiers ne seront pas supprimés, mais les lignes de référentiel contenues dans les fichiers seront commentées, sauf dans le fichier sources.list.distUpgrade . J'ai constaté que je ne pouvais pas supprimer le commentaire devant le référentiel et que cela ne fonctionnait qu'avec la commande apt-get update . Au lieu de cela, j'ai dû rajouter les référentiels en les ajoutant manuellement au fichier /etc/apt/sources.list ou en les ajoutant à nouveau avec la commande add-apt-repository .

PlayOnLinux repository n'est pas encore compatible avec Xenial. Si PlayOnLinux est installé, il sera mis à jour à partir des référentiels Xenial.

EDIT: les repos Google et VirtualBox ont été mis à jour.

L'ajout des dépôts Google Chrome et VirtualBox affichera les messages suivants pendant un apt-get update . Celles-ci ont été rapportées ici et, espérons-le, elles seront bientôt mises à jour. Les applications seront toujours mises à jour sans aucun problème.

W: http://download.virtualbox.org/virtualbox/debian/dists/xenial/InRelease: Signature by key 7B0FAB3A13B907435925D9C954422A4B98AB5139 uses weak digest algorithm (SHA1)
W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)

Le référentiel graphics-drivers pour Ubuntu contenant les pilotes NVIDIA devra être rajouté. L'exécution simple de sudo add-apt-repository ppa:graphics-drivers/ppa fonctionne avec Xenial et les pilotes mis à jour après l'installation. J'ai dû recopier mon ancien fichier xorg.conf pour que mes moniteurs fonctionnent correctement.

fail2ban devait être purgé avec mes anciens fichiers de configuration personnalisés. Réinstallé sans problème et semble fonctionner correctement.

D'autres applications diverses devaient être réinstallées. sudo apt-get install --reinstall <application>

Dans l'ensemble, la mise à niveau s'est bien déroulée et se sent vraiment stable.

$ cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"
NAME="Ubuntu"
VERSION="16.04 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
UBUNTU_CODENAME=xenial

$ uname -a
Linux terrance-Linux 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:   xenial
    
réponse donnée Terrance 22.04.2016 - 00:39
la source
39

La réponse se trouve dans les notes de version

.
  

14.04 Les mises à niveau de LTS à LTS seront activées avec la version 16.04.1 LTS, dans environ 3 mois.

La stabilité dans une version LTS vient en premier.

    
réponse donnée mikewhatever 21.04.2016 - 21:21
la source

Lire d'autres questions sur les étiquettes