Erreur d'installation de Steam sur 14.04 Ubuntu 64bit

23

J'ai essayé certaines des solutions postées ailleurs dans le forum de support, l’une semblait fonctionner, mais après une mise à jour rapide, je me suis retrouvé à la case départ. Je suis un nouvel utilisateur Linux et je suis déjà en apprentissage :) Merci pour toute aide

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.3)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Press return to continue: 
    
posée Wes Young 21.02.2015 - 04:41
la source

5 réponses

32

C'est ce qui fonctionne réellement pour 14.04:
sudo apt-get install libc6:i386
sudo apt-get install libgl1-mesa-glx-lts-trusty:i386

Preuve: J'espère que cela aide les autres.

    
réponse donnée JorgeArtware 07.09.2015 - 09:35
la source
29

Solution de contournement:

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386

La commande est un peu différente si vous utilisez Ubuntu 14.04.3 ou une version ultérieure avec la pile d'activation matérielle (noyau 3.19):

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386
    
réponse donnée Liam McLennan 23.02.2015 - 23:07
la source
3

C'est en fait un bug. J'ai déjà signalé ce problème sur Bugs Launchpad et vous pouvez le suivre en utilisant ces deux liens de suivi de bogue.

Vous pouvez le corriger manuellement, mais c'est compliqué. Ubuntu devs le réparera bientôt, alors je vous conseille d'attendre les mises à jour.

    
réponse donnée Peter Maciejko 21.02.2015 - 21:53
la source
1

Pour Ubuntu 14.04.3, essayez cette solution de contournement:

sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386
    
réponse donnée Peter Maciejko 05.10.2015 - 06:42
la source
1

J'ai trouvé que cela fonctionnait parfaitement pour moi.

sudo apt-get install steam -y
    
réponse donnée Goddard 26.10.2015 - 02:31
la source

Lire d'autres questions sur les étiquettes