remmina ne fonctionne plus "ne peut pas se connecter au serveur RDP localhost"

25

Jusqu'à hier soir, remmina fonctionnait bien. Je pouvais exécuter RDP via un tunnel SSH et tout allait bien.

Puis il a cessé de fonctionner. Je peux aller aussi loin que la boîte de dialogue de mot de passe pour ma machine de travail, mais il dit juste Cannot connect to RDP server localhost .

Je n'arrive même pas à trouver des journaux intéressants. J'ai réinstallé remmina, effacé mon répertoire .remmina , redémarré ma machine et même redémarré ma passerelle.

Juste pour rendre les choses vraiment bizarres, mon portable (qui a la même configuration - Ubuntu et Remmina les plus récentes) peut très bien faire la connexion. Il passe même par le même routeur, même sans fil.

Des pensées?

    
posée Chris Curvey 26.09.2012 - 22:29
la source

6 réponses

38

Je ne sais pas pourquoi cela a fonctionné, mais j'ai commencé à modifier les paramètres un à la fois. Lorsque j'ai édité les propriétés de connexion, j'ai regardé l'onglet "Avancé" et changé la sécurité de "négocier" à "TLS", et voilà, tout fonctionne.

Étrangement, "négocier" fonctionne toujours sur l’ordinateur portable, mais au moins, je suis de retour avec mon écran plus grand:)

    
réponse donnée Chris Curvey 27.09.2012 - 00:15
la source
35

Cela m'est arrivé, et j'ai trouvé cette réponse qui a résolu le problème. Juste rm ~/.freerdp/known_hosts et réessayez.

Apparemment, cela se produit lorsque les clés du serveur de tunnel changent. Voir ce bogue .

UPDATE

Le premier lien pointe maintenant vers une réponse supprimée, voici donc quelques informations supplémentaires sur ce lien:

  
  • Il semble que le fichier "known_hosts" contienne des données de routage pour chaque serveur, que celles-ci deviennent parfois obsolètes et que Remmina   essaie de se connecter en utilisant les données obsolètes, il échoue. Supprimer le   Le fichier known_hosts résout ce problème. - Erel Segal-Halevi 13 décembre 12   à 10:06

  •   
  • FWIW, mon problème n’a rien à voir avec known_hosts (comme expliqué ci-dessous), mais tout à voir avec les paramètres de sécurité: voir    lien   pour plus de détails. - Tomislav Nakic-Alfirevic 24 avril 14 à 10:58

  •   
  • Totalement travaillé, je me demandais où les certs étaient stockés. J'ai eu le même problème pour la plupart, utilisais Remmina à RDP à un certain   machine, puis un jour il a cessé de fonctionner (rien sur la télécommande   machine changée). Les autres connexions RDP que j'avais enregistrées fonctionnaient toujours,   sauf pour cette machine. Il est arrivé à utiliser NLA auth, qui   semble faire partie du problème avec le dernier Remmina pas sauver   certs - Nicholi 26 avril 13 à 20h26

  •   
  • merci, il se connectait parfaitement alors j'ai reformaté le serveur et il a cessé de fonctionner, en supprimant la ligne pour cet hôte a fonctionné. -   Bor691 15 janvier 14 à 8h50

  •   
  • Je dois utiliser deux services sur la même adresse, mais sur des ports différents, et l’utiliser à plusieurs reprises est la seule façon de me connecter aux deux. -   Gringo Suave 13 octobre 14 à 18:55

  •   
    
réponse donnée itsadok 08.08.2013 - 10:33
la source
4

Cela m'est arrivé lorsque j'ai copié ma configuration remmina (sous ~/.remmina ) d’une machine à une autre. Peut-être que les versions remmina étaient différentes; changer la sécurité n'a pas aidé, mais à supprimer et recréer la connexion.

    
réponse donnée user1889941 12.02.2013 - 23:25
la source
1

Le problème est lié au paramètre viewmode = 1 dans le fichier de configuration enregistré. Si vous redimensionnez la fenêtre, elle devrait être actualisée et commencer à afficher la session. Changer cette valeur booléenne à 0 obligera la fenêtre à utiliser les valeurs par défaut et elle actualisera le chargement. Le problème est que si vous redimensionnez la fenêtre après le démarrage de la session, remmina changera ce paramètre.

A work around would be to set the window_maximize=0 to true and then just click/press the maximize button/shortcut to bring it back to your settings. 
window_maximize=1 
window_height=960 
viewmode=1 
Window_width=1440
    
réponse donnée JayMcB74 27.02.2013 - 15:21
la source
1

Cela a fonctionné pour moi en changeant la sécurité en NLA pour une raison inconnue.

    
réponse donnée Johan Wallgren 03.05.2017 - 10:38
la source
0

Probablement une réponse stupide, mais le problème pour moi était que j'ai essayé de me connecter via un réseau Wi-Fi ouvert (non crypté) et que remmina ne le permettrait pas. Une fois connecté à un réseau sécurisé, tout fonctionnait comme prévu.

    
réponse donnée ErnestScribbler 16.06.2017 - 00:38
la source

Lire d'autres questions sur les étiquettes