Pourquoi ne pas monter les fichiers de lecture dans "/etc/fstab.d/"?

23

J'essaie de configurer un volume monté automatiquement et j'ai remarqué qu'il y a maintenant un /etc/fstab.d/ sur mon serveur. J'ai créé un nouveau fichier dans le répertoire avec les contenus suivants:

# backupstore: large volume
/dev/mapper/bagend-backupstore  /mnt/backupstore        ext4    auto,relatime,users,sync        0       0

Mais quand je lance mount -a le volume n'est pas monté. Aussi, quand je lance mount /mnt/backupstore ou /dev/mapper/bagend-backupstore , on me dit que le système n'a pas pu trouver l'entrée dans fstab (et pour préempter: oui, le périphérique et le point de montage sont corrects - je peux facilement le monter avec mount -t ext4 /dev/mapper/bagend-backupstore /mnt/backupstore )

Lorsque je supprime le fichier de /etc/fstab.d/ et que je mets l’entrée dans le fichier /etc/fstab principal, je n’ai aucun problème à monter le volume.

Alors, la commande mount peut-elle être faite pour vérifier les entrées dans /etc/fstab.d/ et si oui, que dois-je faire pour y arriver?

    
posée HorusKol 26.07.2012 - 10:24
la source

2 réponses

20
  • /bin/mount ne peut pas encore lire /etc/fstab.d , seule la bibliothèque ( libmount ) peut le faire.
  • Ceci est un bug "liste de souhaits" connu dans util-linux , le package qui fournit mount
  • La fonctionnalité a été ajoutée dans la dernière util-linux 2.21 (la notes de version dire" Utiliser l'argument de filtre de scandir * pour récupérer les fichiers /etc/fstab.d/*.fstab ")
  • Puisque même Debian Unstable (Sid) est sur la version 2.20-x de util-linux , je doute que nous verrions 2.21 dans Ubuntu jusqu'à 13.04
  • Si vous en avez besoin plus tôt, vous pouvez soit compiler 2.21 à partir du kernel.org source , mais je vous recommande d’attendre au moins qu’il atteigne Debian ( util-linux fournit également un certain nombre d’autres utilitaires / bibliothèques critiques du système)
réponse donnée ish 26.07.2012 - 11:18
la source
11

Le support /etc/fstab.d a été rétabli depuis mount (8) après la discussion en amont . Les répertoires des onglets de montage sont uniquement pris en charge par libmount. Il n'est pas prévu de prendre en charge fstab.d in mount (8) par défaut.

Le problème est que /etc/fstab est de facto standard utilisé sur de nombreux endroits (libc, systemd, programmes d’interface utilisateur, ..) et il est irréel de souhaiter que tous les endroits puissent être modifiés pour prendre en charge fstab.d .

Quoi qu’il en soit, vous pouvez utiliser un nouveau mount (8) à partir de util-linux & gt; = 2.21 et une nouvelle option --fstab <path> pour spécifier une autre table de montage, cette option prend également en charge les répertoires. Cela signifie que vous devez spécifier explicitement le répertoire - mount (8) ne le lira pas par défaut. Voir la page de manuel mount (8) pour plus de détails.

    
réponse donnée Karel Zak 30.07.2012 - 14:14
la source

Lire d'autres questions sur les étiquettes