"Le logiciel ne peut pas être installé ou supprimé car le service d’authentification n’est pas disponible. "

26

J'ai 12.10 ubuntu et quand j'essaie de supprimer / installer des programmes, j'obtiens une notification:

  

Le logiciel ne peut pas être installé ou supprimé car le service d’authentification n’est pas disponible.

(org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name':  ':1.104'}): org.debian.apt.install-or-remove-packages

Lorsque je me connecte en tant qu'utilisateur root (au lieu d'utiliser le compte d'utilisateur que j'utilise régulièrement), je n'ai aucun problème.

    
posée grr 18.11.2012 - 19:41
la source

6 réponses

27

Il semble que l'agent d'authentification du kit de règles ne soit pas démarré dans le programme des applications de démarrage.

Ajoutez la ligne ci-dessous aux applications de démarrage.

 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

Notez également que cela a déjà été soulevé en tant que bogue et que la correction est fournie dans software-center - 5.3.9

Mettez à jour votre centre logiciel pour résoudre le problème.

Voici les détails sur le bogue

    
réponse donnée devav2 18.11.2012 - 19:59
la source
5

J'ai eu le même problème. En effet, Agent d'authentification PolicyKit n'a pas été coché dans Programmes de démarrage . Je l'ai vérifié et le problème a été résolu. J'espère que cela en prendra soin pour vous aussi.

    
réponse donnée Zoids 29.12.2012 - 19:19
la source
4

Je pense que vous pouvez simplement réinstaller le logiciel ubuntu, il sera réparé, je l'ai fait. Il vous suffit de taper cette commande dans votre terminal pour réinstaller le centre logiciel

sudo apt-get update; sudo apt-get --purge --reinstall install software-center software-properties-common software-properties-gtk

    
réponse donnée Mohamed Yaser 16.05.2013 - 11:17
la source
1

@Davav et @Zoids ont raison. Il y a une question similaire sur SO ici: Erreur d’authentification lors de la tentative d’installation ou de désinstallation à l’aide d’Ubuntu Software Center (14.04)

Ajouter le lien pour aider les autres. En plus de l'ajouter aux éléments de démarrage, vous devez même exécuter l'application pour que l'application fonctionne pour votre session en cours. Par conséquent, lancez l'application en tant que sudo /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

    
réponse donnée Vinod Tigadi 28.05.2015 - 08:21
la source
0

Si cela peut vous aider, j'utilise xubuntu 14.04 et j'ai le même problème. J'ai eu le kit de stratégie lancé au démarrage, mais le package policykit-1-gnome n'a pas été installé. Une fois installé, cela a fonctionné!

    
réponse donnée Franperr 12.02.2015 - 01:13
la source
0

L'agent d'authentification PolicyKit a été décoché dans les programmes de démarrage. Je l'ai vérifié et le problème a été résolu.

    
réponse donnée Fabricio DEL PUERTO 14.07.2015 - 21:03
la source

Lire d'autres questions sur les étiquettes