Comment désactiver la suspension en 14.04?

26

Pour une raison quelconque, Ubuntu n'avait pas eu un bon support pour la suspension. Créer le fichier /etc/polkit-1/localauthority/50-local.d/com.ubuntu.disable-suspend.pkla avec l'option de suspension désactivée ci-dessous dans le menu principal au 12.04. Mais, le même ne fonctionne pas après le passage de 12.04 à 14.04.

[Disable suspend by default]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no

Comment désactiver la suspension dans 14.04?

    
posée Praveen Sripati 22.04.2014 - 17:06
la source

3 réponses

28

Créez un nouveau fichier appelé /etc/polkit-1/localauthority/50-local.d/com.ubuntu.disable-suspend.pkla avec le contenu suivant:

[Disable suspend (upower)]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable suspend (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.suspend
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable suspend when others are logged in (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.suspend-multiple-sessions
ResultActive=no
ResultInactive=no
ResultAny=no

puis redémarrez.

Cela dit à PolicyKit de dire automatiquement "non" à chaque fois que quelque chose demande s'il est OK / possible de suspendre. Les menus de déconnexion réagiront en supprimant automatiquement le choix du menu «Suspendre».

Je ne comprends pas très bien pourquoi, mais le paramètre upower est nécessaire pour KDE mais n'affecte pas Unity. Les paramètres login1 sont nécessaires pour Unity mais n'affectent pas KDE.

    
réponse donnée Richard Hansen 26.06.2014 - 07:38
la source
9

Pour moi, il est important de simplement désactiver le "Suspend automatique"
Parce que je veux toujours pouvoir faire la "suspension manuelle"
dans /etc/polkit-1/localauthority/50-local.d/com.ubuntu.disable-suspend.pkla

Donc, j'ai utilisé:

[Disable suspend (upower)]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no
ResultInactive=no
ResultAny=no

[Disable suspend (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.suspend
ResultActive=yes
ResultInactive=no
ResultAny=yes

[Disable suspend when others are logged in (logind)]
Identity=unix-user:*
Action=org.freedesktop.login1.suspend-multiple-sessions
ResultActive=yes
ResultInactive=no
ResultAny=yes

Maintenant, je peux cliquer sur "Suspendre" dans le menu de déconnexion. Mais le PC continue à fonctionner à moins que je l'envoie à "Suspend".

    
réponse donnée linolino 03.01.2015 - 17:16
la source
1

Vous ne pouvez pas. Ceci est un bug dans polkit en 14.04. Pour contourner ce problème, vous pouvez

chmod 000 /usr/lib/pm-utils/bin/pm-action

Si vous votiez pour le bogue du tableau de bord mentionné ci-dessus, cela aiderait.

    
réponse donnée dmd 24.04.2014 - 22:51
la source

Lire d'autres questions sur les étiquettes