Pourquoi y a-t-il un délai entre le moment où une touche est pressée et le moment où elle est acceptée?

24

C'est l'un des problèmes les plus farfelus et les plus étranges que j'ai jamais rencontrés. Mon clavier fonctionnait parfaitement jusqu'à hier sur Ubuntu 13.04. Cependant, lorsque je démarre sur Ubuntu aujourd'hui, j'ai soudain trouvé que toutes les touches fonctionnaient, mais je dois les maintenir pendant une seconde environ pour qu'elles fonctionnent.

  • Ce comportement est vrai pour toutes les clés sauf pour les clés Num Lock , Caps Lock et Scroll Lock , l’indicateur de sur mon clavier s’allume dès que j’appuie sur ces touches.

  • Le clavier fonctionne bien sur l’écran de connexion où je mets mon mot de passe.

  • Le clavier fonctionne également normalement si j'utilise la session Invité au lieu de mon compte d'utilisateur normal.

  • Je n’ai fait aucun remappage de touches et n’utilisais pas le clavier standard anglais (États-Unis).

  • J'ai manipulé les paramètres du clavier dans les paramètres système, mais en vain.

  • J'ai Windows 7 en double amorçage et le clavier fonctionne parfaitement.

Pourquoi suis-je confronté à un tel comportement et comment le normaliser?

PS: Utilisation de Clavier Logitech Classic K100 (modèle USB) .

    
posée Aditya 25.09.2013 - 21:26
la source

8 réponses

25

Parce que vous avez probablement placé l'option Clés lentes dans Paramètres système Accès universel Taper . Désactivez-le:

    
réponse donnée Radu Rădeanu 04.10.2013 - 23:00
la source
1

Je ne peux pas poster une réponse correcte avec des images et tout cela parce que je suis sur un ordinateur Windows uniquement en ce moment mais, essayez d'aller aux paramètres du clavier et vérifiez s'il y a un paramètre de sensibilité, il y a aussi essayer de débrancher le clavier puis de le rebrancher. Peut-être que cela le réinitialisera ... Juste des suggestions!

J'espère que ça aide ... Bonne chance!

    
réponse donnée SoCalDiegoRob 04.10.2013 - 22:29
la source
1

J'ai eu un problème similaire. Je suis tombé sur la réponse en essayant la solution ici. D'une manière ou d'une autre, le lecteur d'écran était allumé et provoquait un comportement erratique. Cochez la case sous Paramètres système → Accès universel → Voir. Assurez-vous que le lecteur d'écran est réglé sur OFF. Désactivation du lecteur d'écran

    
réponse donnée user260596 13.02.2016 - 07:05
la source
0

Cela peut se produire quand un programme démon intercepte des frappes au clavier (comme sur carte). A titre d'essai, ouvrez gnome-system-monitor et regardez s'il y a un script bash ou même des scripts python en cours d'exécution. Essayez de fermer à bord si ça marche.

    
réponse donnée Python Student 04.10.2013 - 20:15
la source
0

Je sais que ce que je recommanderai est presque la solution la plus facile et la plus laide du moment:

Déplacez les répertoires .* vers un autre emplacement:

mkdir ~/backup
mv ~/.config ~/.dbus ~/.gconf ~/backup/

maintenant redémarrez votre session. Le problème aurait dû disparaître. Si le problème disparaît, vous pouvez restaurer un par un le innocent avec

cp -nr ~/backup/.dbus ~/.dbus

Redémarrer la session, le problème est-il à nouveau? Supprimez le répertoire et copiez plutôt un par un le contenu des sous-répertoires. Même avec les 2 autres répertoires.

cp -nr ~/backup/.config ~/.config
cp -nr ~/backup/.gconf ~/.gconf

Je sais que la méthode est assez brutale, mais comme je ne pouvais pas trouver le fichier exact / dconf / gconf / xinput qui pourrait causer cela, un petit hack rapide devrait suffire.

    
réponse donnée Braiam 04.10.2013 - 22:20
la source
0

Il y a une autre raison de retard lors du changement de disposition du clavier. Selon le problème, # 1370953 (et # 1370953 ) Un tel comportement peut être lié à de mauvaises performances du disque. Voir Commentaire de Maxim Kravets :

  

Chaque modification de disposition alterne le fichier ~ / .config / dconf / user. Disposition   le changement est lent lorsque le disque est occupé.

Il y a une chose (pas une seule) à résoudre le problème du disque - pour changer le planificateur de files d'attente de disque. Par défaut, Ubuntu configuré pour utiliser le planificateur de délai, pour un disque dur lent, il est préférable d'utiliser le planificateur cfq à la place.

Voir instruction .

    
réponse donnée sempasha 07.03.2017 - 12:59
la source
0

Le problème de ce retard de saisie de texte inacceptable pourrait aussi avoir une raison complètement différente de celles mentionnées ici auparavant (Sticky Keys), et je l'ai trouvé:

Par erreur, l’option «Screen Magnifier» (Options d’accessibilité) a été activée. - Et mec, est-ce que cette chose ralentit si vous utilisez un Netbook peu puissant, comme je le fais (ASUS X206HA) ... m'a rendu à moitié fou. - Mais par chance, j'ai finalement découvert cela, éteint la loupe et tout est de nouveau rapide et lisse.

    
réponse donnée tonphilm 31.08.2017 - 21:30
la source
0

Comme décrit dans la question, dans l’écran de connexion je n’avais pas de délai mais dans le gestionnaire de fenêtres (génial wm), il y avait un retard de clavier irrégulier (parfois court / long délai). Avant, j'avais mis le code suivant dans /etc/X11/xorg.conf

Section "Device"
Identifier  "Card0"
Driver      "intel"
Option      "Backlight"  "/sys/class/backlight"
EndSection

faire fonctionner xbacklight . Il s'est avéré que les lignes ci-dessus provoquaient le retard du clavier dans mon cas.

    
réponse donnée phinz 10.04.2018 - 17:49
la source

Lire d'autres questions sur les étiquettes