Impossible d'accéder aux dossiers partagés Ubuntu à partir de Windows 7

23

Dans Ubuntu Maverick, j'ai partagé certains dossiers à l'aide de l'interface graphique "Options de partage" de Nautilus.

Je peux les voir depuis Windows 7, mais lorsque j'essaie d'y accéder (sous Windows), ils me demandent un nom d'utilisateur et un mot de passe. Peu importe ce que j'entre, cela ne me laissera pas entrer. Comment puis-je configurer cela pour le partager normalement?

Mise à jour: j'ai constaté que certains des dossiers partagés me laissaient entrer, mais que d'autres ne le faisaient pas. Parmi ceux qui le font, certains de leurs sous-dossiers, d'autres pas, etc. Comment puis-je rechercher la cause?

Lorsque je laisse l'interface graphique installer ce dont elle a besoin, elle installe samba et libpam-smbpass . Sur la machine à laquelle je ne parviens pas à me connecter, libpam-smbpass n'est pas installé. Cela pourrait-il être le problème?

    
posée endolith 30.12.2010 - 04:46
la source

10 réponses

8

Ouvrez à nouveau Nautilus en tant qu’utilisateur ordinaire et modifiez le partage pour supprimer l’accès des invités. Tapez gksudo nautilus , accédez au dossier partagé et partagez-le à nouveau. Partagez le dossier mais ne donnez pas d'accès invité. Nautile proche.

Accédez à votre espace Windows, accédez au partage et indiquez le nom d'utilisateur et le mot de passe Ubuntu.

Assurez-vous que votre pare-feu Ubuntu autorise l'accès entrant aux ports Samba. Assurez-vous que le pare-feu Windows autorise un accès sortant pour les mêmes ports.

    
réponse donnée BZ1 20.01.2011 - 11:07
la source
25

Avez-vous installé Samba? sudo apt-get install samba

Si tel est le cas, vous devez définir un mot de passe Samba: sudo smbpasswd -a USERNAME . Cette commande générera une invite pour un mot de passe (remplacez USERNAME par votre nom d'utilisateur).

Définir un dossier à partager mkdir /home/USERNAME/sharedfolder

Faites une copie de sauvegarde de votre fichier smb.conf: sudo cp /etc/samba/smb.conf ~

Ouvrez votre fichier smb.conf: gksu gedit /etc/samba/smb.conf

Ajoutez ceci à la toute fin du fichier:

[sharedfolder]
path = /home/USERNAME/sharedfolder
available = yes
valid users = USERNAME
read only = no
browsable = yes
public = yes
writable = yes

Il ne devrait y avoir AUCUN espace entre les lignes et il devrait y avoir un seul espace avant et après chacun des signes identiques. Enregistrez et quittez gedit.

Redémarrez Samba sudo restart smbd

Utilisez cette commande pour rechercher des erreurs de syntaxe dans votre fichier smb.conf: sudo testparm

Vous devriez maintenant pouvoir partager à partir de votre ordinateur Windows 7.

Modifier:

Je comprends que vous essayez d'accéder à votre partage Ubuntu à partir de Windows 7 et que vous souhaitez le faire avec une interface graphique.

but when I try to access them (from Windows) it asks for a username and password. No matter what I enter, it won't let me in. How do I configure this to share normally?

Pour ce faire, vous devez configurer un utilisateur / mot de passe Samba sur votre machine Linux, comme décrit précédemment. Je pourrais recommander un programme graphique pour Ubuntu, mais franchement, c'est beaucoup plus compliqué et déroutant de le faire de cette façon. Le programme est gadmin-samba et se trouve dans le référentiel Ubuntu. Attention! vous pouvez totalement modifier votre configuration si vous utilisez ce programme à mauvais escient. Merci de nous indiquer les étapes que vous avez suivies et les erreurs que vous avez rencontrées. Merci!

    
réponse donnée JBAlaska 30.12.2010 - 08:40
la source
5

J'ai un serveur Ubuntu avec un certain nombre d'ordinateurs et d'ordinateurs portables sous Windows 7 et j'ai constaté qu'un ordinateur portable n'autorisait pas l'accès aux fichiers des dossiers indiquant "Vous n'avez peut-être pas l'autorisation, etc.". J'ai parcouru Internet pendant 3 jours - pas de chance. Finalement décidé de demander à mon fils qui a installé le serveur et il a dit que Windows 7 peut stocker des mots de passe sur le serveur et que ceux-ci sont parfois corrompus. La réponse simple était la suivante: -

Si vous avez enregistré un mot de passe pour un lecteur réseau sous Windows et que vous souhaitez le supprimer, appuyez sur les touches [Windows] + [R] pour ouvrir la ligne de commande Windows. Puis entrez

control keymgr.dll

et cliquez sur “OK” pour ouvrir le gestionnaire de références Windows qui vous permet de gérer et de supprimer les mots de passe enregistrés dans Windows.

Mettez le serveur en surbrillance, puis cliquez sur SUPPRIMER DE VAULT

.

Redémarrez l'ordinateur.

Cette procédure fonctionne pour Windows XP, Vista et Windows 7.

    
réponse donnée brian 24.09.2013 - 16:31
la source
2

J'ai complètement désinstallé et purgé samba et samba-common, puis les ai réinstallés ainsi que tous les packages qui en dépendent. Le partage de l'interface graphique et le nom d'hôte de l'ordinateur fonctionnent à nouveau, même s'ils ne fonctionnent qu'en mode Invité.

Je n'ai pas compris quelles informations d'identification utiliser autrement. WINDOWSMACHINE/winusername UBUNTUMACHINE/ubuntuusername ou tout simplement username . Rien ne fonctionne. Mais le mode Invité fonctionne.

Les dossiers que je partage contiennent d'autres dossiers. Parfois, ils sont inaccessibles à la machine Windows et parfois, ils sont accessibles. Apparemment, quand il est écrit "laissez-moi configurer les autorisations pour vous", cela ne concerne que le dossier que vous partagez, pas les sous-dossiers. Si les autorisations de dossier pour "Groupe" et "Autres" ne sont pas définies sur "Créer et supprimer des fichiers", vous ne pourrez pas y accéder en mode Invité.

    
réponse donnée endolith 15.01.2011 - 18:58
la source
2

J'ai eu le même problème. "Vous n'êtes peut-être pas autorisé à utiliser cette ressource réseau. Contactez l'administrateur de ce serveur pour savoir si vous disposez des autorisations d'accès".  Tout fonctionnait bien avec samba jusqu'à ce qu'une nouvelle installation de 11.10 soit effectuée (l'installation de la mise à niveau n'a pas cassé les partages samba).

J'ai installé "Samba Server Configuration Tool 1.2.63" et cela montrait que l'utilisateur par défaut n'était personne. Changé que coïncider avec mon mot de passe et tout a bien fonctionné par la suite. J'avais comparé mes fichiers de configuration samba et rien n'était différent. L'outil mentionné l'a corrigé.

    
réponse donnée danb 25.03.2012 - 19:39
la source
2

J'ai eu énormément de problèmes avec cela et je viens de le comprendre, alors j'ai pensé le documenter.

Je pense que la dernière chose qui me réglait était d'ouvrir le fichier smb.conf (/ var / etc / samba /) et à la fin du fichier, les dossiers que je pensais être partagés avaient deux points; avant le navigable = oui que j'ai enlevé. Je pense que c'était la dernière étape.

J'ai également précédemment modifié le regedit sur Windows avec un fichier Win7_Samba3DomainMember.reg (bien que je pense utiliser Samba (1) - beaucoup de travaux en cours se déroulent ici: > j'ai trouvé le gadmin-samba PAS utile , cela a empiré les choses, mais j’ai reconnu que c’était dû à ma connaissance limitée, mais l’autre utilitaire Samba était très utile (system-config-samba).

Outre toutes les autorisations de dossier habituelles, le "partage de fichiers personnel" (accessible via le tableau de bord) comportait également une configuration simple qui, je suppose, n'aurait pas eu besoin d'être effectuée.

    
réponse donnée brett 04.07.2012 - 15:35
la source
1

Pour moi, cela a fonctionné en commentant simplement la ligne qui dit security = share et en décommentant la ligne qui dit security = user dans smb.conf

    
réponse donnée Mystic Odin 04.07.2012 - 20:11
la source
0
  1. Si vous utilisez Windows 7, vous devrez peut-être modifier les paramètres de votre registre:

    Exécutez le fichier Win7_SambaDomainMember.reg , qui insérera les paramètres de registre suivants ( Voir le wiki Samba pour plus de détails)

    HKLM\System\CCS\Services\LanmanWorkstation\Parameters
         DWORD  DomainCompatibilityMode = 1
         DWORD  DNSNameResolutionRequired = 0
    

    puis redémarrez (je ne connais aucun effet secondaire autre que celui de permettre l'accès à Samba)

  2. Si vous utilisez Ubuntu 11.10, assurez-vous que python-glade2 est installé

    sudo apt-get install python-glade2
    
réponse donnée David LeBauer 04.01.2012 - 18:58
la source
0

J'ai eu le même problème lorsque je voulais partager un lecteur. Je devais modifier mon fstab pour monter automatiquement le lecteur sur le point de montage spécifié. J'ai ensuite essayé de configurer le fichier smb.conf pour partager le lecteur. Le lecteur a été affiché dans Windows, mais je ne pouvais pas y naviguer. J'ai donc essayé ce que vous avez fait, mais lorsque j'ai essayé de le faire sous l'onglet Partage dans la boîte de dialogue des propriétés, un message est apparu pour insérer cette option dans la partie globale de smb.conf file:

usershare owner only = false

J'ai ensuite commenté ma configuration pour partager ce point de montage dans le fichier smb.conf .

Cela a fonctionné pour moi ...

    
réponse donnée brievolz84 08.11.2012 - 22:12
la source
-1

Essayez ceci à partir de la boîte Win7:

Panneau de configuration > Outils d'administration

Local Security Policy > Local Policies > Security Options

Modifiez ces entrées:

Sécurité réseau: niveau d'authentification LAN Manager Envoyer LM & Réponses NTLM

Sécurité de session minimale pour NTLM SSP Désactiver Exiger un cryptage 128 bits

    
réponse donnée nejode 15.01.2011 - 20:27
la source

Lire d'autres questions sur les étiquettes