Découverte du service réseau désactivée: qu'est-ce que cela signifie pour moi?

97

Chaque fois que je démarre, je reçois un message "La découverte du service réseau est désactivée. Votre réseau actuel possède un domaine .local, ce qui n'est pas recommandé et incompatible avec la découverte du service réseau Avahi. Le service a été désactivé. "

Qu'est-ce que cela signifie pour moi?

Le Wi-Fi est désactivé.

    
posée Nickolai Leschov 31.08.2013 - 16:27
la source

4 réponses

82

Il semble que avahi-daemon soit démarré lorsque la connexion réseau est établie ( /etc/network/if-up.d/avahi-daemon ). Cette notification vous informe que mDNS (Avahi) a été désactivé. Il n'est utilisé que pour un petit nombre d'applications qui ne fonctionnent que sur le réseau local, cela ne nuira pas à votre connexion Internet ou à votre DNS.

L’utilisation la plus connue de mDNS est le partage de musique avec Rhythmbox (ou iTunes) sur votre réseau local. C'est une technologie Apple, mais elle a été largement ignorée en faveur de l'UPNP ou de la DLNA.

Pour le désactiver, vous devez éditer le fichier /etc/default/avahi-daemon en tant que root:

sudo -i
gedit /etc/default/avahi-daemon

et ajoutez cette ligne (ou modifiez-la si elle existe déjà):

AVAHI_DAEMON_DETECT_LOCAL=0

Source: lien

    
réponse donnée Radu Rădeanu 31.08.2013 - 17:01
la source
14

Selon le wiki Avahi , il existe deux solutions de contournement:

Mieux un:

Dans /etc/avahi/avahi-daemon.conf décommentez et changez la ligne avec le nom de domaine en

domain-name=.alocal

Deuxième:

Dans /etc/nsswitch.conf , supprimez un texte [NOTFOUND=return] .

    
réponse donnée int_ua 10.02.2013 - 07:52
la source
3

Il est probable que Avahi est désactivé car vous avez un domaine .local et Avahi ne fonctionne pas très bien avec cela.

Avahi est un protocole sans aucune configuration comme Apples Bonjour couramment utilisé si vous avez des Mac sur votre réseau ou si vous souhaitez discuter avec d’autres personnes sur votre réseau local sans vous connecter à un serveur tel que Google Talk ou MSN Messenger.

Vous pouvez lire sur le problème ici .

Vous pourriez probablement simplement l'ignorer ou configurer votre réseau pour utiliser un autre nom de domaine, puis l'option .local par défaut.

    
réponse donnée danne 08.09.2011 - 10:22
la source
2

Bien qu'il puisse y avoir plusieurs causes, j'ai commencé à recevoir exactement la même erreur sur Ubuntu 14.04 après un changement de fournisseur de services Internet. Certains fournisseurs de services Internet malveillants utilisent des adresses de domaine locales pour leurs serveurs DNS, comme expliqué dans ici . Le réseau de ma boîte Ubuntu utilise une configuration manuelle, ce qui a permis de régler le DNS sur l'adresse IP de mon routeur au lieu de l'adresse du serveur DNS du FAI. En interne, le routeur utilise le serveur DNS local de l'ISP, mais Ubuntu n'est pas au courant et heureux. Plus de preuves ici indiquent qu’il s’agit de la faute du FAI

En bref, vérifiez si votre FAI utilise des adresses IP DNS non routables du domaine local. Si oui, changez de fournisseur DNS sur Ubuntu.

    
réponse donnée yoyoma2 01.05.2015 - 17:20
la source

Lire d'autres questions sur les étiquettes