Comment désactiver les raccourcis F1 et F10 dans gnome-terminal?

115

Comment puis-je désactiver les raccourcis clavier F1 (aide) et F10 (menu notifications)?

D’abord, j’ai besoin d’un utilitaire d’écran et d’autre part pour quitter mc dans la console.

Il n’existe pas de telles raccourcis clavier dans les paramètres système Raccourcis clavier .

    
posée Marko Kevac 27.04.2011 - 15:55
la source

14 réponses

106

11.04

Désactiver le raccourci F1

  1. Dans un terminal gnome, ouvrez Edit ➜ Raccourcis clavier .

  2. Faites défiler la liste jusqu'au raccourci Aide / Contenu , cliquez à l'endroit où il est indiqué "F1" et appuyez sur Retour arrière :

Désactiver le raccourci F10

  1. Installez le compizconfig-settings-manager package.

  2. Ouvrez Gestionnaire de paramètres CompizConfig .

    • Cliquez sur Super pour ouvrir le Dash, tapez "Compiz" et appuyez sur Enter .
  3. Tapez "unity" dans l'entrée Filter et sélectionnez le plug-in Ubuntu Unity .

  4. Cliquez sur le bouton situé à droite de Clé pour ouvrir le premier menu du panneau et décochez la case Activé .

  5. Si le raccourci global F10 est désactivé, désactivez maintenant le raccourci F10 de gnome-terminal:

    • Dans un terminal gnome, ouvrez Raccourcis clavier ( Édition> Raccourcis clavier) et
      désélectionnez Activer la touche de raccourci de menu (F10 par défaut)

  6. F10 est mappé sur menubar_accel par quelque chose dans Ubuntu. Gnome? Metacity? Vous ne savez pas exactement ce qui la vole, mais la clé ne parvient pas à Eclipse.

    • Lancez gconf-editor, naviguez jusqu'à / desktop / gnome / interface, puis faites défiler la page jusqu'à menubar_accel et supprimez la valeur F10. [Volé d'ici]
réponse donnée Isaiah 23.06.2011 - 20:52
la source
44

Désactiver F10 dans gnome-terminal en 12.04

Tapez ceci dans la console:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Fermez ensuite toutes les sessions de terminal. Maintenant, il devrait fonctionner comme il se doit (en mc par exemple).

réponse donnée Paweł Gościcki 30.04.2012 - 21:25
la source
23

commencer gconf-editor et suivre /apps/gnome-terminal/keybindings/help

Description:

"Touche de raccourci clavier pour lancer l’aide. Exprimée sous forme de chaîne au même format que celui utilisé pour les fichiers de ressources GTK +. Si vous définissez cette option sur la chaîne spéciale" désactivée ", aucun raccourci clavier ne sera associé à cette action."

    
réponse donnée Rinzwind 21.08.2011 - 22:28
la source
7

Je suis nouveau sur Linux et cette touche F10 me rend fou. Toutes les astuces ci-dessus ne fonctionnaient pas, mais j'ai trouvé une solution (pour Ubuntu 11.10 avec le bureau classique Gnome 3). Dans un terminal, entrez la commande suivante:

gsettings set org.gnome.desktop.interface menubar-accel ""

Avec dconf-editor, on peut trouver que le F10 est vraiment parti. Notez que ce genre de trucs semble dépendre fortement de la version de Gnome / Ubuntu.

    
réponse donnée gast128 29.11.2011 - 20:34
la source
4

Pour quitter mc (avec la touche F10). Désactiver "Clé pour ouvrir le menu du premier panneau" dans le plugin unité compiz (ccsm)

    
réponse donnée kholis 29.04.2011 - 12:33
la source
4

@kholis est correct pour désactiver F10 dans Unity, mais si vous êtes un newb comme moi, vous avez besoin d'un peu plus d'informations pour que cela fonctionne.

Si ce n’est pas déjà installé, installez compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Lancez le gestionnaire de paramètres nouvellement installé et filtrez pour "unity"

Modifier "Key pour ouvrir le menu du premier panneau" pour le désactiver ou le changer pour une autre clé.

Je n'ai pas encore trouvé de moyen de changer la F1.

réponse donnée Ryan Sorensen 30.04.2011 - 19:36
la source
3

L'instruction sur lien (citée ci-dessous) fonctionne également dans Ubuntu 11.04. (Il semble désactiver F1 à la fois sur le bureau et dans le terminal. C'est-à-dire que F1 n'envoie pas de séquence ansi au shell dans le terminal, si c'est ce que voulait l'OP.)

  
  1. Aller au système - Préférences - Raccourcis clavier
  2.   
  3. Créez un nouveau raccourci. Nommez-le «ne rien faire» et écrivez «faux»   (sans les guillemets) dans le champ "commande". Poussez ok.
  4.   
  5. Allez au bas de la liste et trouvez votre nouvelle commande. Cliquez sur   sur le "Disabled", à droite, et appuyez sur F1.
  6.   
    
réponse donnée David Andersson 22.08.2011 - 04:12
la source
3

Vous pouvez facilement le désactiver à l'aide de CCSM (Cliquez pour installer si vous ne l'avez pas installé) ).

Ensuite, accédez à Bureau - & gt; Plugin Ubuntu Unity - & gt; Touche pour ouvrir le premier menu du panneau et la désactiver ou la remplacer par un autre raccourci clavier.

Remarque : il semble que cette méthode ne fonctionne pas dans Unity2D.

    
réponse donnée Binarylife 27.10.2011 - 00:03
la source
2

Ceci est une astuce pour les utilisateurs de Thnkpad, en particulier T60. Remapper la touche F1 pour échapper. Cela élimine le popup ennuyeux de l'aide du terminal lorsque vous appuyez sur F1. Vous faites souvent cela en raison du placement amusant de l'ESC sur les T60.

    
réponse donnée ncmathsadist 03.12.2011 - 18:42
la source
1

Si vous souhaitez uniquement changer cela dans Terminal Gnome , vous pouvez cliquer sur Modifier & gt; Raccourcis clavier dans le terminal.

    
réponse donnée Jeremy Bicha 30.04.2011 - 20:37
la source
1

Je recommande d'utiliser F1 comme raccourci pour autre chose. Je lance Tilda, un terminal de ligne de commande de style quake, et le raccourci par défaut est F1. Il remplace l'Aide, donc je n'ai jamais d'aide lancée quand je frappe F1. Même si vous n'aimez pas beaucoup Tilda, frapper à nouveau F1 pour le cacher est beaucoup moins fastidieux que de fermer Help après l'avoir lancé accidentellement.

    
réponse donnée titaniumtux 03.12.2011 - 20:23
la source
1

12.04

F1 ne semble rien faire hors de la boîte le 12.04
F10 semble simuler un clic droit
Donc, en réponse aux spécificités de la question, il n’est pas nécessaire de désactiver l’aide et les notifications.

Vous pouvez toujours les associer à quelque chose comme ceci:
Le mappage des touches de raccourci dans 12.04 s'effectue simplement via le widget Clavier.

Dans le lanceur Unity, recherchez le clavier.

Dans la fenêtre qui s'ouvre, sélectionnez l’onglet des raccourcis et les raccourcis personnalisés.
Cliquez sur le plus pour ajouter un nouveau raccourci.

Nommez-le comme correspondant à la fonctionnalité que vous lui assignez.
Entrez la commande à exécuter dans la commande.

Sur le côté droit de la fenêtre, cliquez où il est indiqué désactivé. Cela devrait basculer vers le nouvel accélérateur.

Maintenant, appuyez simplement sur F10 .
L'accélérateur de raccourcis personnalisés que vous avez défini remplace le comportement de simulation par clic droit. Vous pouvez définir cette commande sur echo 'nope' > /dev/null si vous voulez simplement que votre F10 ne fasse rien.

    
réponse donnée RobotHumans 02.04.2012 - 19:50
la source
1

12.04 Sans unité - Désactiver le comportement F1 et F11

J'ai installé Ubuntu 12.04 / 64 et j'ai complètement supprimé Unity en suivant ces instructions . De nombreux outils qui modifient le comportement de Unity ne fonctionnent donc pas. En particulier, CCSM ne "voit" plus les raccourcis clavier.

J'ai trouvé que la méthode utilisant Edit- & gt; Raccourcis clavier dans la fenêtre du terminal ne fonctionnait pas non plus. Après un peu de jeu, je me suis rendu compte que, dans la fenêtre Raccourcis clavier dans la section Touches de raccourci , F1 et F11 étaient toujours définis pour leurs raccourcis respectifs.

Pour résoudre ce problème,

  1. Cliquez sur le "F11" dans le champ de droite de la ligne qui définit F11 comme plein écran. Le texte deviendra "New Accelerator ...".

  2. Tapez une autre séquence de touches moins répréhensible (comme alt-F11) et cette combinaison de touches remplacera le raccourci. Si quelqu'un sait comment taper "rien", merci de nous le faire savoir.

  3. Répétez pour la touche F1.

réponse donnée Wes Miller 20.11.2013 - 17:33
la source
0

Ctrl + F1 ne fonctionne pas non plus. La solution est la même que pour Shift + F10. N'oubliez pas le point-virgule comme séparateur!

Placez ceci dans ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
réponse donnée egmont 16.03.2014 - 12:46
la source

Lire d'autres questions sur les étiquettes