La vapeur ne démarre pas. Erreur LibGL [dupliquer]

27

Steam ne se lance pas ... essayer de le lancer depuis l'icône ne fait rien, pas d'erreurs, rien.

Essayer de lancer depuis le terminal et je reçois ceci:

Running Steam on ubuntu 15.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1437790054)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Toute aide serait formidable.

    
posée dougm96 30.07.2015 - 13:00
la source

2 réponses

59

Pour le réparer, ouvrez simplement le terminal et exécutez ces commandes:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1

Steam devrait alors fonctionner correctement. Mais assurez-vous de ne pas installer les pilotes AMD propriétaires car ils sont très mauvais pour la stabilité du système d’exploitation par rapport aux pilotes open source. Si vous obtenez de faibles performances avec les pilotes open source, mettez simplement à niveau la version de Mesa en ajoutant le PPA xorg-edgers

sudo add-apt-repository ppa:xorg-edgers/ppa

Après cela, tapez ceci pour mettre à jour la version de Mesa:

sudo apt-get update && sudo apt-get upgrade

Puis redémarrez et le nouveau pilote Mesa doit être chargé.

    
réponse donnée The Intelligent Human 04.08.2015 - 13:32
la source
22

Cela m’a permis d’y aller le plus possible. Je devais aussi changer la façon dont j'ai lancé Steam.

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

Selon ce fil de discussion: Erreur lors de l'installation de Steam sur Ubuntu 15.04

    
réponse donnée revnoah 12.02.2016 - 00:44
la source

Lire d'autres questions sur les étiquettes