La dernière mise à jour bloque le gestionnaire de réseau (pas de connexion Internet, pas d'applet)

85

Lors de la mise à niveau aujourd'hui, mon gestionnaire de réseau sans fil a disparu. Même pas connexion via une connexion filaire.

Cette erreur est affichée par les fichiers:

**(nm-applet:2716): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files 

(nm-applet:2716): nm-applet-WARNING **: Error connecting to ModemManager: Error calling StartServiceByName for org.freedesktop.ModemManager1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Cannot launch daemon, file not found or permissions invalid 

(nm-applet:2716): nm-applet-WARNING **: Could not find ShellVersion property on org.gnome.Shell after 5 tries 

(nm-applet:2716): nm-applet-WARNING **: Failed to register as an agent: (2) The name org.freedesktop.NetworkManager was not provided by any .service files 

Existe-t-il un correctif que je peux télécharger via Windows et envoyer à mon ubuntu, ou est-ce que je dois tout recharger? J'ai essayé de faire tourner deux versions mais toujours pas d’accès à Internet.

    
posée Adam Albanowicz 29.01.2016 - 13:25
la source

7 réponses

124

Cause

Ceci est dû à une régression introduite avec un correctif pour bogue n ° 1511735 libnl3 .
Le crash du gestionnaire de réseau résultant a été signalé dans bogue du gestionnaire de réseau n ° 1539513 ou Bogue du gestionnaire de réseau n ° 1539634

Solution

Rétrograder les paquets libnl et attendre la mise à niveau du paquet du gestionnaire de réseau

Étape 1

Essayez de rétrograder libnl avec apt-get comme dans @Max answer:

sudo apt-get install libnl-3-200=3.2.21-1 libnl-route-3-200=3.2.21-1 libnl-genl-3-200=3.2.21-1

Étape 2

Si l'étape 1 échoue,
Comme les paquets ne sont plus dans votre cache et ne peuvent évidemment pas être téléchargés par le gestionnaire de paquets, vous devez rétrograder manuellement les paquets libnl (téléchargement + installation):

  • Téléchargez-les et copiez-les sur votre système
    [de démarrer un CD live distrib / rescue ou à partir d'un autre ordinateur + clé USB]
    Liens de téléchargement pour amd64 : libnl libnl-genl libnl-route
    Liens de téléchargement pour i386 : libnl libnl-genl libnl-route

  • Retour à votre système, où vous avez enregistré ces fichiers .deb , installez-les avec dpkg:

    sudo dpkg -i libnl-*.deb
    

Étape 3

Maintenant, vous devriez pouvoir (re) démarrer NetworkManager et rétablir le réseau:

sudo service network-manager restart

Remarque

Ces bogues frappent Ubuntu Trusty 14.04 avec des mises à jour pré-publiées : trusty-proposed

Où la dernière mise à jour des paquets libnl de la version 3.2.21-1 à 3.2.21-1ubuntu1 a introduit une régression provoquant le blocage du gestionnaire de réseau

Il n'y a pas encore de mise à niveau sur network-manager dans trusty-proposed
Version actuelle: 0.9.8.8-0ubuntu7.2

Une mise à jour de network-manager est désormais disponible dans trusty-proposed
Version mise à jour: 0.9.8.8-0ubuntu7.3
veuillez tester le package proposé (# 1539634 commentaire n ° 11)

Ainsi, jusqu’à ce qu’une mise à jour soit déclenchée sur votre gestionnaire de paquets, vous devriez appliquer un "hold" - comme mentionné dans bug n ° 1511735 de libnl3 commentaire n ° 29 :

sudo apt-mark hold libnl-3-200 libnl-genl-3-200 libnl-route-3-200

Une fois la future mise à niveau de trusty-proposed installée, vous pouvez la supprimer avec:

sudo apt-mark unhold libnl-3-200 libnl-genl-3-200 libnl-route-3-200

Ce qui vous permettra ensuite de mettre à jour à nouveau libnl

    
réponse donnée r2rien 30.01.2016 - 09:59
la source
10

À partir de 2016-05-13 cet libnl Le bogue affecte également les utilisateurs sans trusty-proposé , qui seront presque certainement dirigés ici par Google.

Les paquetages libnl et network-manager mis à jour ont déjà été publiés. Je recommande donc une mise à niveau directe .

Activer le réseau manuellement

En supposant que vous utilisez une connexion filaire, eth0 et un réseau avec DHCP activé, configurez votre interface réseau à l'aide d'un terminal:

sudo ifconfig eth0 up
sudo dhclient eth0

Mettre à jour le gestionnaire de réseau

Lorsque le réseau est opérationnel, effectuez une mise à jour à l’aide de Software Updater ou à partir du terminal utilisant apt-get .

Option A: logiciel de mise à jour

Exécutez Software Updater et mettez à jour normalement. Au moment de la rédaction, des paquets fixes avaient déjà été publiés.

Option B: apt-get

(non testé). Si vous souhaitez minimiser les pièces en mouvement ou n’avez pas d’interface graphique, vous pouvez également effectuer une mise à jour depuis le terminal:

sudo apt-get update
sudo apt-get install network-manager
    
réponse donnée Eero Aaltonen 17.05.2016 - 10:05
la source
8

En plus de la solution donnée, je veux donner un conseil général.

Désactiver le référentiel "proposé"

Il n'est pas censé être allumé. Ce "problème" n'a affecté que les utilisateurs qui ont activé le référentiel proposé et installé un package défectueux.

Ce référentiel contient des packages de tests qu’il n’est pas recommandé d’installer, sauf si vous souhaitez tester des packages spécifiques.

Garder "proposé" désactivé si vous ne voulez pas ce genre de surprises.

Vous pouvez vous référer à cette question pour plus d'informations.

    
réponse donnée Pilot6 30.01.2016 - 23:33
la source
3

Mettez à jour network-manager 0.9.8.8-0ubuntu7.2 et redémarrez.

Solution de contournement: utilisation des paramètres réseau manuels sur sudo nano /etc/network/interfaces

Solution de contournement!

Rétrograder certaines bibliothèques:

sudo apt-get install libnl-3-200=3.2.21-1 libnl-route-3-200=3.2.21-1 libnl-genl-3-200=3.2.21-1
    
réponse donnée Max 29.01.2016 - 15:43
la source
2

J'ai eu le même problème ce matin et j'ai rétrogradé les paquets libnl qui fonctionnaient aussi.

J'ai redémarré avec un CD de secours, téléchargé libnl-3-200-3.2.21-1_amd64.deb , libnl-genl-3-200_3.2.21-1_amd64.deb et libnl-route-3-200_3.2.21-1_amd64.deb depuis lien , l’a installé avec dpkg -i et redémarré.

Le réseau est de retour. Ce n'est peut-être pas la solution ultime, mais ça m'a permis de continuer pour le 14.04.

Voici le rapport de bogue: lien .

    
réponse donnée Daniel Young 30.01.2016 - 02:33
la source
1

Je savais que la solution serait rapide, la partie délicate était la question de la poule et de l’œuf de se connecter. Une des méthodes consiste à utiliser l’Ethernet filaire, ce qui est très simple:

Ouvrir un terminal

sudo dhclient eth0
sudo apt-get update
sudo apt-get upgrade
    
réponse donnée Dave Crooke 12.07.2016 - 22:15
la source
0

Je suis un très nouveau débutant à ubuntu et aussi un homme non technique ayant très peu d’expérience dans ces langages informatiques.

J'ai rencontré le même problème avec nm

comme demandé par r2rien j'ai téléchargé les trois fichiers à partir des liens fournis par lui

(d’abord, je ne pouvais pas comprendre qu’il s’agissait de trois liens, mais grâce à son utilisation précise de l’anglais: le mot "fichiers" m'a fait rechercher et télécharger les deux autres fichiers)

alors je ne pouvais pas l'installer

Je n'ai pas pu comprendre l'astérisque dans "sudo dpkg -i libnl - *. deb"

combien de fois j'ai essayé d'installer les premiers fichiers individuellement, puis ensemble, puis par apt-get; parfois interchanger = à la place de _ comme 3-200 = 3.2.21-1 à la place de 3-200_3.2.21-1. toujours pas de résultat. a cherché sur le net puis a trouvé un moyen très facile de le faire. en faisant glisser le fichier dans le terminal après "sudo dpkg -i"

a ensuite rencontré un autre problème: le traitement des déclencheurs ... cela aussi, comme quelqu'un a suggéré par "entrez et ensuite nom d'utilisateur et entrez" a été résolu. était toujours sceptique. enfin ça a marché. merci r2rien et amis.

    
réponse donnée Dev 02.02.2016 - 11:31
la source

Lire d'autres questions sur les étiquettes