Un nouvel ordinateur se bloque à l'arrêt / redémarrage, comment résoudre le problème?

23

Mon système fonctionne mais il se bloque lors de l’arrêt / reboot / suspend / hibernate: toutes les fenêtres et la barre de menus disparaissent mais le papier peint du bureau reste. Il ne montre même pas l'écran d'arrêt (celui avec les points animés) où je pourrais frapper ESC et regarder le texte de la console d'arrêt. Le système est entièrement nouveau et entièrement mis à jour avec Update Manager.

  1. Comment puis-je déterminer ce qui cause le gel?
  2. Existe-t-il un journal que je peux étudier?
  3. Comment puis-je résoudre ce problème?

Je ne vois aucune cause évidente du gel. La seule pièce jointe USB est une souris / un clavier; Je n'ai pas de stockage externe attaché; et je n'ai aucun programme en cours d'exécution (la machine se bloque même lors d'un arrêt à partir de l'écran de connexion).

Ce que j'ai essayé jusqu'à présent:

  • Basé sur d’autres questions ( ceci , this , et this ) qui suggère des paramètres ACPI, j'ai essayé sudo shutdown -h now pour voir si l'affichage du texte de la console d'arrêt offrait des conseils, mais le système n'atteint même pas la distance gèle encore lorsque l'écran affiche l'image d'arrière-plan du bureau, sans aucune barre d'outils. Seul sudo shutdown --force fonctionne, mais ce n’est pas une solution.
  • L'édition du menu grub pour ajouter acpi = off au noyau n'a pas aidé. Je suppose qu'il n'y a pas grand intérêt à essayer les autres suggestions (moins importantes) de l'ACPI?
  • L'ajout de noapic à l'entrée grub n'a pas eu d'effet perceptible. Ajouter nolapic à la place a fait quelque chose (j'avais supprimé l'option quiet ) - le système a continué à continuer avec l'arrêt, jusqu'à la ligne Vérification de l'exécution sans surveillance- mises à niveau: qui étaient les derniers caractères à l'écran.
  • J'ai également vérifié le BIOS du système, notamment en ce qui concerne les options d'alimentation, mais n'a rien vu d'anormal. Changer le mode de veille du BIOS de S3 à S1 n'a pas aidé. Le paramètre de veille ne peut pas être désactivé et il n’existe aucun autre paramètre relatif à ACPI AFAIK.
  • La réinitialisation du BIOS n'a pas aidé. Pas surpris; n'avait rien changé.
  • J'ai essayé d'aller sur une console virtuelle (CtrlAltF1) comme suggéré par djeikyb et à partir de là shutdown -h now et il a gelé là aussi, après cette sortie de la console . Je n'ai pas essayé de tuer les processus un à la fois parce que je suis encore trop novice pour trouver une solution.
  • Amorcer avec le noyau 2.6.35.22 plutôt que 2.6.35.25 n’a pas aidé.
  • La désactivation des pilotes Nvidia n’a pas aidé.
  • Lancement depuis Live CD (la clé USB en fait) n’a pas aidé; il gèle de la même manière.
  • Amorcer à partir de Live CD, avec acpi=off noapic nolapic n’a pas aidé non plus. Il n'y a pas eu non plus que nolapic . Donc, évidemment, ce n'est pas un paramètre personnalisé dans mon installation, mais une sorte de problème de base.
  • MemTest a concouru en 1 heure sans erreurs.
posée Torben Gundtofte-Bruun 13.04.2017 - 14:24
la source

8 réponses

7

Cette réponse sur les forums Ubuntu a la solution exacte! (Pourquoi n'ai-je pas posté là-bas en parallèle ici sur AU? Il aurait sauvé une semaine de calendrier et plusieurs heures de temps d'ordinateur!)

  

Le mauvais pilote est chargé qui   empêche l'arrêt. Pour résoudre ce problème, vous avez besoin   pour ce faire:

     

Ouvrez un terminal et tapez: sudo modprobe -rf rt2860sta

     

Suivi de: sudo modprobe rt2860sta

     

Ensuite, vous devez mettre en liste noire le mauvais pilote:
echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf

     

Une fois que vous avez redémarré (vous aurez besoin de   faire une mise hors tension pour le dernier   temps!), vous trouverez que vous pouvez redémarrer   correctement.

    
réponse donnée Torben Gundtofte-Bruun 25.02.2011 - 00:05
la source
4

Pour Ubuntu 11.10, vous pouvez essayer l’option reboot=bios (ou d’autres options) comme expliqué ici .

  1. Accédez au fichier de configuration GRUB comme expliqué ici .

    cd .. && cd .. && sudo -H gedit etc/default/grub
    
  2. Modifiez la ligne GRUB_CMDLINE_LINUX="" pour qu’elle indique:

    GRUB_CMDLINE_LINUX="reboot=bios"
    

    et enregistrez le fichier.

  3. Mettez à jour GRUB pour écrire la configuration:

    sudo update-grub
    
  4. Redémarrez votre ordinateur

    (ça peut rester sur l’écran violet, mais heureusement pour la dernière fois ...)

réponse donnée Jonathan 22.12.2017 - 20:05
la source
2

Cela pourrait être un problème ACPI. Vous pouvez essayer de transmettre certains paramètres au noyau pour désactiver certaines fonctions ACPI. Notez que cela entraînera une perte de fonctionnalités (gestion de l'alimentation) ou des performances (beaucoup d'interrogation).

Tout d'abord, une petite explication sur l'ajout de certains paramètres du noyau, dépouillés misérablement de Htorque :

  1. Démarrez votre système et attendez que le menu GRUB s'affiche (si vous ne voyez pas de menu GRUB, appuyez et maintenez la touche Shift gauche juste après le démarrage du système).
  2. Maintenant, mettez en évidence le noyau que vous souhaitez utiliser et appuyez sur la touche c . Vous devriez pouvoir voir et éditer les commandes associées au noyau en surbrillance.
  3. Descendez à la ligne commençant par linux et ajoutez l’un des paramètres suivants après un espace.
  4. Maintenant, appuyez sur Ctrl + x pour démarrer.

Vous ne pouvez pas essayer les options suivantes, une à chaque fois, elles sont ordonnées de plus agressives, susceptibles de fonctionner moins agressives mais moins de fonctions désactivées:

  • acpi=off , celui-ci devrait complètement désactiver acpi. C'est le plus susceptible de fonctionner, mais vous perdrez toute votre gestion de l'alimentation.
  • pci=noacpi , cela obligera le noyau à ignorer les acpi pour les analyses pic et les affectations irq.
  • acpi=noirq , cela désactivera uniquement l'affectation irq via acpi.
  • irqpoll , cela fera que le noyau interroge toutes les interruptions irq sans surveillance.
  • noapic , le noyau ignorera le APIC .
réponse donnée Javier Rivera 16.02.2011 - 21:55
la source
1

Je voudrais:

  • réinsérez les puces RAM
  • réinitialiser le BIOS par défaut
  • essayez de lancer Live distro et voyez comment cela fonctionne
  • exécutez MemTest pendant un certain temps
réponse donnée jet 17.02.2011 - 21:25
la source
1

J'ai résolu ce problème en ajoutant la ligne suivante au fichier /etc/default/halt :

INIT_HALT = POWEROFF
    
réponse donnée Fabio 07.09.2012 - 22:57
la source
0

Dans la plupart des cas, cela est dû à une carte graphique défectueuse. E.g Dans Ubuntu 12.04, j'ai dû installer toutes les mises à jour (y compris celles liées à xorg). Après cela, j'ai installé le catalyseur 12.10, qui a résolu le problème. Je vous suggère de supprimer (si installé) laptop-mode-tools (y compris ses dépendances, c.-à-d. Ethtool, sdparm), car cela provoque également le blocage de l'arrêt.

    
réponse donnée razor 26.10.2012 - 18:59
la source
0

Curieusement, mon problème a été résolu lorsque j'ai supprimé le paramètre "maintenant". C'est-à-dire que j'utilisais:

sudo /sbin/reboot now

et ça se bloquait,

mais quand j'ai utilisé:

sudo /sbin/reboot

le problème a été résolu.

Je ne comprends pas pourquoi. Le problème est apparu uniquement lorsque j'ai installé Ubuntu 13.10 .
J'ai toujours 3 autres stations avec le même matériel, mais avec une ancienne version de Ubuntu 12.04 et je n'ai pas ce problème.

    
réponse donnée Haroon 28.06.2014 - 11:26
la source
0

J'ai également été confronté à la même situation, mais je n'ai pas pu le résoudre par l'une des méthodes ci-dessus. Bien qu'il puisse y avoir de nombreuses causes à ce problème, mais j'ai résolu ce problème en désactivant le contrôleur USB 3.0 dans le menu du BIOS.

    
réponse donnée Kapil Garg 26.10.2016 - 21:31
la source

Lire d'autres questions sur les étiquettes