Les menus Eclipse sont coupés ou ne s'affichent pas

84

J'utilise Ubuntu 13.10 (avec JDK 1.7.0_45).

J'ai téléchargé et non compressé Eclipse Kepler pour les développeurs Java EE.

Les menus du logiciel sont endommagés. Je n'ai pas remarqué de problèmes similaires dans d'autres logiciels.

Lorsque je clique sur un menu dans Eclipse, le menu déroulant semble être "coupé". Parfois, la liste déroulante s'affiche, mais les options sont invisibles.

J'ai essayé Eclipse Indigo, mais le même problème se produit.

    
posée Ralph Rassweiler 18.10.2013 - 15:21
la source

6 réponses

84

Comment résoudre les problèmes de menu Eclipse dans Ubuntu 13.10

(manière stable, jusqu'à ce que quelqu'un corrige le bogue)

Cette méthode prend pour acquis que vous avez déjà votre fichier eclipse.desktop (ou que vous pouvez en créer un autre à partir de rien). Sinon, vous pouvez jeter un coup d’œil à la «méthode rapide» ci-dessous.

  1. Ouvrez votre fichier eclipse.desktop :

    sudo -H gedit /usr/share/applications/eclipse.desktop
    

    (Si vous ne le trouvez pas dans ce chemin, essayez ~/.local/share/applications/eclipse.desktop . Sinon, vous devrez peut-être trouver le votre en utilisant la commande locate ).

  2. Remplacez la ligne Exec= par ceci:

    Exec=env UBUNTU_MENUPROXY= eclipse
    

    Où "eclipse" est le chemin de votre exécutable eclipse. Dans ce cas, il n'y a que "eclipse" car il existe un lien symbolique dans le dossier /usr/bin .

    REMARQUE: Si vous ne trouvez pas votre fichier eclipse.desktop , vous pouvez simplement en créer un dans le chemin ci-dessus et le remplir avec ces lignes:

    [Desktop Entry] 
    Type=Application 
    Name=Eclipse 
    Icon=eclipse 
    Exec=env UBUNTU_MENUPROXY= eclipse 
    Terminal=false 
    Categories=Development;IDE;Java;
    
  3. Enregistrez le fichier.

Vous pouvez maintenant exécuter Eclipse à partir de son icône, comme d’habitude.

(rapide mais répétitif)

Si vous n’avez pas de fichier eclipse.desktop et que vous ne souhaitez pas le créer pour le moment, vous pouvez simplement exécuter Eclipse avec cette commande:

UBUNTU_MENUPROXY= eclipse

où "eclipse" est le chemin d'accès à votre exécutable eclipse . Notez que c'est juste le moyen rapide d'exécuter une fois Eclipse. Si vous ne voulez pas vous souvenir de cette commande et l'utiliser chaque fois que vous devez exécuter Eclipse, suivez la procédure ci-dessus "stable".

Ou vous pouvez en faire un alias

alias eclipse = 'UBUNTU_MENUPROXY= eclipse'

et la commande eclipse fonctionnera correctement.

Sources:

réponse donnée Kurt Bourbaki 05.11.2013 - 12:43
la source
10

J'ai eu le même problème, ma solution la plus paresseuse est

  1. Ouvrez un terminal Gnome (raccourci CTRL + ALT + T par défaut)
  2. Issue UBUNTU_MENUPROXY=0 eclipse .

Fonctionne pour moi.

    
réponse donnée Abel Melquiades Callejo 12.12.2013 - 23:33
la source
6

Dans mon cas, il y avait deux versions du fichier dans / usr / share / applications:

eclipse.desktop
Eclipse.desktop

Supprimez l'un d'eux ou modifiez la ligne Exec dans les deux cas, comme décrit ci-dessus. La troisième version du fichier se trouve dans le dossier d'accueil:

~/.local/share/applications/Eclipse.desktop

Vous pouvez également supprimer cette dernière ou modifier la ligne Exec dans celle-ci également.

Il suffit de modifier la ligne Exec comme suit:

Exec=env UBUNTU_MENUPROXY= /path/to/eclipse/eclipse
    
réponse donnée Karşıbalı 08.11.2013 - 13:32
la source
2

Vous devez éditer un fichier appelé eclipse.desktop pour inclure l’option MENUPROXY.

  • Selon votre installation, cet emplacement variera. Pour le trouver, tapez sudo find / -name eclipse.desktop .
  • Une fois l’emplacement trouvé, ouvrez le fichier dans votre éditeur préféré. Pour moi, c'est vim, donc je tape sudo vim /usr/share/applications/eclipse.desktop (notez que votre emplacement peut être différent, voir la première étape.
  • Dans le fichier, recherchez une ligne qui ressemble à ceci - & gt; Exec=/opt/eclipse/eclipse . (Notez que le vôtre peut simplement avoir l’éclipse sans le chemin complet).
  • Après avoir trouvé cette ligne, commentez-la. Ajoutez ensuite cette ligne: Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse (modifiez le cas échéant. Si votre installation n’a pas le chemin complet ou s’il a un chemin différent, ajustez ici). Notez l'espace après MENUPROXY =. C'est important. 'Démarrez Eclipse et profitez à nouveau des menus du haut.
réponse donnée Terry 21.10.2013 - 17:31
la source
1

Vous pouvez essayer ceci: lien Le menu d'Eclipse ne s'affiche pas dans le menu global d'Unity. Fonctionne avec moi.

    
réponse donnée Philmagno 18.10.2013 - 23:26
la source
-1

Dans mon cas, le fichier n’existait pas,

J'ai dû le créer dans ~/.local/share/applications

créez simplement eclipse.desktop contenant

Version=4.3.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= path=/home/abali/apps/eclipse/eclipse Icon=/home/abali/apps/eclipse/icon.xpm
Terminal=false
Type=Application
Categories=IDE;

N'oubliez pas de faire

source eclipse.desktop

, alors ouvrez eclipse et ça marche.

    
réponse donnée user2030755 26.11.2013 - 10:12
la source

Lire d'autres questions sur les étiquettes