Empêcher les fenêtres de voler le focus

25

J'utilise Maverick avec Compiz activé.

J'ai recherché AskUbuntu et Google. AskUbuntu n’a rien sur ce sujet et tout ce que Google a découvert a quelques années.

Je fais des tests de navigateur et mes tests engendrent constamment de nouvelles fenêtres Firefox. Le problème est que, lorsque la fenêtre est créée, elle prend le focus. C'est incroyablement agaçant car je suis en train de taper ailleurs. Cela ne se produit pas seulement avec mes tests, mais c'est l'exemple le plus courant que je rencontre. Parfois, mon IDE décide qu'il veut se concentrer lorsque quelque chose de spécial se produit (comme lorsque quelque chose se passe), et plus tard, je trouverai des fragments de messages instantanés que j'ai tapés dans mon code. Ça me rend fou. J'ai regardé dans les paramètres de Gnome et les paramètres de Compiz et je ne peux pas trouver un moyen d'empêcher que cela se produise.

Est-ce que quelqu'un connaît un moyen d'empêcher une application de voler le focus lorsqu'elle est ouverte? Je préfère que la barre des tâches clignote sur moi ou quelque chose pour attirer mon attention.

    
posée Joel 20.10.2010 - 16:51
la source

4 réponses

16

Le paramètre est dans CompizConfig & gt; Général & gt; Focus & amp; Augmenter le comportement tel que documenté. Les règles de Correspondance de fenêtre sont très importantes.

    
réponse donnée msw 20.10.2010 - 17:07
la source
0

Si vous travaillez dans une fenêtre la plupart du temps, vous pouvez cliquer avec le bouton droit sur la barre de titre et dire à la fenêtre d'être toujours au dessus ... ce n'est pas une solution parfaite, mais vous pouvez ombrer la fenêtre lorsque vous fait, ou le minimiser puis y retourner ...

    
réponse donnée nathwill 20.10.2010 - 17:03
la source
0

Vous pouvez également modifier ce paramètre dans gconf-editor si vous n'avez pas installé CCSM . Accédez à la clé /apps/compiz/general/screen0/options/focus_prevention_level et définissez sa valeur sur 4 .

Pour certaines personnes, 4 est trop élevé. Les utilisateurs d’Eclipse trouveront que différentes boîtes de dialogue ne captureront pas correctement le focus du clavier lorsque celui-ci est défini sur 4, mais s’il est défini sur 3.

    
réponse donnée Daniel Dinnyes 31.07.2011 - 14:29
la source
0

Ce n’est pas quelque chose que vous devez configurer globalement. C'est à dire. vous ne voulez pas vraiment que les nouvelles fenêtres no se focalisent: vous ne voulez pas que les fenêtres test soient actives. Pour ce faire, utilisez le plug-in Règles de fenêtre de Compiz pour empêcher que toutes les fenêtres "test" de Firefox ne prennent le pas.

Vous devez écrire une règle pour identifier uniquement les instances de "test" de Firefox. S'ils ont tous une chaîne spécifique dans le titre, cela fonctionnerait. Sinon, vous pouvez utiliser wmctrl pour définir la propriété WM_ICON_NAME X. (Je ne sais pas comment définir facilement les propriétés X pour Firefox. Si quelqu'un d'autre le fait, veuillez taper dessus!)

    
réponse donnée Jean Jordaan 24.07.2015 - 18:25
la source

Lire d'autres questions sur les étiquettes