Comment arrêter l'écran noir après 10 min

23

Mon OS est Lubuntu 13.04. Après 10 minutes d'inactivité, l'écran devient noir. Ce que j'ai fait pour l'arrêter sans effet:

  • désinstallé complètement xscreensaver
  • dans le réglage de puissance, je définis pour ne jamais masquer l'écran
  • exécutez une commande trouvée sur Internet avec "xset" qui a été dit pour le résoudre (mais peut-être que ce n'était pas la bonne commande, si vous le savez, veuillez l'écrire)

Et toujours rien. Je ne sais pas pourquoi Lubuntu veut tellement rester noir pour regarder des films. Par exemple, sur kubuntu / ubuntu, je viens de définir les paramètres d'alimentation pour ne jamais devenir noir et cela fonctionne. Peut-être que lubuntu utilise un noyau personnalisé avec des économies d'énergie extrêmes codées en dur qui ne peuvent pas être désactivées?

    
posée user1873947 05.05.2013 - 20:18
la source

13 réponses

12

Essayez d'installer:

sudo apt-get install xfce4-power-manager

puis configurez-le dans:

xfce4-power-manager-settings 
    
réponse donnée Arturo Veras 13.02.2014 - 01:39
la source
16

Dans Lubuntu, c'est une option dans les préférences appelée "Light Lock". Il est agaçant par défaut.

    
réponse donnée Mark 22.08.2014 - 22:32
la source
9

Pour un correctif temporaire dans le terminal et tapez:

xset s 0 0

et cela devrait arrêter le problème de suppression de 10 minutes, pour le rendre plus permanent, insérez une ligne avec la même commande au début du fichier /home/username/.profile .

    
réponse donnée TenPlus1 05.05.2013 - 21:52
la source
3

Aide pour moi après le redémarrage. Dans /etc/X11/xorg.conf (si vous ne l’avez pas, créez simplement):

Section "Monitor"
    Identifier "eDP0" <<< or LVDS0 or VGA0 or ...
    Option "DPMS" "false"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection
    
réponse donnée Anonymous1 23.12.2014 - 08:12
la source
1

Dans Ubuntu Mate 15.10 x64, j'avais le même problème. dans le coin supérieur de Mate, allez à System > Administration , puis à LightDM GTK+ Greeter Settings et entrez votre mot de passe. Dans la fenêtre suivante, cliquez en haut à droite sur Misc. , vous trouverez Timeout Until The Screen Blanks et il sera défini sur 1 minute par défaut. Déplacez simplement le curseur vers la gauche vers Never . Cela peut aussi être le cas à Lubuntu, mais c'était certainement le problème dans Mate 15.10.

    
réponse donnée Cominatyalive 21.01.2016 - 21:52
la source
0

Je crois que j'ai trouvé une solution à ce problème. J'ai récemment mis à jour depuis Ubuntu Mate 15.04, dans lequel l'écran noir m'a rendu fou, à 15h10, avec une nouvelle installation. Avec la nouvelle version, après que je l'ai configuré l'écran de veille, tout semblait fonctionner correctement, pas d'écran noir du tout. Après cela, j'ai effectué quelques personnalisations du système, dont la dernière consistait à supprimer les applications de démarrage, le gestionnaire de puissance (j'utilise un ordinateur de bureau et je pensais que c'était une perte de temps inutile pour l'exécuter). Après cela, et après un redémarrage, l'écran noir détesté s'est à nouveau montré. J'ai donc créé une nouvelle application de démarrage nommée Power Manager et j'ai défini "mate-power-manager" comme commande. Cette solution simple a fonctionné pour moi et je crois que j'ai eu le problème en 15.04 pour la même raison. J'espère que ça aide.

    
réponse donnée Marco 03.01.2016 - 17:53
la source
0

Lors de la visualisation de vidéos sur mon htpc, l’écran disparaît après 10 minutes sans saisie clavier / souris. Manifestement pas le comportement souhaitable pour un htpc. La désactivation des économiseurs d'écran et de l'économie d'énergie n'a eu aucun effet. Finalement, mes recherches sur le Web m'ont amené à croire que cela avait été causé par xserver. J'ai testé ceci en lançant ce qui suit:

xset s off && xset -dpms

dans un terminal au début d'une session et a confirmé que cela éliminait la suppression d'écran indésirable. L'exécution de xset -q dans le terminal confirme que DPMS (Energy Star) était désactivé.

Afin d’éviter d’avoir à ouvrir un terminal et d’exécuter cette commande au début de chaque session, je le configure pour qu’il s'exécute au démarrage du système. La suppression de l'écran était de retour et xset -q montrait DPMS activé. Une autre recherche a révélé que ce comportement est initié lors de la connexion et remplace la commande exécutée au démarrage. Pour l'exécuter automatiquement, ajoutez simplement les lignes ci-dessous à la fin du .profile dans votre dossier d'accueil.

Turn off screen blanking

xset s off && xset -dpms

Si vous ne voyez pas le fichier .profile, ouvrez votre dossier d'accueil dans votre navigateur de fichiers, cliquez sur "Afficher" et sélectionnez "Afficher les fichiers cachés". Ensuite, faites un clic droit sur .profile , sélectionnez "Ouvrir avec l'éditeur de texte", copiez et collez ce qui précède sur une ligne vide à la fin du fichier et enregistrez le fichier modifié.

    
réponse donnée rjd 14.07.2016 - 18:50
la source
0

Dans Greenie Linux (basé sur Lubuntu), j'ai supprimé xscreensaver et lightlocker, installé gnome-screensaver et l’a ajouté au démarrage automatique.

    
réponse donnée Ross Vassilev 30.07.2016 - 15:38
la source
0

Dans Lubuntu 16.10:

Bouton du menu principal (sur le panneau) - & gt; Préférences & gt; Power Manager & gt; L'onglet Affichage (probablement aussi le réglage automatique du verrouillage sur l'onglet Sécurité est nécessaire pour afficher les films).

    
réponse donnée Mateusz Konieczny 24.03.2017 - 21:38
la source
0

Lubuntu 16.04 LTS. J'ai essayé de suivre les instructions de Arturo Veras en installant xfce4-power-manager. Quand j'ai essayé, il a dit que c'était déjà la dernière version, donc je l'ai couru. C'est la même chose que de parcourir le menu:

Lubuntu | Préférences | Power Manager

J'ai essayé avant de trouver les informations d'Arturo, mais apparemment, je n'ai pas fait quelque chose de bien. Cette fois, j'ai défini les paramètres suivants sous "Plugged In"

Blank After: Jamais Dormir après: Jamais Éteindre après: jamais Sur l'inactivité réduire à: 80% Réduire après: Jamais (mais je peux changer celui-ci.)

Je suis allé souper, j'ai mangé, nettoyé la vaisselle, préparé des smoothies et je me suis assis pour écrire ceci, mais celui-ci n'est toujours pas vide. :)

Dans l’installation de Lubuntu 16.04 LTS à partir du lecteur flash en direct, Xfce Power Manager était automatiquement installé, donc je n’avais pas besoin de faire la ligne de commande.

J'espère que cela sera utile pour le prochain utilisateur de l'interface graphique.

    
réponse donnée Buck 08.01.2018 - 00:46
la source
0

Il existe une application caffeine pour gérer la désactivation de l’écran (et l’économiseur d’écran).

sudo apt-get install caffeine

Après l’installation, vous devez exécuter la commande caffeine-indicator . Ensuite, vous aurez une icône dans le bac. Cliquez dessus et sélectionnez Activate dans le menu contextuel pour empêcher l'affichage de s'éteindre. Si vous souhaitez autoriser l'affichage à s'éteindre à nouveau, vous devez cliquer sur l'icône caffeine plateau et sélectionner Deactivate dans le menu.

    
réponse donnée Oleg Svechkarenko 02.04.2018 - 08:07
la source
-1

les nouvelles versions d’Ubuntu utilisent gnome-screensaver, pas xscreensaver. Les paramètres sont dans Paramètres système - & gt; Luminosité et verrouillage

    
réponse donnée Ben Lin 04.06.2013 - 00:38
la source
-1

Installation de xfce4 pour éviter de noircir l'écran? C'est ridicule. Vous pouvez essayer au moins ce script simple avant d’utiliser un gestionnaire de bureau complet uniquement pour l’économiseur d’écran (qui s’allume lorsque vous n’utilisez pas l’ordinateur): lien

    
réponse donnée David Vartanian 17.02.2015 - 16:42
la source

Lire d'autres questions sur les étiquettes