Impossible de changer la luminosité du rétro-éclairage Ubuntu 14.04

25

Ce matin, j'ai constaté que je ne pouvais plus changer la luminosité de l'écran de mon ordinateur portable Dell XPs 13. J'ai essayé ce qui suit pour changer la luminosité

  • Utiliser les touches de luminosité du clavier
  • Exécutez les commandes ci-dessous
  • Démarrage avec l’option du noyau acpi_backlight = vendor. Cela a entraîné la présence d'un dossier dell_something dans le dossier / sys / class / backlight. Changer le fichier de luminosité dans ce dossier n'aide pas.
  • Ajoutez 'intel_backlight' à xorg.conf
  • Définissez l'option "Charger la mémoire ROM de l'option héritée" sur "Activé" et "Amorcer sécurisé" sur Désactivé
  • Démarrage avec l’option du noyau i915.disable-pch_pwm = 0
  • Démarrez depuis une nouvelle installation de la clé USB Ubuntu 12.04. Je ne peux toujours pas contrôler la luminosité. C'est étrange car l'ordinateur portable est préinstallé avec 12.04. Peut-être que c'est un problème de matériel?
  • Installez le dernier pilote vidéo intel

Y a-t-il des idées pour lesquelles cela s'est brusquement brisé? J'ai mis à jour du 12.04 au 14.04 en avril et jusqu'à hier, les touches de luminosité fonctionnaient bien.

Merci!

echo 100 > /sys/class/backlight/intel_backlight/brightness
echo 100 > /sys/class/backlight/acpi_video0/brightness
    
posée Lespaul86 04.06.2014 - 12:29
la source

16 réponses

27

J'ai un correctif pour mon ordinateur portable dell 5521, fonctionnant pour Ubuntu 14.04 mais fonctionnera pour les noyaux v3.13 +.

  1. Ouvrir /etc/default/grub

    sudo nano /etc/default/grub
    
  2. pour changer la ligne

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    à

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"
    
  3. puis enregistrez et quittez et

  4. exécuter

    sudo update-grub
    
  5. puis redémarrez

L’explication est que ACPI ajoute son propre contrôle de rétroéclairage même si un autre est déjà présent, à savoir intel_backlight , en ajoutant que cette ligne force CPI à utiliser le rétroéclairage Intel.

    
réponse donnée dushanabe 10.06.2014 - 20:29
la source
9

Pour moi, la solution est sur le rapport de bogue n ° 1249219 .

Fondamentalement, cela fonctionne en créant le fichier /usr/share/X11/xorg.conf.d/20-intel.conf avec les lignes suivantes:

Section "Device"
        Identifier "card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
        BusID "PCI:0:2:0"
EndSection
    
réponse donnée Daria 13.10.2014 - 18:16
la source
3

J'ai utilisé cette solution très simple et très simple:

  • Installer xbacklight
  • Ouvrez les applications de démarrage
  • Ajoutez un nouvel élément de démarrage (donnez-lui un nom et dans le type de ligne de commande: xbacklight -set 50 )

50 m'a donné le niveau de luminosité dont j'avais besoin, mais vous devrez peut-être tester les valeurs de votre système.

    
réponse donnée CeeDee 29.12.2014 - 13:29
la source
3

J'ai créé un script simple:

touch /usr/bin/brightness

Le contenu comme suit:

#!/bin/bash
echo  | sudo tee /sys/class/backlight/intel_backlight/brightness

Cela vous permet d’exécuter les opérations suivantes à partir de la ligne de commande:

brightness 100
brightness 4000

Les valeurs dépendent de vos valeurs maximales de luminosité que vous pouvez obtenir en exécutant:

cat /sys/class/backlight/intel_backlight/max_brightness 

N'oubliez pas de rendre le script exécutable:

chmod +x /usr/bin/brightness

J'ai choisi de ne pas modifier les autorisations du fichier de luminosité et de conserver la partie sudo pour des raisons de sécurité.

    
réponse donnée Tisch 21.09.2017 - 15:19
la source
2

J'ai lu beaucoup d'articles

Voici ce que j'ai fait, car je lutte depuis longtemps avec ça ...

Création et modification du fichier /usr/share/X11/xorg.conf.d/20-intel.conf avec les lignes suivantes ...

Section "Device"
   Identifier "card0"
   Driver "intel"
   Option "Backlight" "intel_backlight"
   BusID "PCI:0:2:0"
EndSection

... n'a pas fonctionné du tout

J'utilisais l'option xbacklight depuis un certain temps, mais cela ne me satisfaisait pas, car je savais que cela devait être possible avec Linux nativement.

J'ai essayé beaucoup d’options GRUB sans effet, alors j’étais encore en train de googler, de revenir pour résoudre ce problème.

Aujourd'hui, je suis arrivé à la solution suivante:

  1. Vous devez tuer votre gestionnaire d'affichage pour créer un nouveau fichier Xorg.conf (car il exécute le serveur X):
    • Appuyez sur Ctrl + Alt + F1 (Ne paniquez pas, pendant que votre système Windows s'exécute, vous pouvez revenir en arrière avec Ctrl + Alt + F7 )
    • tapez sudo service lightdm stop et appuyez sur Entrez (par exemple, gdm, kdm, xdm)
  2. Créer un nouveau fichier de configuration Xorg
    • tapez X -configure et appuyez sur Enter
    • tapez mv xorg.conf.new /etc/X11/xorg.conf et appuyez sur Enter
  3. Lancez X Server (vous pouvez tout faire sans interface graphique via la ligne de commande, mais j'étais plus à l'aise avec cette approche):
    • tapez sudo service lightdm start et appuyez sur Entrez (par exemple, gdm, kdm, xdm)
  4. Modifier le fichier Xorg.conf
    • naviguez jusqu'à /etc/X11/xorg.conf et ouvrez Xorg.conf (dans mon cas, le dernier était xorg.conf.05312015) via le Leafpad (par exemple, gedit, pluma)
    • recherche de Section "Device" et de Driver (sur mon PC, il est dit Driver "intel" par défaut, mais cela pourrait être autre chose, alors changez-le en intel )
    • ajouter la ligne Option "Backlight" "intel_backlight" après Driver "intel" (cela importe peu où, tant qu'il reste dans la section Périphérique)
    • enregistrer
  5. Modifier GRUB

    • sudo gedit /etc/default/grub (p.ex. tableur, pluma ...)
    • défini sur GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" ( acpi_osi= l'a fait pour moi, les autres options ne fonctionnaient pas ...)
    • dans le terminal, tapez sudo update-grub et appuyez sur Entrée
    • ou utilisez le personnaliseur GRUB:

    sudo add-apt-repository ppa:danielrichter2007/grub-customizer sudo apt-get update sudo apt-get install grub-customizer

  • appuyez sur Enregistrer dans le coin supérieur gauche, ce qui mettra à jour GRUB pour vous

    1. Redémarrer et profiter

Ce qui est amusant, c'est que ce code est exactement le même que dans /usr/share/X11/xorg.conf.d/20-intel.conf , mais cela a fonctionné comme prévu!

    
réponse donnée RiddleMeThis 31.05.2015 - 21:20
la source
2
  1. Ouvrir un terminal, exécutez gksudo gedit /etc/rc.local

  2. Il vous demandera un mot de passe. Tapez votre mot de passe.

  3. Ensuite, l'éditeur de texte apparaîtra avec le fichier rc.local ouvert. Il contient des éléments et à la fin exit 0 .

  4. Avant cette ligne exit 0 , ajoutez les commandes ci-dessous pour réduire la luminosité dans Ubuntu:

    echo x > /sys/class/backlight/intel_backlight/brightness
    echo y | tee /sys/class/backlight/acpi_video?*/brightness # (optional) > /dev/null
    

    où 0 ≤ x ≤ 4882 et 0 ≤ y ≤ 10.

  5. C'est ça. Enregistrez et redémarrez votre ordinateur.

réponse donnée Phoenix 18.04.2015 - 22:32
la source
1

Cela fonctionne pour Ubuntu 14.04 pour moi. Réglage de luminosité minimum:

echo 0 | sudo tee /sys/class/backlight/acpi_video0/brightness 

Maximum:

echo 7 | sudo tee /sys/class/backlight/acpi_video0/brightness
    
réponse donnée Edip Ahmet 31.10.2015 - 09:30
la source
1

Cela a fonctionné pour Acer 5830TG dans Ubuntu 16.04 LTS

  1. Assurez-vous d’abord que votre système utilise la carte graphique Intel

    $ ls /sys/class/backlight
    intel_backlight
    

    Au moins intel_backlight doit être mentionné

  2. Téléchargez et installez le pilote graphique Intel et suivez les instructions .

  3. Sur le fichier de configuration grub, /etc/default/grub modifie la ligne suivante:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    à

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    
  4. Puis mettez à jour grub

    sudo update-grub
    
  5. Créez et ouvrez le fichier /usr/share/X11/xorg.conf.d/20-intel.conf :

    gksudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf
    
  6. Ajoutez le texte suivant:

    Section "Device"
            Driver      "intel"
            Option      "Backlight"  "intel_backlight"
            Identifier "card0"
    EndSection
    
  7. Enregistrez et redémarrez.

réponse donnée mmm011 24.12.2016 - 07:54
la source
1

J'ai eu le même problème sur mon ordinateur portable Samsung avec Ubuntu 14.04 et le noyau 3.19.

Pour moi, la solution consistait à définir la ligne dans le fichier de configuration /etc/default/grub comme suit:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=0"

puis mettre à jour les paramètres:

sudo grub-update

Si cela ne vous aide pas, vous pouvez désactiver l'option de démarrage Legacy (CMS) dans le BIOS.

Avant d’essayer:

  • Définition du fichier /usr/share/X11/xorg.conf.d/80-backlight.conf
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"
réponse donnée yqbk 18.05.2016 - 21:46
la source
1

J'ai une réponse qui a fonctionné pour moi le 16.04 et maintenant le 18.04. Je pense que cette réponse s'applique uniquement si les deux déclarations suivantes s'appliquent à votre système . S'il vous plaît ne perdez pas votre temps si ces déclarations ne sont pas vraies:

  1. ls /sys/class/backlight/ renvoie acpi_video0 et exactement un autre, tel que intel_backlight
  2. echo 450 | sudo tee /sys/class/backlight/intel_backlight/brightness réduit la luminosité de moitié et echo 900 | sudo tee /sys/class/backlight/intel_backlight/brightness rend la luminosité maximale.

    (Ici, vous devez remplacer intel_backlight par ce que vous avez trouvé à l’étape 1 et en remplaçant 450 et 900 selon le paramètre de luminosité maximum de votre appareil, trouvé par la commande cat /sys/class/backlight/intel_backlight/max_brightness ou votre équivalent.)

Dans ce cas, votre problème est probablement dû au fait que le système a ajouté le module acpi_video0 de manière incorrecte et que les clés de luminosité l’utilisent au lieu de intel_backlight (ou votre équivalent).

Pour résoudre ce problème, vous devez ajouter l’option de démarrage
acpi_backlight=none qui supprimera le répertoire acpi_video0 de /sys/class/backlight/ . Les touches de luminosité appliquent désormais leur logique au seul répertoire de /sys/class/backlight/ , ce que nous voulons.

J'ai glané cette connaissance à partir de cette page utile lien qui indique que "Si vous trouvez que changer le acpi_video0 rétroéclairage ne modifie pas réellement la luminosité, vous devrez peut-être utiliser acpi_backlight=none . "

    
réponse donnée ianinini 22.07.2018 - 13:32
la source
0

cloner le script suivant et l'exécuter à partir d'un terminal racine après avoir collé le script dans /bin

git clone https://github.com/el-beth/backlight.sh.git

    
réponse donnée endrias 16.07.2017 - 19:57
la source
0

Cela a fonctionné pour ma série eeepc seashell:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

Ceci provient de lien , et ils l’ont eu de lien .

    
réponse donnée jlcolon 19.11.2014 - 02:20
la source
0

J'ai trouvé une solution après des années de recherche et cela fonctionne très bien.

Juste ajouté dans / etc / default / grub GRUB_CMDLINE_LINUX_DEFAULT string acpi_backlight=video .

Lenovo Ideapad Z500: Intel HD4000, GeForce 740m

    
réponse donnée randomprofilename 19.04.2018 - 07:41
la source
0

J'ai eu le même problème sur mon Lenovo Ideapad Z500.

J'ai trouvé cette astuce qui fonctionnait sur mon Ubuntu 16.04:

Dans le fichier de configuration GRUB, /etc/default/grub modifie la ligne suivante:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

en ajoutant cette chaîne: acpi_backlight=vendor . Dans mon cas, j'ai enlevé acpi-osi=linux et remplacé, donc à la fin c'était:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Mettre à jour grub en exécutant:

sudo update-grub

Créez ensuite un fichier de configuration xorg tel que celui-ci:

sudo touch /usr/share/X11/xorg.conf.d/80-backlight.conf

et copiez-y ce texte:

Section "Device"
     Identifier  "Intel Graphics"
     Driver      "intel"
     Option      "AccelMethod"     "sna"
     Option      "Backlight"       "ideapad" 
     BusID       "PCI:0:2:0"
EndSection

Enregistrez le fichier et redémarrez.

Vous pouvez également essayer d’utiliser des clés de luminosité Fn en dehors d’Ubuntu (avant qu’elles ne commencent ou dans les paramètres du BIOS). Ça pourrait marcher.

    
réponse donnée erostrato 08.05.2016 - 15:25
la source
0

Xubuntu 16.04 (Samsung N150 - Intel GMA3150):

Correction d'un problème de contrôle de la luminosité en créant /usr/share/X11/xorg.conf.d/20-intel.conf avec le texte suivant:

Section "Device"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        Identifier "card0"
EndSection

Merci à: ArchLinux - Samsung_N150_Backlight et Daria

    
réponse donnée BBQ 29.11.2016 - 10:17
la source
-3

Voici ce que j'ai fait:

$sudo su -
#more /sys/class/backlight/intel_backlight/brightness 
19200

J'ai changé la valeur à 50200

#nano /sys/class/backlight/intel_backlight/brightness
50200

et sauvé. Cela a changé la luminosité immédiatement. J'utilise un ordinateur portable Asus X441N: lien

    
réponse donnée user807497 17.11.2017 - 13:06
la source

Lire d'autres questions sur les étiquettes