Panique du noyau après la mise à jour vers la version 4.4.0-108-generic

32

Aujourd'hui, j'ai eu ce que je présume être la mise à jour qui devrait prendre en charge Spectre et Meltdown. Cela ne s'est pas très bien passé. Qu'est-ce que je fais maintenant? Voir la photo à l'écran.

Je ne peux pas démarrer le noyau 4.4.0-108-générique à cause d'une panique du noyau. J'utilise 16.04 sur un processeur Intel Core i5-4670K à 3,40 GHz × 4.

    
posée fregger 10.01.2018 - 00:47
la source

5 réponses

32

N'installez pas 4.4.0-108-generic sur Xenial! Il interrompt les fonctionnalités d'amorçage / redémarrage / arrêt / suspension !

Installez 4.4.0-109-generic ( consultez USN-3522-3 pour plus de détails) !

Redémarrez sur le dernier noyau actif et supprimez 4.4.0-108-generic:

  1. Appuyez sur Shift entre UEFI / BIOS et l'écran de connexion pour entrer GRUB
  2. Dans GRUB, sélectionnez Advanced options for Ubuntu et sélectionnez Ubuntu, with Linux 4.4.0-xxx-generic (où xxx & lt; 108)
  3. Connectez-vous au système et supprimez ce bug 4.4.0-108-generic et installez plutôt 4.4.0-104-generic.

    sudo apt-get purge linux-headers-4.4.0-108 linux-headers-4.4.0-108-generic \
    linux-image-4.4.0-108-generic linux-image-extra-4.4.0-108-generic \
    linux-tools-4.4.0-108 linux-tools-4.4.0-108-generic
    sudo apt-get autoremove
    sudo apt-get install linux-headers-4.4.0-104 linux-headers-4.4.0-104-generic \
    linux-image-4.4.0-104-generic linux-image-extra-4.4.0-104-generic \
    linux-tools-4.4.0-104 linux-tools-4.4.0-104-generic
    

À partir de 2018-01-10 18:00 UTC, le noyau 4.4.0-109-generic semble être distribué sur des miroirs.

Mais si vous le souhaitez, vous pouvez sélectionner Serveur principal ( lien ).
Vous pouvez y accéder à partir de software-properties-gtk / software-properties-kde .

Vous pouvez installer 4.4.0-109-generic avec les commandes suivantes:

sudo apt-get update
sudo apt-get install linux-headers-4.4.0-109 linux-headers-4.4.0-109-generic \
linux-headers-generic linux-image-4.4.0-109-generic \
linux-image-extra-4.4.0-109-generic linux-image-generic \
linux-tools-4.4.0-109 linux-tools-4.4.0-109-generic linux-tools-generic
    
réponse donnée N0rbert 10.01.2018 - 13:14
la source
6

Dans votre menu de démarrage, choisissez advanced options for ubuntu .

Vous pouvez y démarrer à partir d’un noyau plus ancien (qui est toujours installé).

    
réponse donnée Erik Lamers 10.01.2018 - 11:21
la source
1

Je ne peux pas démarrer avec 109 ou 108 ubutnu VM sur win 7 x64

voir: lien

mon question

J'ai dû démarrer avec 104

    
réponse donnée rajeev 15.01.2018 - 22:03
la source
0

Cela a résolu le problème pour moi:

  1. Utilisation du menu de démarrage grub, lancez la version précédente du noyau.
  2. Installer un noyau encore plus récent

sudo apt install linux-generic-hwe-16.04-edge

mise à jour: ressemble à problème avec la version 4.4.0.108 corrigé avec la version 4.4.0.109 publiée tout à l'heure.

    
réponse donnée Yngvi Hrafn Pétursson 10.01.2018 - 13:20
la source
-1

Vous pouvez installer le dernier patch avec succès si vous démarrez avec un noyau plus ancien (je suis revenu sur trois versions), puis exécutez toutes les options avancées d'Ubuntu "nettoyage du système", y compris fsck. Il y a apparemment quelque chose dans les versions précédentes qui doit être "corrigé" avant que le correctif ne puisse être installé avec succès.

    
réponse donnée Bill Wilken 11.01.2018 - 13:51
la source

Lire d'autres questions sur les étiquettes