14.04 n'a pas de package imagemagick

29

D'habitude, j'avais installé Image Magick sur mes systèmes Ubuntu avec une commande comme celle-ci

sudo apt-get install imagemagick

ou comme ça:

sudo apt-get install php5-imagick

En ce moment, je lance le dernier 14.04, et ces paquets semblent avoir disparu des dépôts. Est-ce que je manque quelque chose? Ont-ils été obsolètes? Comment pourrais-je installer ImageMagick maintenant?

    
posée Enrique Moreno Tent 23.05.2014 - 12:38
la source

4 réponses

49

Le paquet que vous recherchez est imagemagick . Confirmez que toutes les sources sont cochées dans "Logiciels et mises à jour":

puis mettez à jour la liste des paquets en ouvrant un terminal ( Ctrl + Alt + t ), puis en tapant ce qui suit:

sudo apt-get update

et entrez votre mot de passe, puis

sudo apt-get install imagemagick php5-imagick

puis appuyez sur Retour pour confirmer l'installation.

    
réponse donnée jobin 23.05.2014 - 12:44
la source
9

Dans Ubuntu 14.04, imagemagick est disponible sur le dépôt principal & amp; php5-imagick est disponible sur le référentiel d'univers. Alors suivez la commande dans le terminal:

sudo add-apt-repository main
sudo add-apt-repository universe
sudo apt-get update
sudo apt-get install imagemagick php5-imagick
    
réponse donnée Pandya 23.05.2014 - 14:14
la source
2

ça a fait le tour pour moi ...

sudo apt-get install php5-imagick
sudo service apache2 reload
    
réponse donnée Mark N Hopgood 14.07.2015 - 18:31
la source
1

J'ai utilisé ce qui suit:

sudo apt-get update
sudo apt-get install imagemagick php-imagick

et a également dû redémarrer apache avant de commencer à fonctionner:

systemctl restart apache2
    
réponse donnée danlynn 28.01.2017 - 08:51
la source

Lire d'autres questions sur les étiquettes