La vidéo flash apparaît en bleu

243

Le problème

Après la mise à jour d’Ubuntu 11.10 vers Ubuntu 12.04, toutes les vidéos sont toujours bleues, qu’elles soient lues dans un navigateur ou un lecteur. Le même problème se produit également en 11.10.

J'ai essayé de désinstaller tous les fichiers Flash et de les réinstaller, mais cela ne fait aucune différence.

Quelle est la cause de la vidéo Flash bleue?

Ubuntu 11.10 64bit

Ubuntu 12.04LTS 64bit

À quoi ça ressemble

    
posée pst007x 29.03.2012 - 20:42
la source

19 réponses

51

Correction (contournement)

Problème: Tous les navigateurs Web flash player video sont bleus

  • Chrome
  • Google Chrome
  • Firefox

Les deux plug-ins flash provoquent une superposition bleue de la vidéo flash. Supprimez-la.

  • Adobe - flashplugin
  • Flashplugin - installateur

Solution (pas aussi fonctionnelle que le plug-in Adobe Flash mais ça marche)

  • Installer lightspark (plus les plug-ins de navigateur) ou
  • Installez gnash (plus les plug-ins de navigateur)

Correctif possible 1

Supprimé:

  • Plug-ins de navigateur gnash
  • Plug-ins de navigateur gightspark
  • API de décodage et de présentation vidéo pour Unix (bibliothèques) libvdpau1
  • flashplugin - installateur

Installé:

adobe-flashplugin Le navigateur a redémarré, et cela a fonctionné pour moi.

Correctif possible 2

Installé:

  • libvdpau1

Configuration Flash

  • désactiver l’accélération matérielle dans Flash.

Ouvrez votre navigateur et accédez à une vidéo flash (youtube, abobe flash site, etc.) cliquez avec le bouton droit de la souris, sélectionnez les paramètres et désactivez l'accélération matérielle.

Si vous ne parvenez pas à désactiver l’accélération matérielle, connectez-vous à l’environnement 2D Unity.

BOGUE: lien

OBS: En cas de persistance. Redémarrez la machine.

    
réponse donnée pst007x 30.03.2012 - 21:26
la source
187

Il y a des recommandations trompeuses et des recommandations erronées, alors résumons le problème et les solutions.

TL; DR

Les dernières versions d’Ubuntu depuis la version 12.10 (Quantal) contiennent une version corrigée de la bibliothèque. Si vous rencontrez toujours des problèmes avec la vidéo bleue (sauf le groupe Blue Man ), consultez cette réponse - le nom de la bibliothèque de Flash Player doit être libflashplayer.so sinon libvdpau n'appliquera pas la solution de contournement. Vous pouvez également consulter le fichier /etc/vdpau_wrapper.cfg . Là, vous pouvez désactiver les solutions de contournement appliquées par libvdpau.

Si vous avez Oneiric (11.10) ou Precise (12.04), installez le fichier libvdpau corrigé:

sudo add-apt-repository ppa:tikhonov/misc
sudo apt-get update
sudo apt-get install libvdpau1

Sinon, vous pouvez modifier la bibliothèque de Flash Player:

cd /usr/lib/flashplugin-installer || cd /usr/lib/adobe-flashplugin/
sudo perl -pi.bak -e 's/libvdpau/lixvdpau/g' libflashplayer.so

Lisez l'intégralité de l'article avant de commenter.

Le problème

Flash Player depuis la version 11.2 utilise l’accélération vidéo matérielle sur la plupart des plates-formes. Malheureusement, l’accélération sous Linux n’est pas seulement non prise en charge, mais essentiellement brisée. Flash Player échange les couleurs de la vidéo dans les conditions suivantes:

  • Vous utilisez un GPU Nvidia assez récent avec le support VDPAU .
  • Vous utilisez la version actuelle du pilote binaire Nvidia (les anciennes versions ne prennent pas en charge VDPAU).
  • Le paquetage libvdpau1 est installé.
  • Le lecteur du site utilise Stage Video - c'est pourquoi seuls YouTube et quelques autres joueurs sont concernés .

Voir l'explication de Pierre-Loup Griffais de Nvidia .

Ce n'est pas un bogue dans les pilotes Nvidia. Nvidia est conscient de ce problème et a déjà créé une solution de contournement. Le pilote Nouveau n'est probablement pas affecté car le support de décodage vidéo n'est pas encore terminé .

Ce n'est pas un bogue dans libvdpau. libvdpau est juste un wrapper qui permet aux lecteurs vidéo d'utiliser le décodage VDPAU (voir Explication de Stephen Warren ).

Ce n'est pas un bogue spécifique à Ubuntu. D'autres distributions sont également affectées, par exemple Arch .

Le bogue est très probablement dans Flash Player - même si Adobe essaie de blâmer Nvidia et les utilisateurs incompétents. Il y a eu plusieurs rapports sur le bugtracker d'Adobe, tous ont été rejetés comme "CannotReproduce":

  • lien
  • lien
  • lien
  • lien
  • lien
  • lien

Adobe ne proposera pas de correctif officiel, car Flash Player basé sur NPAPI ne reçoit que des correctifs de sécurité jusqu'en 2017. Espérons que nous n'aurons pas besoin de Flash Player à ce moment-là.

Les solutions de contournement

Utilisez libvdpau 0.5

Disponible dans les dépôts officiels depuis Ubuntu 12.10 libvdpau 0.4.1-6

Cette version de libvdpau inclut une solution de contournement de Stephen Warren décrite ci-dessous.

Voir l'annonce du lancement

Installer le correctif libvdpau (correctif)

Stephen Warren a créé un joli patch pour libvdpau , qui détecte Flash Player et s'applique solutions de contournement que pour cela. Le patch peut être contrôlé à l'aide du fichier /etc/vdpau_wrapper.cfg .

libvdpau corrigée corrige les couleurs et permet à Flash Player d’utiliser VDPAU pour la superposition matérielle, qui offre néanmoins des avantages en termes de performances.

Pour que le wrapper fonctionne, il doit reconnaître l’utilisation de Flash. La bibliothèque Flash doit donc être nommée libflashplayer.so et le wrapper doit être activé dans Firefox (dans about:config , dom.ipc.plugins.enabled.libflashplayer.so et dom.ipc.plugins.enabled doivent être définis sur true ).

Pour Precise (12.04) et Oneiric (11.10), vous pouvez installer libvdapu corrigé à partir de PPA de Maxim Thikonov en utilisant les commandes suivantes:

sudo add-apt-repository ppa:tikhonov/misc
sudo apt-get update
sudo apt-get install libvdpau1

La modification devrait entrer en vigueur après le redémarrage (ou éventuellement plus tôt).

Empêchez Flash Player de trouver libvdpau

(Via Daniel Mario Vega sur Launchpad )

Localisez libflashplayer.so dans votre système - pour Ubuntu, il s'agit soit de /usr/lib/adobe-flashplugin/ si adobe-flashplugin package est installé, soit de /usr/lib/flashplugin-installer/ pour flashplugin-installer package. Consultez about:plugins de votre navigateur si vous ne parvenez pas à trouver le fichier ( un petit ajustement dans le cas de Firefox peut être requis).

Exécutez les commandes suivantes - en supposant que vous avez installé flashplugin-installer ou adobe-flasplugin :

 cd /usr/lib/flashplugin-installer || cd /usr/lib/adobe-flashplugin/
sudo perl -pi.bak -e 's/libvdpau/lixvdpau/g' libflashplayer.so

La modification prend effet après le redémarrage du navigateur.

Cela va modifier le binaire de Flash Player pour rechercher la bibliothèque "lixvdpau" inexistante au lieu de "libvdpau". Par conséquent, il ne tentera pas d'utiliser la présentation VDPAU.

La commande crée la sauvegarde libflashplayer.so.bak du binaire si vous rencontrez des problèmes.

Vous devez exécuter cette commande chaque fois qu’une mise à jour de Flash Player est effectuée, car votre modification sera remplacée.

Avec cette solution de contournement, vous pouvez garder l'accélération matérielle activée, installer libvdpau1 et il est très facile à appliquer par rapport à l'application de correctifs libvdpau.

Utilisez Google Chrome avec PepperFlash

Depuis la version 20, Google Chrome est livré avec "Pepper" Flash Player 11.3 avec prise en charge de PPAPI (au lieu de 11.2 sur NPAPI utilisé par Firefox et autres). PepperFlash ne semble pas être affecté par ce problème car il semble utiliser une accélération matérielle complète.

PepperFlash peut être utilisé avec Chrome , mais malheureusement aucun autre navigateur ne supporte actuellement PPAPI.

Désactiver l’accélération matérielle de Flash Player

La solution la plus simple et la moins intrusive consiste à désactiver la accélération matérielle dans les paramètres d’affichage de Flash Player. - cliquez avec le bouton droit sur Flash, sélectionnez Paramètres ...

Cela n’est cependant pas si facile, car la fenêtre Paramètres ne répond pas dans le gestionnaire de composites (Compiz, Unity standard) et si le navigateur affiche des barres de défilement.

Pour désactiver l’accélération matérielle, ouvrez toute vidéo (par exemple sur YouTube) en plein écran et puis ouvrez la fenêtre Paramètres .... Vous pouvez également passer temporairement à Unity 2D ou à un autre WM non composite.

La modification prend effet après l’actualisation.

Inconvénient: cette option désactive l’accélération matérielle dans Flash Player, même pour les opérations vectorielles et bitmap. Certains jeux et films Flash peuvent avoir de moins bonnes performances et / ou de meilleurs graphiques.

Désinstallez libvdpau

Si vous souhaitez activer l’accélération matérielle dans Flash Player, vous pouvez désinstaller libvdpau du système, ce qui empêche effectivement Flash Player d’utiliser VDPAU.

Exécuter:

sudo apt-get remove libvdpau1

L'inconvénient: les lecteurs de bureau (comme Totem et Mplayer) ne pourront pas non plus utiliser le décodage vidéo matériel. Cela entraînera une augmentation de l'utilisation du processeur pendant la lecture. De plus, les performances de lecture vidéo peuvent être affectées (par exemple, des images perdues ou des images complètement figées), en particulier si le processeur est plus lent et que vous regardez des vidéos 1080p.

Activer le décodage vidéo du matériel Flash Player

La plupart des utilisateurs ont signalé que cela entraînait des pannes très fréquentes de Flash Player (probablement dues à des problèmes de concurrence lors du décodage), mais si vous vous sentez chanceux, essayez-le.

C'est également la même méthode utilisée par addon Flash-Aid . Cela ne le rendra pas meilleur.

Exécuter:

sudo mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1" | sudo tee /etc/adobe/mms.cfg > /dev/null

Cela créera le fichier /etc/adobe/mms.cfg avec EnableLinuxHWVideoDecode=1 content. C'est la seule façon de forcer Flash Player à décoder la vidéo sur GPU et elle n'est pas officiellement prise en charge par Adobe.

Pour annuler cela, exécutez:

sudo rm /etc/adobe/mms.cfg

pour supprimer le fichier mms.cfg.

Vous pouvez essayer d’améliorer encore la stabilité de Flash Player avec la variable d’environnement VDPAU_NVIDIA_NO_OVERLAY=1 , consultez Forums Nvidia .

Remplacer les lecteurs Flash

(Recommandé par Bowser sur Launchpad )

Utilisez le module complémentaire Firefox FlashVideoReplacer , Literna Mágica ou une autre solution pour remplacer les lecteurs standard de Flash par un plug-in de lecteur vidéo intégré (comme Totem - totem-mozilla - ou VLC - mozilla-plugin-vlc ). Pas de lecteur Flash, pas de problème.

Patch libvdpau (hack vdpau_trace)

Il existe un correctif non officiel de Nvidia qui corrige le bogue de Flash Player au niveau libvdpau par piratage vdpau_trace.

Notez que le correctif susmentionné de Stephen Warren est techniquement supérieur et devrait être utilisé à la place.

Les solutions de contournement

Les solutions suivantes ne fonctionneront que partiellement ou elles peuvent avoir certaines réserves.

Activer HTML5 sur YouTube

Activer le lecteur HTML5 à lien ne fonctionnera pas avec toutes les vidéos; Certaines vidéos YouTube ne sont tout simplement pas disponibles pour le lecteur HTML5 (par exemple en raison du manque de prise en charge des annonces). Toutefois, la vidéo HTML5 est géniale et vous devriez l’utiliser quand même.

Rétrograder vers Flash Player 11.1

Il existe des vulnérabilités connues dans FP 11.1 qui sont corrigées dans la version 11.2. Si vous voulez risquer cela, vous devriez savoir dans quoi vous vous engagez.

Si vous voulez quand même rétrograder, essayez Flash Player 10.3 qui est toujours maintenu - vous pouvez l’obtenir dans Archives d'Adobe

Passer à un autre GPU

Il semble que très peu de GPU Nvidia ne soient pas affectés, particulièrement Quadro 2000 et GeForce GT 430. Tous deux ont VDPAU, jeu de fonctionnalités C , mais sinon la plupart des GPU de jeu de fonctionnalités sont également affectés. Si vous avez l'un des GPU mentionnés ci-dessus, veuillez nous indiquer sur Launchpad si le bogue vous affecte.

    
réponse donnée jnv 13.04.2017 - 14:24
la source
94

MISE À JOUR: Veuillez consulter cette solution pour un correctif approprié. La solution mentionnée ici entraîne des pannes pour beaucoup de ceux qui ont essayé.

Ceci est dû à un bug dans la nouvelle version de Flash que Adobe refuse réparer. Il y a aussi un rapport de bogue sur Launchpad qui en parle (LP: # 967091 ) . Le bogue n'apparaît que lorsque vous utilisez les pilotes binaires NVidia et que libvdpau est installé. Une solution rapide ajoute des paramètres supplémentaires à la configuration Flash.

sudo mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg > /dev/null

Cela corrige le problème tout en ayant toujours une accélération matérielle VDPAU. Malheureusement, il n'y aura probablement pas de nouvelle version de Flash pour résoudre ce problème sans ce manuel de configuration car la version Flash qui a introduit ce bogue est également la dernière version de Flash pour Adobe.

Si cela provoque une instabilité pour vous, annulez les modifications en supprimant le répertoire que vous avez créé auparavant.

sudo rm -r /etc/adobe

ou vous pouvez essayer de réduire le fichier /etc/adobe/mms.cfg à la

OverrideGPUValidation=true

ligne en éditant avec sudo gedit /etc/adobe/mms.cfg.

    
réponse donnée mniess 31.03.2012 - 22:22
la source
14

Ok, alors voici mon expérience avec la résolution de ce problème (sur les pilotes Ubuntu 12.04 64 bits, nVidia):

  • Supprimer l'installateur flashplugin et installer adobe-flashplugin ( ne l'a pas corrigé )

Cela a fonctionné jusqu'au redémarrage. Mais j'ai gardé adobe-flashplugin depuis que je suis sur 64 bits (j'ai eu l’impression que cela fonctionnait le mieux).

  • Modification de la version du pilote ( n'a pas résolu le problème )

Au début, j’avais les mises à jour de nvidia-current, je les ai changées en nvidia-current. Cela ne l'a pas réparé. Synaptic indique que les versions du pilote sont identiques à celles de cette écriture (295.33).

  • Installation du module complémentaire Flash-Aid dans Firefox ( corrigé, mais instable )

Cela a fonctionné aussi longtemps que j'ai activé l'option d'accélération matérielle (à ne pas confondre avec l'option ci-dessous !!). Peu importe si j'installais le plugin Flash à partir de référentiels ou de la version bêta d'Adobe. Cependant, tout en corrigeant la teinte bleuâtre, le plug-in est devenu extrêmement instable et se bloque constamment lors de l'interaction avec les objets Flash.

  • Activation de la vidéo HTML5 sur Youtube ( correction sur Youtube )

Bien que je n’aie eu ce problème que sur les vidéos Youtube, je ne suis pas sûr que les autres sites et vidéos ne soient pas affectés. Comme suggéré par d'autres personnes ici, visitez youtube.com/html5 si vous souhaitez activer ou désactiver la vidéo HTML5 sur Youtube.com.

  • Désactivation de l’accélération matérielle par un clic droit sur une vidéo Flash (réparée)

C'est ce qui a le mieux fonctionné pour moi (mais je devais me connecter avec Unity 2D selon la suggestion de pst007x dans ce fil de discussion) . La teinte bleuâtre a disparu et les vidéos sont stables. J'avais peur que la charge de travail du processeur augmente mais en testant avec et sans accélération matérielle, je ne voyais aucun changement (j'ai utilisé une vidéo du canal Googles en 1080p pour cela), elle commence à environ 40% et tombe à 20% lorsque la vidéo est complètement chargé.

    
réponse donnée foh1981 31.03.2012 - 14:37
la source
9

Ma solution rapide à YouTube, de toute façon, consistait à rejoindre leur version bêta HTML5 .

Cela a fonctionné un régal ... Et de ce que je peux voir, il semble que seul YouTube soit affecté par ce vieux bogue qui remonte sa tête laide ...

Il est préférable de commencer à utiliser HTML5. Vous devez vous rappeler que Flash est en train de disparaître quand il s’agit de Linux. Ensuite, nous devrons tous utiliser Google Chrome et rien d’autre: (

    
réponse donnée MikeH 31.03.2012 - 03:53
la source
4

J'ai résolu ce problème après avoir retiré le lecteur flash, puis installé manuellement le flash-back en téléchargeant le flash depuis le site d’Adobe et en l’installant via Ubuntu Software Center.

    
réponse donnée subeh.sharma 16.01.2012 - 10:27
la source
3

J'ai résolu ce problème (en utilisant Linux Mint Lisa, basé sur Ubuntu Oneiric) en déplaçant le pilote NVIDIA vers la version 173.

Mise à jour: Malheureusement, la version 173 du pilote NVIDIA produit la même teinte bleue dans les vidéos MP4 que la version recommandée (mise à jour) du pilote NVIDIA fait dans les vidéos Flash . C'est un peu exaspérant: je peux avoir mon café trop froid ou trop sucré.

Et une autre mise à jour: j'ai été capable de résoudre le problème de MP4 dans Totem en accédant aux Préférences et en déplaçant complètement le curseur de Teinte vers la droite. Chaud et pas trop sucré.

    
réponse donnée Avi Jacobson 23.01.2012 - 04:43
la source
3

Essayez ceci:

sudo apt-get purge flashplugin-installer
sudo apt-get install adobe-flashplugin
    
réponse donnée SirCharlo 30.03.2012 - 15:11
la source
2

Cela peut être un problème si les pilotes Nvidia sont installés avec la dernière version de Flash. Essayez de cliquer avec le bouton droit sur la vidéo Flash et de désactiver l’accélération matérielle depuis les paramètres. Cela a fonctionné pour moi.

    
réponse donnée Mark Taylor 30.04.2012 - 13:24
la source
1

J'ai le même problème. J'utilise Linux 3.2.0-24-générique (32 bits), Flash (dernière version) 11.2.202.236 et Mozilla Firefox.

J'ai essayé d'annuler l'accélération dans les paramètres globaux - cela ne l'a pas réparé. J'ai essayé de réinitialiser les paramètres du pilote Nvidia pour mon écran X.

Il n’ya aucun problème avec la couleur du lecteur vidéo et il y a des vidéos que je peux lire sur Internet et qui sont acceptables, mais pas des vidéos YouTube.

Créer un fichier mms.cfg a fonctionné. Cependant, il a éliminé le lecteur multimédia et les reproductions miro (les vidéos et les films sont devenus bleus là-bas).

J'ai ensuite suivi ceci:

  1. Ouvrez les propriétés de gstreamer ( Alt + F2 , entrez gstreamer-properties ). Passez à l'onglet vidéo. Remplacez le plug-in de sortie par défaut par "X Window System (X11 / XShm / Xv)". Make Device -Default. Testez et fermez la boîte.
réponse donnée user70284 13.06.2012 - 08:52
la source
1

J'ai encore eu ce problème après une mise à niveau. J'ai compris que pour que l'option enable_flash_uv_swap de /etc/vdpau_wrapper.cfg fonctionne, le fichier de la bibliothèque Flash (ou lien symbolique) doit être nommé libflashplayer.so (le mien était flashplayer-alternative.so ). Je viens donc de renommer flashplayer-alternative.so en libflashplayer.so et cela a commencé à fonctionner.

Pour plus d'informations, consultez [ANNONCE] libvdpau 0.5 :

  

Cette solution est appliquée si "libflashplayer" se trouve dans   / proc / self / cmdline et la chaîne "enable_flash_uv_swap = 1" se trouve dans   /etc/vdpau_wrapper.cfg.

    
réponse donnée nicudotro 07.05.2013 - 01:46
la source
0

J'ai utilisé Flash-Aid , il a été corrigé loin.

    
réponse donnée Shaun 29.03.2012 - 08:41
la source
0

Ok. Voici le correctif, qui l'a fait pour moi et je suis sûr qu'il devrait le faire pour tout le monde !!

sudo apt-get remove libvdpau1
sudo apt-get install flashplugin-installer

après cela, faites:

sudo mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg > /dev/null
    
réponse donnée entonjackson 30.04.2012 - 08:48
la source
0

La désinstallation de libvdpau1 résout ce problème pour moi. Pour l'instant ...

    
réponse donnée Gonzoza 01.05.2012 - 21:55
la source
0

Pour les utilisateurs de NVIDIA. J'ai testé 3 cartes vidéo dès maintenant. Tous les Nvidia. Donc pour tous ceux qui ont une Nvidia 8600 GT, une Nvidia 9500 ou une Nvidia 440 GT (peut-être toutes les cartes Nvidia). Vous devez uniquement supprimer le package libvdpau1 . Ensuite, lancez Firefox ou Chrome et tout devrait être bon.

sudo apt-get remove libvdpau1 and done.

Testé sur youtube avec / sans rejoindre le HTML5 et fonctionne dans les deux sens.

Testé vimeo et TED également. Tout se passe comme il se doit.

Vous ne devez utiliser cette option que si vous avez un bon processeur, car la suppression de ce paquet envoie le décodage vidéo au processeur plutôt qu’au GPU. Quoi qu’il en soit, si vous avez un Dual Core ou mieux, vous ne rencontrerez aucun problème même avec une vidéo 1080p.

    
réponse donnée Luis Alvarado 02.05.2012 - 18:58
la source
0

Cela semble être un problème avec la mise à jour 11.2.202.228 et ci-dessous est la solution la plus rapide et la plus raisonnable jusqu'à ce qu’Adobe le résolve:

sudo apt-get remove flashplugin-installer 
wget https://launchpad.net/ubuntu/+archive/partner/+files/adobe-flashplugin_11.1.102.63.orig.tar.gz    
tar xzvf *.tar.gz

Localisez le libflashplayer.so pour votre architecture.

cp /usr/lib/flashplugin-installer/libflashplayer.so libflashplayer.so.bak

Copiez le nouveau libflashplugin.so dans le répertoire ci-dessus, écrasez et redémarrez votre navigateur.

    
réponse donnée sm0ke 31.03.2012 - 21:32
la source
0

Une autre façon de résoudre ce problème (qui a fonctionné à chaque fois pour moi) est la suivante:

Lorsqu'une vidéo flash est en cours de lecture, cliquez avec le bouton droit dessus - & gt; Paramètres - & gt; Décochez "activer l'accélération matérielle" - & gt; Actualiser la page

    
réponse donnée dlin 09.08.2012 - 21:15
la source
-1

Le problème est dû aux pilotes NVIDIA. Assurez-vous d'utiliser les pilotes indiqués sous la forme Recommended sous Système & gt; Pilotes supplémentaires . Cela m'est arrivé, et maintenant je n'ai pas la brume bleue dans mes vidéos.

    
réponse donnée Petronilla Escarabajo 29.03.2012 - 22:03
la source
-1

Reportez-vous à la section Correction d'un problème lié à la vidéo Blue Tint de Youtube. Ubuntu 12.04 , et suivez les instructions pour installer le nouveau VDPAU1, et il corrigera le problème correctement.

    
réponse donnée TenPlus1 13.06.2012 - 10:40
la source

Lire d'autres questions sur les étiquettes