Chrome + Écran tactile + Unité (14.04)

23

J'ai un Dell 14R avec écran tactile avec Ubuntu 14.04. Lorsque je lance Google Chrome en cliquant sur le lanceur à l'aide du pavé tactile ou de la combinaison Super +, appuyez sur l'assistance dans Chrome ne fonctionne pas. Lorsque je touche un élément, il obtient uniquement la mise au point, mais n'active pas l'élément (bouton, champ, etc.). Et les gestes tactiles ne fonctionnent pas. D'autre part, si je lance Chrome en appuyant sur le bouton du lanceur, le défilement tactile fonctionne dans Chrome, même un glissement vers la gauche revient à la page précédente, etc. Cela n'a pas de sens pour moi, mais c'est toujours comme ça, même après les redémarrages. Tout le monde peut le confirmer? Une idée sur la façon de réparer?

    
posée Luis Fernando P. Gonzalez 24.05.2014 - 16:00
la source

3 réponses

23

Ce problème pourrait être résolu avec le paramètre de ligne de commande --touch-devices de Chrome.

Déterminez l'identifiant du périphérique d'entrée de X dans une console en

.
xinput list

conduisant à

google-chrome --touch-devices=10

sur mon système.

Pour que Chrome utilise toujours cet indicateur CLI, voir: Comment définir des indicateurs CLI pour Google Chrome?

    
réponse donnée alex 08.06.2014 - 16:44
la source
7

Réponse MISE À JOUR:

  1. Modifiez ~/.profile et ajoutez les éléments suivants à la fin du fichier:

    export CHROMIUM_USER_FLAGS="--touch-devices='echo $(xinput list | grep 'Virtual core pointer' | awk 'match(\
    #!/bin/bash
    /usr/bin/google-chrome-stable --touch-devices=$(xinput list | grep Touchscreen | awk 'match(\
    export CHROMIUM_USER_FLAGS="--touch-devices='echo $(xinput list | grep 'Virtual core pointer' | awk 'match(\
    #!/bin/bash
    /usr/bin/google-chrome-stable --touch-devices=$(xinput list | grep Touchscreen | awk 'match(\%pre%, /id=/){print substr($0, RSTART+3, RLENGTH)}') --touch-events=enabled --enable-pinch
    
    , /id=/){print substr($0, RSTART+3, RLENGTH-1)}')' --touch-events=enabled --enable-pinch"
    , /id=/){print substr($0, RSTART+3, RLENGTH)}') --touch-events=enabled --enable-pinch
    , /id=/){print substr($0, RSTART+3, RLENGTH-1)}')' --touch-events=enabled --enable-pinch"
  2. Déconnectez-vous puis reconnectez-vous.

  3. Démarrez Google Chrome normalement

CONSEIL : vous devrez peut-être remplacer la chaîne "Pointeur de base virtuel" dans la commande ci-dessus par le nom de votre périphérique de saisie à écran tactile "maître pointeur". Utilisez simplement la commande xinput pour trouver le nom de votre appareil.

REMARQUE : Je suis sous Ubuntu 15.04 avec /usr/bin/google-chrome-stable

.

ANCIENNE Réponse:

J'ai Ubuntu 14.14. Cela a fonctionné pour moi:

  1. Créez un script shell pour démarrer le navigateur Google Chrome appelé start-chrome.sh .

    J'ai mis le mien dans: /usr/local/bin/start-chrome.sh

    Ajoutez les éléments suivants au fichier:

    %pre%

    En gros, j'utilise la commande xinput list , je cherche "Écran tactile" et je trouve son id correspondant. Vous devrez peut-être remplacer "Écran tactile" par le nom de votre périphérique de saisie à écran tactile dans la commande ci-dessus.

  2. Éditez /usr/share/applications/google-chrome.desktop . Recherchez toutes les occurrences de Exec=google-chrome-stable et remplacez-les par Exec=start-chrome.sh

REMARQUE : je pense que cette solution fonctionnera jusqu'à ce que vous mettiez à jour Google Chrome (via apt-get upgrade ) et que le fichier google-chrome.desktop soit écrasé. Vous devrez suivre l’étape 2 ci-dessus pour résoudre ce problème.

    
réponse donnée NHenderson 25.02.2015 - 05:07
la source
6

Vous pouvez essayer d'activer les événements tactiles sous les drapeaux Chrome:

  1. Accédez à chrome://flags/#touch-events et définissez-le sur activé
  2. Redémarrez Chrome

Source:

lien

    
réponse donnée Glutanimate 30.05.2014 - 17:53
la source

Lire d'autres questions sur les étiquettes