Sur Ubuntu 14.04 Centrino Wireless-N 1030 se déconnecte constamment

22

J'ai installé Ubuntu 14.04. Mon wifi se déconnecte de temps en temps et je dois l'éteindre puis le rallumer pour être à nouveau sans fil.

J'utilise Centrino Wireless-N 1030.

    
posée user275886 29.04.2014 - 16:37
la source

6 réponses

27

Assurez-vous également que la gestion de l’alimentation est désactivée.

iwconfig wlan0

devrait afficher une ligne avec Power Management: Off . S'il indique On , vous devez exécuter:

sudo iwconfig wlan0 power off
    
réponse donnée Dan Johansen 15.10.2014 - 14:37
la source
5

Il semble que cela soit dû au mode N du bogue du pilote, vous pouvez le désactiver, par exemple

modprobe -r iwlwifi && modprobe iwlwifi 11n_disable=1

Voir plus de détails ici et ici :

Btw Je suis passé de 12.10 à 14.04 et je faisais face à ce problème, mais une fois réinstallé, je ne vois pas ce problème.

    
réponse donnée Anurag Uniyal 02.05.2014 - 07:10
la source
3

J'avais le même problème. Utiliser modprobe pour désactiver les connexions rapides de type n et ac n'était pas une option car mon ordinateur portable est connecté à un réseau local et nécessite une vitesse réseau élevée.

Une mise à niveau du noyau de 3.13 à 3.18 a résolu le problème dans mon cas. Maintenant, en utilisant de manière fiable une connexion rapide "n" avec 300+ mbit / s (adaptateur wifi: Asus USB-53N, OS: Ubuntu 14.04.1). Plus de déconnexion: -)

    
réponse donnée UbuntuForever 27.12.2014 - 16:46
la source
2
sudo iwconfig wlan0 power off

Cela résout le problème temporairement.

Pour le rendre permanent, ajoutez un fichier de configuration:

cd /etc/pm/power.d
sudo -H gedit wifi_pwr_off

Cela ouvrira un fichier vide, copiez le code ci-dessous dedans:

#!/bin/sh 
/sbin/iwconfig wlan0 power off
  1. Enregistrez le fichier, n'oubliez pas de

    sudo chmod u+x wifi_pwr_off
    

    et redémarrer.

S'il vous plaît noter qu'au lieu de wlan0, il peut être wlan1 etc pour vous. Vous pouvez voir des interfaces avec ifconfig , par exemple.

    
réponse donnée rahul_kumar 28.03.2016 - 11:35
la source
1

Vous devrez peut-être désactiver le mode power_save dans iw car iwconfig est quelque peu déprécié. Exécutez la commande suivante:

sudo iw dev '$(iwgetid 2>/dev/null | grep -o "^\w*")' set power_save off

'$(iwgetid 2>/dev/null | grep -o "^\w*")' obtient le nom de votre appareil, wlan0 , wlan1 , etc., de sorte que vous n'avez pas besoin de le rechercher ou de le taper. Ceci est pratique à utiliser en tant qu'alias ou script.

Si vous connaissez le nom du périphérique, wlan0 par exemple, la commande suivante fait la même chose:

sudo iw dev wlan0 set power_save off
    
réponse donnée mchid 04.02.2016 - 03:18
la source
-1

Cela a fonctionné pour moi:

OPTION 1

sudo modprobe -r iwldvm #otherwise iwlwifi refuses to stop
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1
sudo modprobe iwldvm

OPTION 2

sudo modprobe -r iwldvm #otherwise iwlwifi refuses to stop
sudo modprobe -rv iwldvm
sudo modprobe iwldvm 11n_disable=1
sudo modprobe iwldvm
    
réponse donnée Fakhru_Yaya 12.07.2016 - 08:31
la source

Lire d'autres questions sur les étiquettes