Est-ce que Unity requiert des pilotes de carte graphique propriétaires?

22

J'ai compris que le bureau Unity de Natty utilise Compiz et nécessite donc un pilote de carte graphique prenant en charge les effets de composition. Est-ce que cela signifie que si je possède une carte ATI ou NVIDIA, je suis obligé d'installer un pilote propriétaire, car les pilotes Open Source de ces cartes ne prennent pas en charge Compiz?

    
posée Ralf Hersel 13.01.2011 - 22:54
la source

8 réponses

15

Je crois que Unity nécessite des graphiques 3D. Si un pilote ouvert peut le faire, vous n'avez pas besoin de pilotes propriétaires.

En regardant le statut des pilotes FLOSS Nouveau, vous auriez probablement besoin des pilotes propriétaires de NVIDIA. ils travaillent sur les fonctionnalités nécessaires.

    
réponse donnée txwikinger 13.01.2011 - 23:04
la source
11

Pour les utilisateurs d’anciens matériels ou ayant des problèmes de pilotes, la interface 2D Unity sera disponible en 11.04 (et dans un PPA pour 10.10)

réponse donnée Jorge Castro 14.01.2011 - 01:53
la source
4

J'ai une carte ATI, et Unity / Compiz fonctionne bien pour moi avec les pilotes ouverts dans natty, même si je suis sûr que cela dépend de l’état des pilotes de votre carte. Si votre carte est compatible avec les pilotes ouverts, elle devrait également prendre en charge l'unité.

Il existe une liste (extrêmement longue) de cartes ATI avec accélération 3D open-source sur lien

    
réponse donnée cscarney 17.01.2011 - 23:23
la source
3

Sur Maverick, je peux utiliser Nouveau pour ma carte graphique Nvidia et avoir des graphiques 3D; donc je crois que sur Natty, vous pourriez utiliser des pilotes open source si vous voulez ..

    
réponse donnée Martín Casco 14.01.2011 - 00:23
la source
3

La condition requise pour Unity est que le pilote graphique ait un support 3D.

Les cartes Nvidia nécessiteraient le pilote propriétaire car le pilote open source ne prend pas en charge la 3D.

J'ai un ordinateur portable avec le chipset Intel 945GM qui a des pilotes ouverts pour les graphiques. Il prend également en charge la 3D.

La réponse est - Unity a besoin d’un support 3D. Si votre carte est dotée d’un pilote FOSS prenant en charge la 3D, alors vous êtes bien, sinon vous devez installer des pilotes propriétaires

    
réponse donnée Manish Sinha 14.01.2011 - 00:23
la source
3

Actuellement, je lance Natty avec Unity 3D sur une carte Nvidia en utilisant les pilotes 3D FOSS expérimentaux fournis. En dehors de mes cartes, les ventilateurs ne tournent pas plus vite.

Si la qualité du pilote reste au moins la même, vous n'aurez pas besoin de carte d'identité pour les cartes Nvidia.

Le pilote nvidia-current ne prend pas encore en charge le nouveau Xorg.

    
réponse donnée Seth Hikari 23.02.2011 - 02:13
la source
0

En bref: Non.

J'ai entendu dire qu'il devrait y avoir une option de faible consommation (2D) avec Unity.

    
réponse donnée brews 17.01.2011 - 22:54
la source
0

La réponse est non: Compiz sera content tant que votre pilote free / libre / open source aura - même expérimental - le support de l’accélération 3D. Mon père a un boîtier AMD K7 avec GeForce2 MX 400 (nv11). Je viens de lancer une session live sur Natty et Compiz m'a gentiment montré tous les effets du bureau (le bouton "try Ubuntu" a bien choisi le bureau de Gnome de secours ...)

    
réponse donnée Jesse Zixi Zhang 12.08.2011 - 13:10
la source

Lire d'autres questions sur les étiquettes