Connexion aux partages Windows en utilisant Active Directory?

24

Après la mise à niveau de mon hôte vers la version 12.04, je ne peux plus me connecter aux partages Windows de mon réseau AD (Active Directory). J'ai pu le faire précédemment en utilisant 11.10. J'ai pensé que cela pourrait être un problème avec la mise à niveau, donc j'ai aplati ma boîte et réinstallé à partir de zéro et je ne peux toujours pas me connecter.

Lorsque j'utilise la commande Files> Connect to Server, je rencontre un problème de mot de passe constant lors de l'accès à un serveur Windows à l'aide d'un compte réseau en cours de fonctionnement.

J'ai vérifié les journaux sur la machine Windows pour voir s’il y avait des connexions défectueuses, mais il n’y en a pas. Pourtant, 12.04 me demande toujours mon mot de passe comme si mes identifiants étaient incorrects.

Des suggestions?

    
posée dotdawtdaught 09.05.2012 - 08:41
la source

10 réponses

15

C'est la syntaxe dans ce cas qui semble poser problème. Je peux vérifier que lorsque je tape le serveur et le domaine en minuscule avec mes informations d'identification, il ne se connecte pas.

Cependant ...

Lorsque je saisis le serveur et le domaine dans tous les fichiers CAPS avec mes informations d’identité, cela se passe très bien.

    
réponse donnée jamesmike87 21.05.2012 - 18:10
la source
3

J'avais le même problème de connexion aux partages Windows via nautilus. J'ai pu me connecter sans problème en montant des partages depuis la ligne de commande, mais ce n'est tout simplement pas aussi pratique.

Ce qui a été corrigé pour moi, c’est de taper mon domaine en majuscules. Le nom de domaine en minuscule ne se connectera jamais. Les majuscules se connectent à chaque fois. Bizarre.

    
réponse donnée mcmoyer 15.05.2012 - 17:14
la source
2

Eh bien, si vos deux machines sont connectées via un réseau local, vous devriez pouvoir accéder à votre machine Windows en utilisant l’option Browse Network de nautilus.

Lisez aussi lien

Ou essayez d'utiliser connect to server et utilisez le protocole de partage samba pour vous connecter

  

smb: // adresse-ip-de-machine-windows

    
réponse donnée Srinivas Gowda 09.05.2012 - 09:01
la source
2

C'est certainement quelque chose avec l'interface graphique, car j'avais le même problème, mais la méthode décrite dans lien a bien fonctionné - au moins, pour attacher à ma Buffalo TeraStation sur mon réseau local. Je ne peux pas dire si cela fonctionnera dans un environnement AD.

    
réponse donnée Ed Horch 11.05.2012 - 18:24
la source
1

J'ai dû utiliser un nom de domaine \\ notez le slash supplémentaire. si je faisais Alt-F2 et mettais smb: // Servername / sharename, je devais ajouter un \ avant le nom d'utilisateur.

    
réponse donnée jasonamyers 09.05.2012 - 21:58
la source
1

Cette réponse était dans un fil différent que je ne trouve pas pour le moment. Cela a fonctionné parfaitement et en permanence pour moi.

Dans /etc/samba/smb.conf , ajoutez ce qui suit au bas de la section [global] :

client lanman auth = yes
client ntlmv2 auth = no
    
réponse donnée nhorning 12.07.2012 - 07:58
la source
0

L’Active Directory (AD) est un peu plus complexe que le partage de samba.

lien

AD remplace les domaines Windows et dispose d’un serveur d’authentification. Ce n'est pas la même chose que les partages basés sur des groupes de travail qui ont juste besoin de cifs chargés et vous êtes dans.

    
réponse donnée gecko 09.05.2012 - 11:19
la source
0

Vous avez eu les mêmes problèmes, c’est-à-dire que vous pouviez vous connecter aux partages Windows sur les réseaux AD dans Lucid (10.04) mais pas dans Precise (12.04). Il semble que la syntaxe soit légèrement différente. J'ai accédé sans problème aux partages AD en parcourant le réseau dans Nautilus et en utilisant 'domain \ user' où 'domain' est peut-être le domaine de second niveau dans 'domain2.domain1.topleveldomain' (par exemple corp.mydomain.com) nom de domaine complet pour le domaine, puis le mot de passe. J'espère que ça aide.

OttoPilot.

    
réponse donnée OttoPilot 15.05.2012 - 07:48
la source
0

Afin de me reconnecter à mes partages Windows enregistrés dans 11.10 signets nautilus, je suis passé à l’élément de menu "modifier les signets" et à le modifier comme suit:

mon nom d'utilisateur et mon domaine ont été encodés dans le champ "Location" en tant que smb: // domain; nom d'utilisateur @ server / share / folder lorsqu'il vient d'être mis à niveau de 11.10 à 12.04.

J'ai changé pour smb: // domain% 5Cusername @ server / share / folder et, après avoir été invité à saisir mon mot de passe, je me suis connecté avec succès. Je suppose que c'est dans l'esprit de la réponse de Jasonmyers.

    
réponse donnée A.S. 15.05.2012 - 14:26
la source
0

Vous pouvez simplement saisir le chemin SMB dans l’outil de recherche Ubuntu (Alt + F4). Cela a fonctionné pour moi. Il suffit de taper smb: // nas-server / some-path pour qu'il se charge.

Référence: lien

    
réponse donnée pthurmond 09.05.2013 - 16:11
la source

Lire d'autres questions sur les étiquettes