Comment puis-je changer le dictionnaire par défaut de Firefox?

24

Il est temps que je demande à celui-ci. Firefox pense que je suis canadien.

Je n'ai absolument rien contre les Canadiens et leur orthographe est bien meilleure que celle des Américains, mais je n'épelle pas de spécialiste avec un z . Il y a d'autres problèmes similaires dans lesquels j'écris quelque chose et, soudain, le désaccord surgit.

Quoi qu’il en soit ... Comment peut-on définir la langue par défaut? Puis-je supprimer complètement English (Canada) ?

Quelques précisions sur les raisons pour lesquelles certaines de ces réponses ne me conviennent pas, mais pourraient convenir à quelqu'un d'autre:

  • Sélectionnez un autre dictionnaire dans Firefox en cliquant avec le bouton droit sur une zone de texte - Cela n’a pas eu lieu entre les sessions. Je quitterais Firefox en sirotant ma tasse de thé, je recommencerais et je serais à mi-chemin d'O Canada.

  • Supprimez le dictionnaire canadien de Firefox - Simple: je ne l'avais pas installé. Le seul pack de langue de dictionnaire que j'ai installé dans Firefox est GB.

Dans mon cas, j'avais en quelque sorte installé des paquets de dictionnaire pour en_CA et en_ZA. Je ne sais toujours pas pourquoi ou même comment cela a continué à remplacer la valeur par défaut de Firefox parce que j'ai aussi un paquet de dictionnaire en_GB à l'échelle du système. Très étrange. Package.

    
posée Oli 05.09.2012 - 12:58
la source

5 réponses

20

Firefox semble utiliser myspell/hunspell et lister /usr/share/myspell/dicts/ me montre les dictionnaires auxquels je peux utiliser les options:

$ ls -1 /usr/share/myspell/dicts/*.dic
/usr/share/myspell/dicts/en_CA.dic 
/usr/share/myspell/dicts/en_GB.dic
/usr/share/myspell/dicts/en_ZA.dic
...

Recherchez le nom de fichier du dictionnaire dans les packages installés:

$ dpkg -S /usr/share/myspell/dicts/en_CA.dic
hunspell-en-ca: /usr/share/myspell/dicts/en_CA.dic

Donc, avec le nom du package de langue canadienne, la solution consiste à le supprimer:

sudo apt-get remove hunspell-en-ca
    
réponse donnée Oli 05.09.2012 - 13:16
la source
2

Une réponse simple est de dire qu'un pack de langue est un Add-on .

  • Allez à Tools - & gt; Add-ons .
    Si vous utilisez Ubuntu 12.04 ou plus récent, vous pouvez utiliser Dash pour rechercher dans votre menu; Appuyez sur Alt , et commencez à taper Add-ons .

  • Après avoir ouvert le gestionnaire de modules complémentaires, cliquez sur l’onglet Languages dans le menu de gauche. Là, vous pouvez désactiver n'importe quelle langue.

  • Après avoir ajouté une langue, cliquez avec le bouton droit de la souris sur une zone de texte ou un champ de saisie (les champs de saisie Par défaut sont désactivés, vous devrez donc l'activer avant de passer à l'étape suivante. ).

  • Choisissez Language dans le menu contextuel et sélectionnez la langue souhaitée, et celle-ci deviendra votre langue par défaut jusqu'à ce que vous la changiez à nouveau.

P.S. En cliquant sur "Ajouter une langue" dans le menu contextuel, vous accéderez à une page contenant une liste de packs de dictionnaires de langues liés à leurs add-ons correspondants.

    
réponse donnée Dan 05.09.2012 - 13:16
la source
1
Le commentaire de

Insperatus mérite d’être une réponse complète. J'ai eu ce problème non seulement avec l'orthographe canadienne, mais parfois Firefox utilisait l'orthographe britannique ou australienne. Sous Ubuntu Linux, la suppression des dictionnaires du système pour l’anglais non américain corrige ce problème.

sudo apt-get remove myspell-en-au myspell-en-gb myspell-en-za hunspell-en-ca && sudo apt-get install myspell-en-us

Avant:

Après:

    
réponse donnée Stephen Ostermiller 04.12.2014 - 19:19
la source
0

Cliquez avec le bouton droit sur une zone de texte, assurez-vous que l'option Vérifier l'orthographe est cochée et choisissez le bon dictionnaire.

Puis, cliquez sur les extensions dans la page d’ajout, puis désactivez ou supprimez celle que vous ne voulez pas.

    
réponse donnée Mitch 05.09.2012 - 13:25
la source
0

J'ai eu ce problème pendant des mois, où je choisissais l'anglais comme langue de vérification orthographique, mais cela "oublierait" quand j'ai redémarré le navigateur.

J'ai vérifié mon menu Add-Ons - & gt; Dictionaries et je n'avais pas de liste pour "English (US)", même si c'est la langue par défaut. Je l'ai installé manuellement (à partir du site Web de Mozilla) et maintenant, lorsque je mets l'anglais comme langue de vérification orthographique, la préférence persiste.

En bout de ligne: si vous essayez de lui indiquer d’utiliser la langue de votre système comme valeur par défaut du correcteur orthographique, assurez-vous d’avoir au préalable un module complémentaire de dictionnaire.

    
réponse donnée Coderer 23.01.2015 - 11:56
la source

Lire d'autres questions sur les étiquettes